Bug 540218 - kernel crash during kms graphic boot on Intel GM4500 platform
kernel crash during kms graphic boot on Intel GM4500 platform
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-intel (Show other bugs)
12
All Linux
low Severity high
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
card_GM45
: Reopened, Triaged
: 540681 541332 541593 544205 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-11-22 14:37 EST by Mihai Harpau
Modified: 2010-02-03 18:29 EST (History)
14 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 540681 (view as bug list)
Environment:
Last Closed: 2010-02-03 18:29:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Xorg log of the current session (nomodeset) (51.18 KB, text/plain)
2009-11-25 14:15 EST, Robinson Maureira
no flags Details
Xorg log from laptop withnot nomodeset but transitions to X just fine (45.12 KB, text/plain)
2009-11-25 18:48 EST, Brad Scalio
no flags Details
test patch (1.76 KB, patch)
2009-11-26 07:46 EST, David Woodhouse
no flags Details | Diff

  None (edit)
Description Mihai Harpau 2009-11-22 14:37:36 EST
Description of problem:
Press ESC key during kms graphic boot on Intel GM4500 platform of DELL Latitude E5400 notebook

Nov 22 20:50:19 localhost kernel: BUG: unable to handle kernel NULL pointer dereference at 0000000000000008
Nov 22 20:50:19 localhost kernel: IP: [<ffffffffa00756c1>] intel_tv_mode_set+0x231/0x7c4 [i915]
Nov 22 20:50:19 localhost kernel: PGD 774a4067 PUD 774e9067 PMD 0 
Nov 22 20:50:19 localhost kernel: Oops: 0000 [#1] SMP 
Nov 22 20:50:19 localhost kernel: last sysfs file: /sys/devices/LNXSYSTM:00/device:00/PNP0C0A:00/power_supply/BAT0/voltage_now
Nov 22 20:50:19 localhost kernel: CPU 0 
Nov 22 20:50:19 localhost kernel: Modules linked in: ipt_MASQUERADE iptable_nat nf_nat rfcomm sco bridge stp llc bnep l2cap sunrpc xt_physdev ip6t_REJECT nf_conntrack_ipv6 ip6table_filter ip6_tables ipv6 cpufreq_ondemand acpi_cpufreq freq_table dm_multipath kvm_intel kvm uinput snd_hda_codec_intelhdmi snd_hda_codec_idt snd_hda_intel snd_hda_codec arc4 ecb iwlagn snd_hwdep snd_seq snd_seq_device iwlcore mac80211 snd_pcm snd_timer dell_laptop sdhci_pci btusb sdhci firewire_ohci snd tg3 firewire_core bluetooth mmc_core cfg80211 dcdbas joydev rfkill i2c_i801 wmi soundcore iTCO_wdt snd_page_alloc crc_itu_t iTCO_vendor_support yenta_socket rsrc_nonstatic i915 drm_kms_helper drm i2c_algo_bit i2c_core video output [last unloaded: microcode]
Nov 22 20:50:19 localhost kernel: Pid: 1471, comm: Xorg Not tainted 2.6.31.6-145.fc12.x86_64 #1 Latitude E5400                  
Nov 22 20:50:19 localhost kernel: RIP: 0010:[<ffffffffa00756c1>]  [<ffffffffa00756c1>] intel_tv_mode_set+0x231/0x7c4 [i915]
Nov 22 20:50:19 localhost kernel: RSP: 0018:ffff8800798c18a8  EFLAGS: 00010246
Nov 22 20:50:19 localhost kernel: RAX: 0000000000000000 RBX: ffff880037937000 RCX: 0000000000000000
Nov 22 20:50:19 localhost kernel: RDX: 0000000000000000 RSI: 0000000000000000 RDI: 000000000000000c
Nov 22 20:50:19 localhost kernel: RBP: ffff8800798c1948 R08: 00000000000001df R09: 0000000000000000
Nov 22 20:50:19 localhost kernel: R10: 0000000000000040 R11: 0000000000000000 R12: ffff8800378ad000
Nov 22 20:50:19 localhost kernel: R13: ffff8800772d13d8 R14: ffffffffa007c630 R15: 00000000000200c0
Nov 22 20:50:19 localhost kernel: FS:  00007f55b8fb97e0(0000) GS:ffff8800019bf000(0000) knlGS:0000000000000000
Nov 22 20:50:19 localhost kernel: CS:  0010 DS: 0000 ES: 0000 CR0: 000000008005003b
Nov 22 20:50:19 localhost kernel: CR2: 0000000000000008 CR3: 00000000798b7000 CR4: 00000000000426f0
Nov 22 20:50:19 localhost kernel: DR0: 0000000000000000 DR1: 0000000000000000 DR2: 0000000000000000
Nov 22 20:50:19 localhost kernel: DR3: 0000000000000000 DR6: 00000000ffff0ff0 DR7: 0000000000000400
Nov 22 20:50:19 localhost kernel: Process Xorg (pid: 1471, threadinfo ffff8800798c0000, task ffff8800774a9780)
Nov 22 20:50:19 localhost kernel: Stack:
Nov 22 20:50:19 localhost kernel: 0000034a378ad800 0000000c0000002c 0000000000000000 0000000000000000
Nov 22 20:50:19 localhost kernel: <0> 0000000000000000 ffff880000000000 0000002c0000000c ffff8800378ad800
Nov 22 20:50:19 localhost kernel: <0> 0000007a798c1948 0000000000000000 ffff880000000000 ffff880000000000
Nov 22 20:50:19 localhost kernel: Call Trace:
Nov 22 20:50:19 localhost kernel: [<ffffffffa00521f4>] drm_crtc_helper_set_mode+0x287/0x34e [drm_kms_helper]
Nov 22 20:50:19 localhost kernel: [<ffffffffa006ceda>] intel_get_load_detect_pipe+0x101/0x14a [i915]
Nov 22 20:50:19 localhost kernel: [<ffffffffa00764a6>] intel_tv_detect+0x8d/0x14d [i915]
Nov 22 20:50:19 localhost kernel: [<ffffffffa0052b8b>] drm_helper_probe_single_connector_modes+0xba/0x282 [drm_kms_helper]
Nov 22 20:50:19 localhost kernel: [<ffffffffa002fac8>] drm_mode_getconnector+0xf5/0x39a [drm]
Nov 22 20:50:19 localhost kernel: [<ffffffffa002f9d3>] ? drm_mode_getconnector+0x0/0x39a [drm]
Nov 22 20:50:19 localhost kernel: [<ffffffffa002521f>] drm_ioctl+0x237/0x2f4 [drm]
Nov 22 20:50:19 localhost kernel: [<ffffffff81108b29>] vfs_ioctl+0x6f/0x87
Nov 22 20:50:19 localhost kernel: [<ffffffff81109038>] do_vfs_ioctl+0x47b/0x4c1
Nov 22 20:50:19 localhost kernel: [<ffffffff811090d4>] sys_ioctl+0x56/0x79
Nov 22 20:50:19 localhost kernel: [<ffffffff810fcb6a>] ? sys_write+0x61/0x6e
Nov 22 20:50:19 localhost kernel: [<ffffffff81011cf2>] system_call_fastpath+0x16/0x1b
Nov 22 20:50:19 localhost kernel: Code: 0f 45 d3 45 8b 9e 8c 00 00 00 44 89 5d 88 41 89 d3 41 81 cb 00 00 00 20 83 7d 88 00 41 0f 45 d3 45 8b 9e 90 00 00 00 44 89 5d c8 <45> 8b 59 08 44 89 5d 8c 45 8b 5e 7c 44 89 5d bc 45 8b 9e 80 00 
Nov 22 20:50:19 localhost kernel: RIP  [<ffffffffa00756c1>] intel_tv_mode_set+0x231/0x7c4 [i915]
Nov 22 20:50:19 localhost kernel: RSP <ffff8800798c18a8>
Nov 22 20:50:19 localhost kernel: CR2: 0000000000000008
Nov 22 20:50:19 localhost kernel: ---[ end trace 4c59249044a60371 ]---

Version-Release number of selected component (if applicable):
kernel-2.6.31.5-127.fc12.x86_64
kernel-2.6.31.6-134.fc12.x86_64
kernel-2.6.31.6-145.fc12.x86_64
xorg-x11-drv-intel-2.9.1-1.fc12.x86_64

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
After that kernel bug system is not stuck but I could not use the Gnome desktop
Comment 1 Mihai Harpau 2009-11-22 14:40:29 EST
If I use the nomodeset kernel paramater the bug is happened again.
Comment 2 Mihai Harpau 2009-11-22 17:07:33 EST
It is happened again even if I upgrade notebook BIOS to a new version:

BUG: unable to handle kernel NULL pointer dereference at 0000000000000008
IP: [<ffffffffa00756c1>] intel_tv_mode_set+0x231/0x7c4 [i915]
PGD 66850067 PUD 65818067 PMD 0 
Oops: 0000 [#1] SMP 
last sysfs file: /sys/devices/virtual/net/virbr0/address
CPU 0 
Modules linked in: ipt_MASQUERADE iptable_nat nf_nat rfcomm sco bridge stp llc bnep l2cap sunrpc xt_physdev ip6t_REJECT nf_conntrack_ipv6 ip6table_filter ip6_tables ipv6 cpufreq_ondemand acpi_cpufreq freq_table dm_multipath kvm_intel kvm uinput snd_hda_codec_intelhdmi snd_hda_codec_idt snd_hda_intel arc4 snd_hda_codec ecb firewire_ohci iwlagn snd_hwdep firewire_core snd_seq iwlcore crc_itu_t dell_laptop dcdbas snd_seq_device snd_pcm wmi iTCO_wdt mac80211 cfg80211 i2c_i801 sdhci_pci sdhci tg3 mmc_core ricoh_mmc btusb snd_timer bluetooth snd soundcore iTCO_vendor_support joydev snd_page_alloc rfkill yenta_socket rsrc_nonstatic i915 drm_kms_helper drm i2c_algo_bit i2c_core video output [last unloaded: microcode]
Pid: 1573, comm: Xorg Not tainted 2.6.31.6-145.fc12.x86_64 #1 Latitude E5400                  
RIP: 0010:[<ffffffffa00756c1>]  [<ffffffffa00756c1>] intel_tv_mode_set+0x231/0x7c4 [i915]
RSP: 0018:ffff8800785998a8  EFLAGS: 00010246
RAX: 0000000000000000 RBX: ffff88003790e000 RCX: 0000000000000000
RDX: 0000000000000000 RSI: 0000000000000000 RDI: 000000000000000c
RBP: ffff880078599948 R08: 00000000000001df R09: 0000000000000000
R10: 0000000000000040 R11: 0000000000000000 R12: ffff88003780d000
R13: ffff8800776c13d8 R14: ffffffffa007c630 R15: 00000000000200c0
FS:  00007fc7080307e0(0000) GS:ffff8800019bf000(0000) knlGS:0000000000000000
CS:  0010 DS: 0000 ES: 0000 CR0: 000000008005003b
CR2: 00007f31609135e0 CR3: 000000006604f000 CR4: 00000000000426f0
DR0: 0000000000000000 DR1: 0000000000000000 DR2: 0000000000000000
DR3: 0000000000000000 DR6: 00000000ffff0ff0 DR7: 0000000000000400
Process Xorg (pid: 1573, threadinfo ffff880078598000, task ffff88007191de00)
Stack:
 0000034a3780d800 0000000c0000002c 0000000000000000 0000000000000000
<0> 0000000000000000 ffff880000000000 0000002c0000000c ffff88003780d800
<0> 0000007a78599948 0000000000000000 ffff880000000000 ffff880000000000
Call Trace:
 [<ffffffffa00521f4>] drm_crtc_helper_set_mode+0x287/0x34e [drm_kms_helper]
 [<ffffffffa006ceda>] intel_get_load_detect_pipe+0x101/0x14a [i915]
 [<ffffffffa00764a6>] intel_tv_detect+0x8d/0x14d [i915]
 [<ffffffffa0052b8b>] drm_helper_probe_single_connector_modes+0xba/0x282 [drm_kms_helper]
 [<ffffffffa002fac8>] drm_mode_getconnector+0xf5/0x39a [drm]
 [<ffffffffa002f9d3>] ? drm_mode_getconnector+0x0/0x39a [drm]
 [<ffffffffa002521f>] drm_ioctl+0x237/0x2f4 [drm]
 [<ffffffff81108b29>] vfs_ioctl+0x6f/0x87
 [<ffffffff81109038>] do_vfs_ioctl+0x47b/0x4c1
 [<ffffffff811090d4>] sys_ioctl+0x56/0x79
 [<ffffffff81011cf2>] system_call_fastpath+0x16/0x1b
Code: 0f 45 d3 45 8b 9e 8c 00 00 00 44 89 5d 88 41 89 d3 41 81 cb 00 00 00 20 83 7d 88 00 41 0f 45 d3 45 8b 9e 90 00 00 00 44 89 5d c8 <45> 8b 59 08 44 89 5d 8c 45 8b 5e 7c 44 89 5d bc 45 8b 9e 80 00 
RIP  [<ffffffffa00756c1>] intel_tv_mode_set+0x231/0x7c4 [i915]
 RSP <ffff8800785998a8>
CR2: 0000000000000008
---[ end trace a76b80ebc564ea9a ]---
Comment 3 Brad Scalio 2009-11-24 13:05:40 EST
Yeah I am experiencing the exact same problem on an HP 6930p laptop ... it appears to only happen when dracut builds with the video driver ... if you install the basic Fedora with "basic video driver support" then you get past this.
Comment 4 Brad Scalio 2009-11-24 13:28:13 EST
FYI --- also booting with nomodeset on the kernel line which disables KMS support in the DRM module gets past these issues as well ... so something is up with KMS/DRM
Comment 5 Mihai Harpau 2009-11-24 14:30:07 EST
Well in my case the nomodeset on the kernel line does not resolve the issue
Comment 6 Robinson Maureira 2009-11-25 06:55:22 EST
In my case "nomodeset" let me use X, but compiz crashes if I enable it. My machine is an HP 6730b laptop.

kernel-2.6.31.5-127.fc12.x86_64
kernel-2.6.31.6-134.fc12.x86_64
kernel-2.6.31.6-148.fc12.x86_64
xorg-x11-drv-intel-2.9.1-1.fc12.x86_64

Smolt profile at http://www.smolts.org/client/show/pub_484873bb-2045-4025-9f87-c221de679098
Comment 7 Brad Scalio 2009-11-25 08:55:09 EST
@RobinsonMaureira -- I have a 6930p and yes, compiz does crash if you use the Gnome compat pre-built F12 compiz.  What you can do if you want a compositing windows manager until the inherent problems are fixed (if ever) is use compiz-fusion or KDE.  KDE compositing is OK, and compiz-fusion works.  The errors I receive are:

Nov 24 21:44:07 localhost kernel: compiz[1779]: segfault at a928a0 ip 00a928a0 sp bfaa8f10 error 14 in libstartup-notification-1.so.0.0.0[aec000+9000]

@MihaiHarpau -- sorry to hear that, I noticed that the last sysfs call in your report is to the virtual bridge interface and KVM is loaded ... are you running virtualization?  What you can try is to remove the Virtaulization Group packages or reinstall without that option ... I also noticed issues when running KVM before the whole login problems started.
Comment 8 David Woodhouse 2009-11-25 09:32:12 EST
I see the same oops on HP6930p.

Mihai: Please attach the _full_ dmesg when you claim that 'nomodeset' doesn't fix the issue.
Comment 9 Brad Scalio 2009-11-25 11:19:47 EST
Just an FYI there is plenty online about the fix for intel_tv.c and the intel_tv_mode_set dereference ... in Fedora the i915 is responsible for this:

[root@hp-6930p i915]# strings -o i915.ko | grep intel_tv
 455170 intel_tv_detect_type

So perhaps this patch wasn't incorporated into this upstream kernel?
Comment 10 Mihai Harpau 2009-11-25 11:23:42 EST
Unfortunately I don't have any log that could show that 'nomodeset' case does not resolve the issue for me (maybe was a hard crash without any log I don't know).
Comment 11 Adam Williamson 2009-11-25 14:09:02 EST
We're assigning KMS bugs to the driver components for now, even though the code is technically in the kernel; it's easier for the interested devs to track this way. Re-assigning to xorg-x11-drv-intel and ajax.

Can we get a /var/log/Xorg.0.log from the working case (nomodeset)? It may contain something interesting I guess, and also gives me an easy way to tag this bug with the exact hardware in use (yes, I'm lazy :>)

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 12 Robinson Maureira 2009-11-25 14:15:01 EST
Created attachment 373815 [details]
Xorg log of the current session (nomodeset)

There you go.
Comment 13 Adam Williamson 2009-11-25 14:28:44 EST
Thanks.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 14 Brad Scalio 2009-11-25 15:09:31 EST
*** Bug 540681 has been marked as a duplicate of this bug. ***
Comment 15 Brad Scalio 2009-11-25 18:46:58 EST
So something that may help ... company order a few of the HP 6930p elitebook laptops, identical in every way ... one F12 install doesn't require nomodeset and can boot just fine, a second requires nomodeset otherwise X crashes hard with the same problems noted above.

I am attached the Xorg log from the laptop that doesn't require nomodeset in order to boot and startx.

Again, both laptops are identical, identical installs, and identical media used and options choosen, yet one requires nomodeset and the other does not!!
Comment 16 Brad Scalio 2009-11-25 18:48:37 EST
Created attachment 373881 [details]
Xorg log from laptop withnot nomodeset but transitions to X just fine

Again, this is the Xorg logfile from a laptop that doesn't require nomodeset, but should ;-) as other identical laptops with identical hardware and BIOSes require it otherwise X crashes hard during transition to kdm/gdm from plymouth
Comment 17 David Woodhouse 2009-11-26 07:46:16 EST
Created attachment 373990 [details]
test patch

This makes it work with a simple hack to avoid the oops, and highlights what's going wrong...

[drm] TV-20: set mode NTSC 480i 0
Set video_levels to tv_mode->composite_levels ffffffffa007cf78 from mode NTSC-M
[drm] TV-20: set mode NTSC 480i 0
Set video_levels to component_levels ffffffffa007ce28
[drm] TV-20: set mode NTSC 480i 0
Set video_levels to tv_mode->composite_levels (null) from mode 480p@59.94Hz
Eep, !video_levels
[drm] TV-20: set mode NTSC 480i 0
Set video_levels to tv_mode->composite_levels (null) from mode 480p@59.94Hz
Eep, !video_levels
[drm] TV-20: set mode NTSC 480i 0
Set video_levels to tv_mode->composite_levels (null) from mode 480p@59.94Hz
Eep, !video_levels
[drm] TV-20: set mode NTSC 480i 0
Set video_levels to tv_mode->composite_levels (null) from mode 480p@59.94Hz
Eep, !video_levels

The 480p@59.94Hz mode has the 'component_only' flag set.
Comment 18 David Woodhouse 2009-11-26 07:57:01 EST
[drm:drm_mode_getconnector], connector id 19:
[drm:drm_helper_probe_single_connector_modes], SVIDEO-1
[drm:intel_update_watermarks], plane A (pipe 0) clock: 107520
[drm:intel_update_watermarks], plane B (pipe 1) clock: 69290
[drm:drm_vblank_get], enabling vblank on crtc 0, ret: -22
[drm:intel_crtc_mode_set], Mode for pipe A:
[drm:drm_mode_debug_printmodeline], Modeline 0:"NTSC 480i" 0 107520 1280 1368 1496 1712 1024 1027 1034 1104 0x40 0x0
[drm:intel_crtc_mode_set], disabling CxSR downclocking
[drm:intel_pipe_set_base], No FB bound
[drm:intel_update_watermarks], plane A (pipe 0) clock: 107520
[drm:intel_update_watermarks], plane B (pipe 1) clock: 69290
[drm] TV-20: set mode NTSC 480i 0
Set video_levels to component_levels ffffffffa007ce28
[drm:intel_update_watermarks], plane A (pipe 0) clock: 107520
[drm:intel_update_watermarks], plane B (pipe 1) clock: 69290
[drm:intel_tv_detect_type], No TV connection detected
[drm:intel_update_watermarks], plane B (pipe 1) clock: 69290
[drm:drm_helper_probe_single_connector_modes], SVIDEO-1 is disconnected
[drm:drm_ioctl], pid=1446, cmd=0xc05064a7, nr=0xa7, dev 0xe200, auth=1
[drm:drm_mode_getconnector], connector id 19:
[drm:drm_helper_probe_single_connector_modes], SVIDEO-1
[drm:intel_update_watermarks], plane A (pipe 0) clock: 107520
[drm:intel_update_watermarks], plane B (pipe 1) clock: 69290
[drm:drm_vblank_get], enabling vblank on crtc 0, ret: -22
[drm:intel_crtc_mode_set], Mode for pipe A:
[drm:drm_mode_debug_printmodeline], Modeline 0:"NTSC 480i" 0 107520 1280 1368 1496 1712 1024 1027 1034 1104 0x40 0x0
[drm:intel_crtc_mode_set], disabling CxSR downclocking
[drm:intel_pipe_set_base], No FB bound
[drm:intel_update_watermarks], plane A (pipe 0) clock: 107520
[drm:intel_update_watermarks], plane B (pipe 1) clock: 69290
[drm] TV-20: set mode NTSC 480i 0
Set video_levels to tv_mode->composite_levels (null) from mode 480p@59.94Hz
Eep, !video_levels
[drm:intel_update_watermarks], plane A (pipe 0) clock: 107520
[drm:intel_update_watermarks], plane B (pipe 1) clock: 69290
[drm:intel_tv_detect_type], No TV connection detected
[drm:intel_update_watermarks], plane B (pipe 1) clock: 69290
[drm:drm_helper_probe_single_connector_modes], SVIDEO-1 is disconnected
[drm:drm_ioctl], pid=1446, cmd=0xc05064a7, nr=0xa7, dev 0xe200, auth=1
[drm:drm_mode_getconnector], connector id 5:
[drm:drm_helper_probe_single_connector_modes], VGA-1
Comment 19 Markus Mayer 2009-11-26 07:59:12 EST
*** Bug 541332 has been marked as a duplicate of this bug. ***
Comment 20 Adam Williamson 2009-11-26 11:33:30 EST
*** Bug 541593 has been marked as a duplicate of this bug. ***
Comment 21 David Woodhouse 2009-11-27 11:13:08 EST
Should be fixed in 2.6.31.6-152.fc12, building at http://koji.fedoraproject.org/koji/taskinfo?taskID=1834553
Comment 22 Robinson Maureira 2009-11-27 14:01:25 EST
It's working for me, I'm getting the usual "your BIOS is broken", but it doesn't crash at all.

@BradScalio: I tried compiz-fusion with no luck :-(
Comment 23 Agustin Barto 2009-11-27 14:19:16 EST
2.6.31.6-152.fc12 works for me, but Compiz crashes.
Comment 24 Robinson Maureira 2009-11-27 14:25:26 EST
That's another BZ (https://bugzilla.redhat.com/show_bug.cgi?id=539789)
Comment 25 Markus Mayer 2009-11-30 01:37:03 EST
2.6.31.6-152.fc12 works for me too. Compiz is also working. (https://bugzilla.redhat.com/show_bug.cgi?id=541332)
Comment 26 David Woodhouse 2009-11-30 18:57:06 EST
The 2.6.32 problem is reported upstream at
https://bugs.freedesktop.org/show_bug.cgi?id=25369
Comment 27 Mihai Harpau 2009-12-03 07:37:53 EST
After a few days of thorough testing I can confirm that kernel 2.6.31.6-152.fc12 completely fixed this bug. Many thanks!
Comment 28 Matěj Cepl 2009-12-03 11:01:24 EST
Thank you for letting us know.
Comment 29 Adam Williamson 2009-12-03 14:28:37 EST
matej, 152 has not even been submitted as an update candidate yet. we can't close the bug.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 30 Matěj Cepl 2009-12-03 17:00:32 EST
Right you are, I am sorry.
Comment 31 Matěj Cepl 2009-12-03 17:01:55 EST
but I guess we can call it modified, so, we don't have to be that much concerned with it.
Comment 32 ChrisStout42 2009-12-04 14:12:50 EST
I tried installing 152.  It didn't seem to solve it for me.  I still have to add nomodeset or the kernel crashes when it loads.
Comment 33 Derkjan de Haan 2009-12-16 14:16:44 EST
*** Bug 544205 has been marked as a duplicate of this bug. ***
Comment 34 Derkjan de Haan 2009-12-16 14:18:40 EST
It works a bit better now. I no longer get the Oops, but sometimes the system becomes very slow, with a jumpy mouse pointer, while logon screen is being displayed, and afterwards during login.

When I examine the logs later on, I notice that there are many (1000+)occurances of the line:

[drm] TV-21: set mode NTSC 480i 0

On normal boot, there about 10 lines like this, during a slow boot there are 1000+. This isn't really reproducible, it happens one in five times or so.

kernel is 2.6.31.6-166
Comment 35 Markus Mayer 2009-12-17 10:08:24 EST
Same problem as described in #34. No hdd or CPU activity during this.
Comment 36 Adam Williamson 2010-02-03 18:29:12 EST
We're well past the kernel update that fixed this issue, so we can close the bug now.

Note You need to log in before you can comment on or make changes to this bug.