Bug 540838 - New version 0.9.7.11 released
Summary: New version 0.9.7.11 released
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: qtiplot
Version: 13
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Chen Lei
QA Contact: Fedora Extras Quality Assurance
URL: http://soft.proindependent.com/qtiplo...
Whiteboard:
Depends On: 541207 560258
Blocks: 511688 517747
TreeView+ depends on / blocked
 
Reported: 2009-11-24 10:23 UTC by Chen Lei
Modified: 2010-08-16 12:59 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-06-27 19:05:01 UTC


Attachments (Terms of Use)

Description Chen Lei 2009-11-24 10:23:40 UTC
Upstream released new version, I suggest you consider updating it for F12.
The old version for F12 in the repo crashes every time when trying to plot a graph.
I think qtiplot is one of the best  plotting software in linux.

Comment 1 Ansgar Esztermann 2010-01-21 10:48:20 UTC
I have packaged the new version. You can find the .src.rpm here:
http://download.opensuse.org/repositories/home:/aeszter/Fedora_12/src/qtiplot-0.9.7.10-6.1.src.rpm

Right now, this is a multi-distro version, and it might take some work to get it to conform to all of Fedora's guidelines. 
Frank: If you would like to use my package as a starting point for the official version, feel free to contact me. I will answer any question I can.
If you are no longer interested in maintaining the package, I am willing to do that myself; this would be my first official Fedora package, though, so things might not progress as quickly as with a more experienced maintainer.

Comment 2 Chen Lei 2010-01-21 12:14:08 UTC
Hi Ansgar, the original qtiplot maintainer is unresponsive for nearly one year.
See http://www.opensubscriber.com/message/devel@lists.fedoraproject.org/13276315.html

I think you can post a new bugzilla report and take qtiplot if you will. 

I now work on packaging libs that qtiplot depends on such as muparser, liborigin2, libxls, QuaZIP and QTeXEngine. I can help you if you need any help since I also packaged qtiplot.

Comment 3 Chen Lei 2010-01-24 05:11:25 UTC
SRPM using static linked liborigin2 and QTeXEngine.
http://dl.dropbox.com/u/1338197/1/qtiplot.spec
http://dl.dropbox.com/u/1338197/1/qtiplot-0.9.7.11-1.fc12.src.rpm

Comment 4 Chen Lei 2010-01-28 11:28:00 UTC
Qtiplot-0.9.7.11-1 pushed to rawhide. 



PS: Ansgar, do you mind to maintain qtiplot for fedora with me?
You can find 
src.rpm from http://koji.fedoraproject.org/koji/buildinfo?buildID=153261
spec from http://cvs.fedoraproject.org/viewvc/rpms/qtiplot/devel/

Comment 5 Ansgar Esztermann 2010-02-02 15:55:53 UTC
(In reply to comment #4)
> Qtiplot-0.9.7.11-1 pushed to rawhide. 
> 
> PS: Ansgar, do you mind to maintain qtiplot for fedora with me?

I am certainly willing to help, but I would prefer to wait and see whether Bug #557424 straightens itself out.

Comment 6 Bug Zapper 2010-03-15 13:19:24 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 13 development cycle.
Changing version to '13'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping


Note You need to log in before you can comment on or make changes to this bug.