Bug 54127 - /usr/bin/licq has a race condition
Summary: /usr/bin/licq has a race condition
Status: CLOSED DUPLICATE of bug 55057
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: licq   
(Show other bugs)
Version: 7.3
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bernhard Rosenkraenzer
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-09-28 01:59 UTC by Sean Dilda
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-09-28 02:00:20 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Modified version of /usr/bin/licq (792 bytes, text/plain)
2001-09-28 02:00 UTC, Sean Dilda
no flags Details

Description Sean Dilda 2001-09-28 01:59:34 UTC
The /usr/bin/licq shell script does some ps | grep commands to see if
you're running kde or gnome.  Unfortunately, when you do that, sometimes
the grep command itself will show up in the ps list, and sometimes it
won't...usually it does.   this gives an example of it:

[agrajag@loiosh agrajag]$ ps auxww|grep foo
[agrajag@loiosh agrajag]$ ps auxww|grep foo
agrajag   1944  0.0  0.3  1728  596 pts/3    S    21:52   0:00 grep foo
[agrajag@loiosh agrajag]$ 

The main result of this problem is that those of us running gnome will tend
to get the qt version of licq running, even though we're running gnome and
have the proper packages installed.

In a minute I'll attach my modified version of /usr/bin/licq that pipes
ps's output through 'grep -v grep' before passing it through the final
grep.  This solved the problem for me.

Comment 1 Sean Dilda 2001-09-28 02:00:16 UTC
Created attachment 32839 [details]
Modified version of /usr/bin/licq

Comment 2 Bernhard Rosenkraenzer 2001-10-25 09:02:49 UTC

*** This bug has been marked as a duplicate of 55057 ***


Note You need to log in before you can comment on or make changes to this bug.