Bug 55057 - licq always uses KDE frontend
Summary: licq always uses KDE frontend
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: licq (Show other bugs)
(Show other bugs)
Version: 7.2
Hardware: i686 Linux
medium
medium
Target Milestone: ---
Assignee: Bernhard Rosenkraenzer
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
: 54127 (view as bug list)
Depends On: 55084
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-10-24 23:50 UTC by Damien Miller
Modified: 2007-04-18 16:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-11-12 14:07:32 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Damien Miller 2001-10-24 23:50:41 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.2.1) Gecko/20010901

Description of problem:
The /usr/bin/licq script always executes the KDE frontend, even if run
under GNOME

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Run licq from the GNOME menu
	

Actual Results:  The KDE frontend is started

Expected Results:  The GNOME frontend should have been started

Additional info:

I think the problem is that the /usr/bin/licq script tries to detect the
environment used by grepping the output of ps. Unfortunately the grep is
not specific enough and ends up matching itself: e.g:

ps auxwww | grep kdeinit

will always return:

djm       3266  0.0  0.2  1728  592 pts/3    S    09:46   0:00 grep kdeinit

And test as true in the if statement. Since KDE is tested for first, licq
will always use the KDE frontend.

Solution: make the grep more specific - e.g. "grep kde\\init"

Comment 1 Bernhard Rosenkraenzer 2001-10-25 09:02:44 UTC
*** Bug 54127 has been marked as a duplicate of this bug. ***

Comment 2 Bernhard Rosenkraenzer 2001-10-31 13:58:47 UTC
Fixed; can't build the fixed package in rawhide because of bug 55084 ATM,
though.

Comment 3 Bernhard Rosenkraenzer 2002-01-17 13:41:29 UTC
Fixed in 1.0.4-1


Note You need to log in before you can comment on or make changes to this bug.