Bug 541332 - Kerneloops when starting X
Summary: Kerneloops when starting X
Keywords:
Status: CLOSED DUPLICATE of bug 540218
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 12
Hardware: i686
OS: Linux
low
medium
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-11-25 14:56 UTC by Markus Mayer
Modified: 2009-11-26 12:59 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-11-26 12:59:12 UTC


Attachments (Terms of Use)

Description Markus Mayer 2009-11-25 14:56:20 UTC
Description of problem:

Kerneloops when starting X on my notebook (http://smolt.fedoraproject.org/client/show/?uuid=pub_23e62976-9946-4ab0-bf79-239333f52ea0).


BUG: unable to handle kernel NULL pointer dereference at 00000008
IP: [<f821bc1d>] intel_tv_mode_set+0x1fc/0x77e [i915]
*pdpt = 0000000031c8f001 *pde = 0000000079862067 
Oops: 0000 [#1] SMP 
last sysfs file: /sys/devices/pci0000:00/0000:00:1a.0/usb3/3-1/devnum
Modules linked in: ipt_MASQUERADE iptable_nat nf_nat rfcomm sco bridge stp llc bnep l2cap sunrpc xt_physdev ip6t_REJECT nf_conntrack_ipv6 ip6table_filter ip6_tables ipv6 cpufreq_ondemand acpi_cpufreq dm_multipath kvm_intel kvm uinput snd_hda_codec_analog snd_hda_intel snd_hda_codec arc4 snd_hwdep ecb snd_seq snd_seq_device iwlagn snd_pcm snd_timer iwlcore btusb snd mac80211 uvcvideo bluetooth soundcore ppdev videodev firewire_ohci firewire_core cfg80211 hp_accel parport_pc snd_page_alloc v4l1_compat lis3lv02d serio_raw iTCO_wdt rfkill tg3 parport iTCO_vendor_support crc_itu_t tpm_infineon joydev input_polldev wmi i915 drm_kms_helper drm i2c_algo_bit i2c_core video output [last unloaded: microcode]
Nov 24 15:54:15 localhost kernel: Pid: 1587, comm: plymouthd Not tainted (2.6.31.6-148.fc12.i686.PAE #1) HP Compaq 6530b (KU490ET#ABD)
Pid: 1587, comm: plymouthd Not tainted (2.6.31.6-148.fc12.i686.PAE #1) HP Compaq 6530b (KU490ET#ABD)
EIP: 0060:[<f821bc1d>] EFLAGS: 00010246 CPU: 1
EIP is at intel_tv_mode_set+0x1fc/0x77e [i915]
EAX: 00000000 EBX: f8221650 ECX: 00000000 EDX: 00000000
ESI: f693d000 EDI: 000200c0 EBP: f25bdb6c ESP: f25bdad8
DS: 007b ES: 007b FS: 00d8 GS: 00e0 SS: 0068
Process plymouthd (pid: 1587, ti=f25bc000 task=f5b23fc0 task.ti=f25bc000)
Stack:
00000000 ffffffdb 0001ffff 00000046 0000034a 0000002c 0000000c 00000000
 00000000 00000000 00000000 00000000 00000000 00000000 00000025 0000000c
 0000002c f6942800 f6945ab4 00000040 0000007a 00000000 00000000 00000000
Call Trace:
[<f8133f0d>] ? drm_crtc_helper_set_mode+0x2b0/0x377 [drm_kms_helper]
[<f8213f18>] ? intel_get_load_detect_pipe+0x100/0x141 [i915]
[<c05a165a>] ? number+0x124/0x204
[<f821c873>] ? intel_tv_detect+0x7d/0x12c [i915]
[<f813476e>] ? drm_helper_probe_single_connector_modes+0x9f/0x235 [drm_kms_helper]
[<f810e964>] ? drm_mode_getconnector+0xcd/0x2b4 [drm]
[<f8105a45>] ? drm_ioctl+0x205/0x2a8 [drm]
[<f810e897>] ? drm_mode_getconnector+0x0/0x2b4 [drm]
[<c04c64a7>] ? mem_cgroup_cache_charge+0x35/0xf2
[<c056cf59>] ? inode_has_perm+0x69/0x84
[<c04d349a>] ? vfs_ioctl+0x5c/0x76
[<c04c64a7>] ? mem_cgroup_cache_charge+0x35/0xf2
[<c04d39fa>] ? do_vfs_ioctl+0x498/0x4d6
[<c04c64a7>] ? mem_cgroup_cache_charge+0x35/0xf2
[<c056d2a1>] ? selinux_file_ioctl+0x43/0x46
[<c04c64a7>] ? mem_cgroup_cache_charge+0x35/0xf2
[<c04d3a7e>] ? sys_ioctl+0x46/0x66
[<c04c64a7>] ? mem_cgroup_cache_charge+0x35/0xf2
[<c0408f9b>] ? sysenter_do_call+0x12/0x28
[<c04c64a7>] ? mem_cgroup_cache_charge+0x35/0xf2
[<c04c64a7>] ? mem_cgroup_cache_charge+0x35/0xf2
Code: 4d f0 8b 8b 88 00 00 00 89 4d a0 8b 4d f0 81 c9 00 00 00 20 83 7d a0 00 0f 44 4d f0 89 4d f0 8b 4d dc 8b 93 8c 00 00 00 89 55 ec <8b> 49 08 89 4d a4 8b 53 78 89 55 d0 8b 4b 7c 89 fa 80 ce 0c 89 
EIP: [<f821bc1d>] intel_tv_mode_set+0x1fc/0x77e [i915] SS:ESP 0068:f25bdad8
CR2: 0000000000000008
---[ end trace 1d81aa6f2db523d0 ]---



Version-Release number of selected component (if applicable):
kernel-PAE-2.6.31.6-148.fc12.i686


How reproducible:


Steps to Reproduce:
1. Start with X enabled
  
Actual results:
A black screen. I can reboot my machine by pressing 'CTRL+ALT+F2', logging in as root and run 'shutdown -r now'. But while doing this there is still a black screen.

Expected results:
X should start.


Additional info:
Plymouth works fine. Booting into init 3 also works fine. Booting with 'nomodset' makes X working.

Comment 1 Markus Mayer 2009-11-26 12:59:12 UTC

*** This bug has been marked as a duplicate of bug 540218 ***


Note You need to log in before you can comment on or make changes to this bug.