Bug 541492 - ibus needs to support some xkb layout switching
ibus needs to support some xkb layout switching
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: ibus (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: fujiwara
Fedora Extras Quality Assurance
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-11-25 22:41 EST by Jens Petersen
Modified: 2010-10-08 08:38 EDT (History)
3 users (show)

See Also:
Fixed In Version: ibus-1.3.7-11.fc14
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-10-08 08:38:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
ibus Makefile.am, enginexkbc.py, main.py, varsxkbc.py, setup.ui (15.78 KB, patch)
2010-01-21 00:49 EST, fujiwara
no flags Details | Diff

  None (edit)
Description Jens Petersen 2009-11-25 22:41:25 EST
Description of problem:
Currently we have a mixture of xkb layout config and input methods
on the desktop: even some input methods maps are just made to
avoid xkb setting/configuration issues etc.  And there is a
gnome keyboard indicator/switcher applet for changing layout.
This makes for a confusing UX and UI.  If ibus could handle
this better it might even make sense to run ibus by default
for xkb switching too at least.
Comment 1 Peng Huang 2009-12-09 23:59:00 EST
http://koji.fedoraproject.org/koji/taskinfo?taskID=1863956
It is scratch build for ibus. The srpm is provided by Linpus Engineer. It supports switch xkb layout in ibus systray menu. Please try it.
Comment 2 fujiwara 2009-12-11 02:30:43 EST
OK, I'll check this asap.
However originally I thought another package ibus-xkb besides ibus.
Comment 3 fujiwara 2010-01-21 00:49:39 EST
Created attachment 385850 [details]
ibus Makefile.am, enginexkbc.py, main.py, varsxkbc.py, setup.ui

Another idea.
Comment 4 fujiwara 2010-02-04 03:28:20 EST
Integrating ibus-xkbc is ok however there is a design issue, which layer should be fixed. 
I'll back to GDM again to resolve the original issue.
Comment 5 Jens Petersen 2010-06-25 02:03:26 EDT
Reassigning - not sure if this still needs any more attention?
Comment 6 fujiwara 2010-07-29 02:21:40 EDT
> http://github.com/phuang/ibus/commit/02ea48ca5df2818fc467805cfe612a23632ed79f#commitcomment-119162

Yesterday I saw a commit in a branch.
I'd suggest not to integrate this patch in master. It has many critical problems.
I think the xkb settings should be in the engine only.
I applied the patch:
http://github.com/fujiwarat/ibus-xkb-layouts/commit/ec7d8097ad8e047b2cf5f54922080659f6f9e6f0

Also it's better to disable global input method by default.
Now I'm thinking to integrate ibus-xkb-layouts in Fedora.
Comment 7 fujiwara 2010-07-29 22:00:31 EDT
Yesterday I talked with james.su.
He thinks IMs and layouts should be consolidated and currently no plan to release ibus-xkb-layouts.
I suggested to remove his patch from the branch since I pretty sure it's a wrong patch but not sure.
His bad way is to set 'us' layout forcibly and use IBusEngineDesc.layout in case of use_system_layout.

He suggested Mac OS X has the better implementation, interested.

But currently there are no European keyboards even though IBus will can handle XKB.
I would think it's an idea to use ibus-xkb-layouts for European keyboards but he pointed my approach was also wrong. Using Ctrl + Space is wrong and an engine should have the fixed layout.
Probably I need to work on this to provide the better patch.
Comment 8 Fedora Admin XMLRPC Client 2010-08-02 02:17:38 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 9 fujiwara 2010-08-10 21:15:48 EDT
Added libxklavier feature.
http://github.com/fujiwarat/ibus/commit/38b18273b2d2856ace1d0697470b71e0bc24d0e6

After talked with the maintainer, I'll separate the library dependencies to another binaries.
Comment 11 fujiwara 2010-08-15 21:35:03 EDT
Updated GUI to change the default xkb layout:
http://github.com/fujiwarat/ibus/commit/728652f0b730f4e7b279703437fc37fb75ed174a
Comment 12 fujiwara 2010-08-17 03:47:30 EDT
Updated default loaded layouts to check ~/.config/ibus/xkb/xkblayoutconfig.xml in observed-paths.
http://github.com/fujiwarat/ibus/commit/805bda5bcb3011aaeb7bceadfada454572384e07
Comment 13 fujiwara 2010-08-18 22:33:50 EDT
Created scratch build for f13:
http://koji.fedoraproject.org/koji/taskinfo?taskID=2410753

Today's gcc is old for f14/f15:
http://koji.fedoraproject.org/koji/taskinfo?taskID=2410639
Comment 14 fujiwara 2010-08-26 02:26:02 EDT
Rebuild the scratch build with this feature for f13:
http://koji.fedoraproject.org/koji/taskinfo?taskID=2427951

It includes the fix of bug 627107.

Now this feature is available in f14 and f15.
Comment 18 fujiwara 2010-09-03 05:46:50 EDT
Rebased patch:
http://github.com/fujiwarat/ibus/commit/497be0589fad9336f737c945d5b19a62c0acbf71

Minor chages:
 - Layout typo: s/ar/ara/
 - Moved "Cofigure Layout" button on ibus-setup to "Advanced" tab

http://koji.fedoraproject.org/koji/taskinfo?taskID=2444991
Comment 20 Fedora Update System 2010-09-14 07:54:17 EDT
ibus-1.3.7-5.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/ibus-1.3.7-5.fc14
Comment 21 fujiwara 2010-09-14 07:56:57 EDT
Revised the patch to support xkb variant and option
http://github.com/fujiwarat/ibus/commit/21ebb5e408f048561d845231062165bf154fde8e
Comment 22 Fedora Update System 2010-09-15 23:44:48 EDT
ibus-1.3.7-5.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 23 fujiwara 2010-10-05 06:35:27 EDT
Revised the patch:
http://github.com/fujiwarat/ibus/commit/27d62755adfa03c11380414b63d8daa239dda905

 - Fixed a bug when changed the system layout "jp(kana)" to "jp".
 - Redesigned xkb setting dialog
 - Applied 37ed695bfcaa764c6fd80d4f3d29f3df9032f83f
 - Removed "cn,kr,jp" from the default layouts in input methods.
 - Support group layouts in the system layouts.
 - Put "jp(kana)" into non-latin layouts. i.e. "jp(kana),us"
 - Customize the title in ibus.EngineCombobox and ibus.EngineTreeView.
Comment 24 fujiwara 2010-10-06 00:31:35 EDT
Trimmed spaces:
http://github.com/fujiwarat/ibus/commit/17b05fd6597298a2b54dd16b7a7498d4f816fdad

F13 scratch build:
http://koji.fedoraproject.org/koji/taskinfo?taskID=2516980

I integrated the latest patch in rawhide.

Currently f14 has a build problem in gtk3:
https://admin.fedoraproject.org/updates/glib2-2.26.0-2.fc14
Comment 25 Fedora Update System 2010-10-07 03:35:08 EDT
ibus-1.3.7-11.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/ibus-1.3.7-11.fc14
Comment 26 Fedora Update System 2010-10-07 15:53:34 EDT
ibus-1.3.7-11.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update ibus'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/ibus-1.3.7-11.fc14
Comment 27 Fedora Update System 2010-10-08 08:38:35 EDT
ibus-1.3.7-11.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.