Bug 628161 - Compose seems not to be working with ibus-1.3.7
Summary: Compose seems not to be working with ibus-1.3.7
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: ibus
Version: 14
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: fujiwara
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 628024 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-08-28 10:31 UTC by Jens Petersen
Modified: 2010-09-01 05:46 UTC (History)
4 users (show)

Fixed In Version: ibus-1.3.7-3.fc14
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-09-01 05:46:17 UTC


Attachments (Terms of Use)

Description Jens Petersen 2010-08-28 10:31:33 UTC
Description of problem:
X Compose of keys seems not to be working with ibus-1.3.7 in F14.

Steps to Reproduce:
1. setup Compose key (Multi_key) in
   gnome-keyboard-properties -> Layouts -> Options -> Compose key position
   (eg Right Alt)
2. make sure ibus is running as input-method in im-chooser
3. start gedit
4. type some standard compose sequences:
- Compose ` e
- Compose ^ a
- Compose a e
- Compose " u
  
Actual results:
e
a
e
u

Expected results:
è
â
æ
ü
(typed with Compose using ibus-1.3.6 in F13 :)

Comment 1 Mamoru TASAKA 2010-08-28 11:39:40 UTC
Maybe I am seeing the different effect on bug 628024?

Comment 2 fujiwara 2010-08-30 02:03:14 UTC
*** Bug 628024 has been marked as a duplicate of this bug. ***

Comment 3 fujiwara 2010-08-30 02:11:59 UTC
Probably the right fix is to implement XKB model and options in ibus-xkb.
But I fix the default layout only for the critical issue at the moment.

Comment 5 Fedora Update System 2010-08-30 02:38:52 UTC
ibus-1.3.7-3.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/ibus-1.3.7-3.fc14

Comment 6 Jens Petersen 2010-08-31 02:11:10 UTC
Thanks looks good to me now.

Comment 7 Fedora Update System 2010-09-01 05:46:13 UTC
ibus-1.3.7-3.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.