Bug 541966 - Occasional crash on vm shutdown/reboot
Occasional crash on vm shutdown/reboot
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: libvirt (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Daniel Veillard
Fedora Extras Quality Assurance
: Triaged
: 546589 (view as bug list)
Depends On:
Blocks: F13VirtTarget
  Show dependency treegraph
 
Reported: 2009-11-27 13:08 EST by Yanko Kaneti
Modified: 2010-02-11 09:52 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-02-11 09:52:26 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
gdb bt full (30.80 KB, text/plain)
2009-11-27 13:08 EST, Yanko Kaneti
no flags Details

  None (edit)
Description Yanko Kaneti 2009-11-27 13:08:37 EST
Created attachment 374282 [details]
gdb bt full

using virt-manager to start then shutdown a vm repeatedly. (newly installed F12 x86_64 in this case)
at the end of one of these shutdowns libvirtd will crash with the attached backtrace.

Version-Release number of selected component (if applicable):
libvirt-0.7.4-1.fc13.x86_64

How reproducible:
Not immediately on the first or consecquent vm shutdowns but always
Comment 1 Yanko Kaneti 2009-11-27 13:13:31 EST
qemu-kvm-0.11.0-12.fc13.x86_64
virt-manager-0.8.0-8.fc13.noarch
virt-viewer-0.2.0-1.fc12.x86_64

running under kernel-2.6.31.6-150.fc12.x86_64
Comment 2 Justin M. Forbes 2009-12-01 11:55:42 EST
Thanks, interesting find.  What does the libvirt memory footprint look like prior to crash?
Comment 3 Paul Jenner 2009-12-05 14:47:13 EST
For the benefit of others who find this bug, there is more information in a post to the libvirt mailing-list here:

https://www.redhat.com/archives/libvir-list/2009-December/msg00064.html
Comment 5 Paul Jenner 2010-02-05 16:40:56 EST
Does this still happen with latest F12+virt-preview (or rawhide) libvirt packages? This should be fixed in latest libvirt.
Comment 6 Daniel Berrange 2010-02-11 09:52:26 EST
The patches from comment #4 are not in rawhide
Comment 7 Daniel Berrange 2010-02-11 09:52:44 EST
*** Bug 546589 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.