Bug 541986 - Wine -- winecfg crashes clicking the Audio tab when wine-{alsa,pulseaudio,oss} are installed
Wine -- winecfg crashes clicking the Audio tab when wine-{alsa,pulseaudio,oss...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: wine (Show other bugs)
12
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Andreas Bierfert
Fedora Extras Quality Assurance
:
: 585423 591711 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-11-27 15:26 EST by Gian Paolo Mureddu
Modified: 2010-07-22 22:49 EDT (History)
8 users (show)

See Also:
Fixed In Version: wine-1.2.0-1.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-22 22:44:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Gian Paolo Mureddu 2009-11-27 15:26:09 EST
Description of problem:
The winecfg component of Wine in x86_64 installations of Wine crashes when the Audio tab is clicked and any of the audio controllers (drivers) are installed (wine-alsa, wine-pulseaudio, wine-oss), wine-openal does not cause this (but apparently it is not a "driver" as such). When launching winecfg from the console there is output from apparently random memory addresses, but not a formal backtrace as such.

Version-Release number of selected component (if applicable):
wine-core-1.1.32
wine-common-1.1.32
wine-alsa-1.1.32 || wine-pulseaudio-1.1.32 || wine-oss-1.1.32

How reproducible:
Always

Steps to Reproduce:
1. Install wine-common, wine-core and any of the audio controllers.
2. Open winecfg to try to setup an audio device.
3. See the Windows-like dialog box appear of winedbg entering an infinite loop.
  
Actual results:
The winecfg tool crashes when trying to setup an audio device for Wine.

Expected results:
To be able to configure an audio device for Wine.
Comment 1 Phip 2009-12-02 23:38:10 EST
This is a duplicate of #522941 -- first section.

Also, from Comment 3 there: 
This is a bug in 64bit wine. See http://bugs.winehq.org/show_bug.cgi?id=19316. To run the 32bit winecfg type
'wine32 winecfg'

BUT, based on comments I read on the winehq link ("Wine compiled as 64-bit is highly experiential and won't run anything other then 64-bit code."), I decided to 'yum remove wine-*.x86_64' and would recommend the same to anyone having this problem and not explicitly using 64-bit windows programs. Now winecfg works correctly without having to use wine32.
Comment 2 Michael Wiktowy 2010-02-19 15:12:44 EST
I was experiencing this problem and running 'wine32 winecfg' worked in version 1.1.29. However, doing so in 1.1.38 doesn't run winecfg at all and my windows app (Pokerstars) does not run either. This started at 1.1.36 and continues with version 1.1.38 so some broader problem is present.
Comment 3 Andreas Bierfert 2010-04-25 17:38:21 EDT
*** Bug 585423 has been marked as a duplicate of this bug. ***
Comment 4 Andreas Bierfert 2010-05-12 17:21:22 EDT
*** Bug 591711 has been marked as a duplicate of this bug. ***
Comment 5 Fedora Update System 2010-06-19 05:03:10 EDT
wine-1.2.0-0.4.rc4.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/wine-1.2.0-0.4.rc4.fc12
Comment 6 Fedora Update System 2010-06-19 05:04:53 EDT
wine-1.2.0-0.4.rc4.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/wine-1.2.0-0.4.rc4.fc13
Comment 7 Fedora Update System 2010-06-21 17:27:34 EDT
wine-1.2.0-0.4.rc4.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update wine'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/wine-1.2.0-0.4.rc4.fc13
Comment 8 Michael Cronenworth 2010-06-25 15:40:09 EDT
This does seem to be fixed with wine-1.2.0-0.4.rc4.fc13. Thanks.
Comment 9 Fedora Update System 2010-07-06 13:14:48 EDT
wine-1.2.0-0.6.rc6.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update wine'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/wine-1.2.0-0.6.rc6.fc13
Comment 10 Fedora Update System 2010-07-13 03:55:26 EDT
wine-1.2.0-0.7.rc7.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update wine'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/wine-1.2.0-0.7.rc7.fc13
Comment 11 Fedora Update System 2010-07-22 22:44:19 EDT
wine-1.2.0-1.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 12 Fedora Update System 2010-07-22 22:49:22 EDT
wine-1.2.0-1.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.