Bug 542107 - package-cleanup has an UTF-8 problem if LANG=de_DE.UTF-8
package-cleanup has an UTF-8 problem if LANG=de_DE.UTF-8
Status: CLOSED DUPLICATE of bug 543410
Product: Fedora
Classification: Fedora
Component: yum-utils (Show other bugs)
12
All Linux
low Severity low
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-11-28 06:40 EST by Peter Bieringer
Modified: 2014-01-21 18:12 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-01-12 16:00:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Peter Bieringer 2009-11-28 06:40:42 EST
Description of problem:

# package-cleanup 
Geladene Plugins: dellsysidplugin2, fastestmirror, refresh-packagekit
Traceback (most recent call last):
  File "/usr/bin/package-cleanup", line 382, in <module>
    util = PackageCleanup()
  File "/usr/bin/package-cleanup", line 58, in __init__
    self.main()
  File "/usr/bin/package-cleanup", line 302, in main
    self.optparser.print_help()
  File "/usr/lib/python2.6/optparse.py", line 1651, in print_help
    file.write(self.format_help().encode(encoding, "replace"))
  File "/usr/lib/python2.6/codecs.py", line 351, in write
    data, consumed = self.encode(object, self.errors)
UnicodeDecodeError: 'ascii' codec can't decode byte 0xc3 in position 1626: ordinal not in range(128)


Version-Release number of selected component (if applicable):
yum-utils-1.1.24-2.fc12.noarch

How reproducible:
See above.


Additional info:

Workaround:
LANG=C package-cleanup
Comment 1 seth vidal 2010-01-12 16:00:27 EST

*** This bug has been marked as a duplicate of bug 543410 ***

Note You need to log in before you can comment on or make changes to this bug.