This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 543410 - Locales are breaking package-cleanup tool
Locales are breaking package-cleanup tool
Status: CLOSED DUPLICATE of bug 560369
Product: Fedora
Classification: Fedora
Component: yum-utils (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
: 542107 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-12-02 06:00 EST by Zdenek Kabelac
Modified: 2014-01-21 18:12 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-02-01 15:38:07 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Zdenek Kabelac 2009-12-02 06:00:47 EST
Description of problem:

package-cleanup doesn't work with Czech locales.

# LANG=cs_CZ.UTF-8 package-cleanup 
Zavedeny zásuvné moduly:dellsysidplugin2, priorities, refresh-packagekit, refresh-updatesd
Traceback (most recent call last):
  File "/usr/bin/package-cleanup", line 382, in <module>
    util = PackageCleanup()
  File "/usr/bin/package-cleanup", line 58, in __init__
    self.main()
  File "/usr/bin/package-cleanup", line 302, in main
    self.optparser.print_help()
  File "/usr/lib64/python2.6/optparse.py", line 1664, in print_help
    file.write(self.format_help().encode(encoding, "replace"))
  File "/usr/lib64/python2.6/codecs.py", line 351, in write
    data, consumed = self.encode(object, self.errors)
UnicodeDecodeError: 'ascii' codec can't decode byte 0xc5 in position 188: ordinal not in range(128)


However works without problems with plain C locales:

Loaded plugins: dellsysidplugin2, priorities, refresh-packagekit, refresh-
              : updatesd
Usage: 
    package-cleanup: helps find problems in the rpmdb of system and correct them

    usage: package-cleanup --problems or --leaves or --orphans or --oldkernels
    
....


Version-Release number of selected component (if applicable):

yum-utils-1.1.24-2.fc13.noarch


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Christoph Wickert 2010-01-10 11:26:32 EST
Same here with de_DE.utf8
Comment 2 seth vidal 2010-01-12 16:00:27 EST
*** Bug 542107 has been marked as a duplicate of this bug. ***
Comment 3 Tim Lauridsen 2010-02-01 15:38:07 EST

*** This bug has been marked as a duplicate of bug 560369 ***

Note You need to log in before you can comment on or make changes to this bug.