Bug 54219 - segmentation fault with gnorpm
Summary: segmentation fault with gnorpm
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: gnorpm   
(Show other bugs)
Version: 7.2
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Alexander Larsson
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
: 54776 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-10-01 21:44 UTC by David Lawrence
Modified: 2007-04-18 16:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-01-22 21:28:32 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description David Lawrence 2001-10-01 21:44:46 UTC
Description of Problem:
Segmentation fault doing the following:

1. Click Operations->Find
2. Choose provide in the drop down for find packages that.
3. Enter sendmail or other package name in the text box and click find.
4. Highlight the result and click Query.
5. You get a blank window called Package Information.
6. If you try to verify the package instead of querying it generates
a segmentation fault dialog box.

This occurs on the i386 platform for Enigma also.

Strace output:

open("/var/lib/rpm/Packages", O_RDONLY) = 6
fcntl(6, F_SETFD, FD_CLOEXEC)           = 0
SYS_1212(0x6, 0x80000fffffff8f00, 0x80000fffffff8e78, 0x2000000001801f68,
0x2000000000eae8d0, 0xc00000000000030b, 0x80000fffffff8e20,
0x2000000000f03458) = 0
lseek(6, 0, SEEK_SET)                   = 0
read(6, "\0\0\0\0\1\0\0\0\0\0\0\0a\25\6\0\7\0\0\0\0@\0\0\0\10\0"..., 256) = 256
close(6)                                = 0
open("/var/lib/rpm/Packages", O_RDONLY) = 6
fcntl(6, F_SETFD, FD_CLOEXEC)           = 0
SYS_1212(0x6, 0x80000fffffff8fc0, 0xc00000000000038c, 0x6, 0x2, 0x1,
0x2000000000eae720, 0xc00000000000038c) = 0
pread(6, "\0\0\0\0\1\0\0\0\317\1\0\0\0\0\0\0\0\0\0\0\"\0\0060\0\2"...,
16384, 7585792) = 16384
--- SIGSEGV (Segmentation fault) ---
write(3, "\2\2\4\0006\3\340\1\2\0\0\0\272\326\0\0\f\0\4\0006\3\340"...,
1292) = 1292
read(3, "\26\0008%\32\3\340\1\32\3\340\1\265\2\340\1\0\0\0\0h\1"..., 32) = 32
read(3, 0x80000fffffff8fa0, 32)         = -1 EAGAIN (Resource temporarily
unavailable)
select(4, [3], NULL, NULL, NULL)        = 1 (in [3])
read(3, "\23\3;%6\3\340\0016\3\340\1\0\217\v\10\320\233\326\010"..., 32) = 32

Version-Release number of selected component (if applicable):
gnorpm-0.96-11

Comment 1 Alexander Larsson 2001-10-02 14:43:37 UTC
Hmmm. It seems to happen with other (all?) packages too.


Comment 2 Alexander Larsson 2001-10-02 15:07:18 UTC
This has been fixed in the latest CVS. I will talk to the maintainers and see
when a new version is gonna be released.


Comment 3 Mike A. Harris 2001-10-23 10:25:15 UTC
This occurs on s390 as well.  Changing arch to All.

[root@rawhide zod_was_here]# rpm -q gnorpm
gnorpm-0.96-11

Comment 4 Mike A. Harris 2001-10-23 10:32:05 UTC
*** Bug 54776 has been marked as a duplicate of this bug. ***

Comment 5 R.K.Aa. 2002-01-19 06:10:22 UTC
Same problem on RH7.1/gnorpm 0.96-1. Is there any movement here?

Comment 6 Alexander Larsson 2002-01-22 21:28:27 UTC
I sent a mail to the maintainer asking for a new release.


Comment 7 Alexander Larsson 2002-07-23 16:07:54 UTC
Gnorpm has been deprecated for the next version of RedHat. It will be replaced
with a package called redhat-config-packages.


Comment 8 Rick Richardson 2002-10-16 09:06:12 UTC
When a user selects "upgrade software" in my application, it would fetch the new
RPM for him from my web site and then fire off a "gnorpm-auth -qp
/tmp/newversion.rpm" to perform the actual update.

Now, in RH 8.0, I find that the gnorpm command is gone.  But it does not appear
to me that the replacement package, redhat-config-packages, has the same ability
to graphically install/upgrade a package from a file.

There is no manual page for redhat-config-packages (shouldn't *everything* in
/usr/bin have a man page?), so maybe the functionality is there, just not
documented.

Could you please comment on how to achieve the same gnorpm functionality in RH
8.0?

Thank you.

Comment 9 Alexander Larsson 2002-10-16 12:12:28 UTC
rickr: use redhat-install-packages


Note You need to log in before you can comment on or make changes to this bug.