Bug 542220 - package-cleanup --problems broken on F12
package-cleanup --problems broken on F12
Status: CLOSED DUPLICATE of bug 541551
Product: Fedora
Classification: Fedora
Component: yum-utils (Show other bugs)
12
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-11-28 17:30 EST by alexp
Modified: 2014-01-21 18:12 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-12-01 10:16:48 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
my current /var/lib/rpm/Packages file, compressed to .gz (43 bytes, text/plain)
2009-11-30 22:00 EST, alexp
no flags Details

  None (edit)
Description alexp 2009-11-28 17:30:03 EST
Description of problem:

Running package-cleanup --problems causes Python error

Version-Release number of selected component (if applicable):

1.1.24-2.fc12

How reproducible:

always

Steps to Reproduce:
1. run package-cleanup --problems 
2.
3.
  
Actual results:

Loaded plugins: dellsysidplugin2, presto, refresh-packagekit, refresh-updatesd
Traceback (most recent call last):
  File "/usr/bin/package-cleanup", line 382, in <module>
    util = PackageCleanup()
  File "/usr/bin/package-cleanup", line 58, in __init__
    self.main()
  File "/usr/bin/package-cleanup", line 309, in main
    issues = self._find_missing_deps(self.rpmdb.returnPackages())
  File "/usr/bin/package-cleanup", line 137, in _find_missing_deps
    missing = miscutils.formatRequire(req,ver,flags)
  File "/usr/lib/python2.6/site-packages/rpmUtils/miscutils.py", line 350, in formatRequire
    rpm.RPMSENSE_EQUAL):
TypeError: unsupported operand type(s) for &: 'str' and 'int'

Expected results:

A report about problem packages

Additional info:
Comment 1 seth vidal 2009-11-30 15:20:43 EST
does this happen everytime for you?
Comment 2 alexp 2009-11-30 16:20:07 EST
Yes, every time. I just upgraded my machine from F11 to F12 2 days ago.
Comment 3 seth vidal 2009-11-30 16:26:19 EST
since SOMEthing in there is the source of the problem - can you attach your /var/lib/rpm/Packages file so I can sift it out a bit?

Compressing the file would be good.

thanks
Comment 4 alexp 2009-11-30 22:00:47 EST
Created attachment 374949 [details]
my current /var/lib/rpm/Packages file, compressed to .gz
Comment 5 James Antill 2009-12-01 10:16:48 EST

*** This bug has been marked as a duplicate of bug 541551 ***

Note You need to log in before you can comment on or make changes to this bug.