Bug 541551 - package-cleanup: unsupported operand type(s) for &: 'str' and 'int'
package-cleanup: unsupported operand type(s) for &: 'str' and 'int'
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: yum-utils (Show other bugs)
12
All Linux
low Severity medium
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
: 539580 542220 558797 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-11-26 05:06 EST by Sebastian Vahl
Modified: 2014-01-21 18:12 EST (History)
8 users (show)

See Also:
Fixed In Version: 1.1.25-1.fc12
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-12-01 13:00:00 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Sebastian Vahl 2009-11-26 05:06:12 EST
Description of problem:
"package-cleanup --problems" fails with this traceback:

Loaded plugins: dellsysidplugin2, fastestmirror, presto, refresh-packagekit, upgrade-helper, versionlock
Traceback (most recent call last):
  File "/usr/bin/package-cleanup", line 382, in <module>
    util = PackageCleanup()
  File "/usr/bin/package-cleanup", line 58, in __init__
    self.main()
  File "/usr/bin/package-cleanup", line 309, in main
    issues = self._find_missing_deps(self.rpmdb.returnPackages())
  File "/usr/bin/package-cleanup", line 137, in _find_missing_deps
    missing = miscutils.formatRequire(req,ver,flags)
  File "/usr/lib/python2.6/site-packages/rpmUtils/miscutils.py", line 350, in formatRequire
    rpm.RPMSENSE_EQUAL):
TypeError: unsupported operand type(s) for &: 'str' and 'int'


Version-Release number of selected component (if applicable):
yum-utils-1.1.24-2.fc12.noarch
yum-3.2.25-1.fc12.noarch


How reproducible:
ever

Steps to Reproduce:
1. run 'package-cleanup --problems'
  
Actual results:
traceback

Expected results:
no traceback

Additional info:
"--help", "--dupes" and "--leaves" are working fine.
Comment 1 James Antill 2009-12-01 10:15:31 EST
This should now be fixed in the upstream commit:

http://yum.baseurl.org/gitweb?p=yum-utils.git;a=commitdiff;h=5ef519442e401564d93e8695f42f3014f6712d4c
Comment 2 James Antill 2009-12-01 10:16:48 EST
*** Bug 542220 has been marked as a duplicate of this bug. ***
Comment 3 Sebastian Vahl 2009-12-03 03:03:58 EST
(In reply to comment #1)
> This should now be fixed in the upstream commit:
> 
> http://yum.baseurl.org/gitweb?p=yum-utils.git;a=commitdiff;h=5ef519442e401564d93e8695f42f3014f6712d4c  

Confirmed. Thanks.
Comment 4 James Antill 2009-12-16 10:45:15 EST
*** Bug 539580 has been marked as a duplicate of this bug. ***
Comment 5 Fedora Update System 2010-01-27 07:13:09 EST
yum-utils-1.1.25-1.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/yum-utils-1.1.25-1.fc12
Comment 6 Adam Huffman 2010-01-30 06:33:29 EST
*** Bug 558797 has been marked as a duplicate of this bug. ***
Comment 7 Fedora Update System 2010-02-11 09:47:38 EST
yum-utils-1.1.25-1.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.