Bug 54230 - Having trouble turning on DPMS
Having trouble turning on DPMS
Status: CLOSED DUPLICATE of bug 40889
Product: Red Hat Linux
Classification: Retired
Component: XFree86-Servers (Show other bugs)
7.1
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-10-01 22:35 EDT by wdc
Modified: 2007-04-18 12:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-10-12 00:14:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description wdc 2001-10-01 22:35:43 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.4) Gecko/20010913

Description of problem:
Under RedHat 6.0, I ran my ATI Mach 64 XFree86 version 3 that came with the
distribution.
I managed to turn on monitor power saving by setting:
     Option   "power_saver"
in the Device section of XF86Config, as documented in the XF86_Accel
man page.

But under RedHat 7.1, I am undable to set power saving from XF86Config.

The man page for XF86_Accel says to do the same thing as 6.0 did.
But under 7.1 xset q reports:

DPMS (Energy Star):
  Standby: 10    Suspend: 10    Off: 10
  DPMS is Disabled

(Notice the odd Standby, Suspend and Off times.  If I run startx 
from a virtual console as
root, power saving is STILL turned off, but the times are reasonable
values.)

I tried setting:
    Option "DPMS"
in the Monitor section as the XF86Config man page says to do.
But then the X server wont start, complaining that DPMS is not
a valid Monitor Option string.  (I guess XF86Config documentation
is for 4.0 only.  Perhaps that should be mentioned explicitly.)




Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Start Mach64 X server either with or without Option "power_saver"
2. xset -q
3.
	

Actual Results:  Power saving is turned off by default.

Expected Results:  Power saving should be turned on by default, as
documented in the
man pages.  Or either DPMS or power_saver options should turn it on.

Additional info:

I guess I can work around this by putting appropriate xset commands
into my login, but this used to work.  I'm wondering if a bug
has crept in, or if I'm doing something wrong.

Mostly I'm logging this bug to learn the answer, and in the hope that
the documentation will be made to reflect reality.
Comment 1 Mike A. Harris 2001-10-02 08:16:55 EDT
Make sure you are running an up to date system with all package updates
applied.  XFree86 DPMS works fine, there is no bug in X.  In particular,
there were bugs in xscreensaver, and gnome control center with respect
to DPMS.  Also keep in mind there are 2 different XFree86 config files.
One for 3.3.6, and one for 4.x.  The -4 one is for 4.x - as described
on the manpage.

Hopefully this will help you get it working properly.  If not, try our
mailing lists.
Comment 2 wdc 2001-10-02 13:05:05 EDT
Although I have not tested this, I expect it's a matter of my using
the un-updated xscreensaver and control-center that came on the CD.
Thanks very much for providing the crucial clue.  I found the bug report
on xscreensaver/control-center in Bugzilla, and know that all DPMS bases
are belong to them.  :-)
Comment 3 wdc 2001-10-12 00:14:12 EDT
By the way: My testing at home failed.  I turned on DPMS in the xscreensaver
section of control center, but DPMS is still disabled.

I think this is because, if the bug is fixed in xscreensaver-3.32-2 with
control-center-1.4.0.1-3 as implied in bugzilla bug 40889, those versions are
NOT what shipped with the 7.1 CD,
nor are they available on the errata page  (Not under RH 7.1 bug fixes, nor
package enhancements.)  They are not available on the RedHat updates FTP site.
At least not under any 7.1 designated directory.  The 7.2 directories, and
beta/roswell were inaccessible to me.

I guess this is why 40889 is still open rather than labeled fixed.


So
Comment 4 wdc 2001-10-12 00:15:05 EDT

*** This bug has been marked as a duplicate of 40889 ***

Note You need to log in before you can comment on or make changes to this bug.