Bug 542450 - virt-manager: libvirt permissioning breaks USB devices added by vendor/product instead of bus/device
virt-manager: libvirt permissioning breaks USB devices added by vendor/produc...
Status: CLOSED DUPLICATE of bug 537227
Product: Fedora
Classification: Fedora
Component: virt-manager (Show other bugs)
12
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Cole Robinson
Fedora Extras Quality Assurance
:
: 543839 549500 553068 (view as bug list)
Depends On: 537227
Blocks:
  Show dependency treegraph
 
Reported: 2009-11-29 15:07 EST by greg pryzby
Modified: 2010-05-27 15:31 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-27 15:31:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description greg pryzby 2009-11-29 15:07:20 EST
Description of problem: USB device is not accessible when added via virt-manager


Version-Release number of selected component (if applicable):


How reproducible: 


Steps to Reproduce:
1. Click on Info
2. Add New Hardware
3. Select USB 
4. Select device from list
5. Start VM
6. can't access usb device
   
Actual results:

XML file has vendor id and product id. This doesn't appear to work.

Expected results:

If you get the Bus and Device from lsusb and change the XML file, it works.



Additional info:

virt-manager should add BUS/DEVICE id instead of Vendor/Product ID to XML file.
Comment 1 Daniel Berrange 2009-11-30 05:29:05 EST
To be fair, virt-manager is really doing the right thing here, since device/address is not stable across device plug/unplug.  The real issue is that libvirt is not able to handle vendor/product permissioning.
Comment 2 greg pryzby 2009-11-30 08:06:24 EST
Is there a bug for libvirt and permissioning? 

This worked under Fedora 11, although since I upgraded the system, I don't know if it was using device/address or vendor/product.

I did turn off SELInux in case that was the issue.

Is there a work around (setting perms)? 
Is this something that will be fixed?
Comment 3 Cole Robinson 2009-12-22 09:53:45 EST
*** Bug 549500 has been marked as a duplicate of this bug. ***
Comment 4 Cole Robinson 2009-12-22 09:54:11 EST
*** Bug 543839 has been marked as a duplicate of this bug. ***
Comment 5 Andres Garcia 2009-12-23 06:14:34 EST
I am the one that reported bug 543839 that has been marked as duplicated of this one and, just in case, I wanted to point out that I had selinux disabled in /etc/selinux/config.

I tried the tip above to add the usb dongle by hand in the xml file indicating bus and device and it worked beautifully.
Comment 6 Cole Robinson 2009-12-23 08:50:08 EST
Disabling selinux likely won't help, this is actually an issue with libvirt auto changing path permissions/labels as mentioned in comment #2. I've changed the bug title to reflect reality.
Comment 7 Cole Robinson 2010-01-07 09:28:24 EST
*** Bug 553068 has been marked as a duplicate of this bug. ***
Comment 8 Cole Robinson 2010-05-10 16:32:15 EDT
The libvirt fixes are upstream, so moving this to post. I'll look into backporting the changes.
Comment 9 Cole Robinson 2010-05-27 15:31:54 EDT
There is a libvirt update in updates-testing, heading to stable, that should fix this issue. Closing as a dup of the libvirt bug tracking this:

https://bugzilla.redhat.com/show_bug.cgi?id=537227

*** This bug has been marked as a duplicate of bug 537227 ***

Note You need to log in before you can comment on or make changes to this bug.