Bug 543839 - Virtual machines don't access USB devices
Virtual machines don't access USB devices
Status: CLOSED DUPLICATE of bug 542450
Product: Fedora
Classification: Fedora
Component: virt-manager (Show other bugs)
12
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Cole Robinson
Fedora Extras Quality Assurance
:
Depends On: 542257
Blocks:
  Show dependency treegraph
 
Reported: 2009-12-03 04:45 EST by Andres Garcia
Modified: 2009-12-22 09:54 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-12-22 09:54:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andres Garcia 2009-12-03 04:45:21 EST
Description of problem:

I am trying to connect usb devices to virtual machines in F12. To test the feature I use a bluetooth dongle. 

In F11 I would just need to add the usb physical device using the virt-manager GUI and everything worked, although it was another computer.

In F12 it doesn't, lsusb at the host returns:

Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 009 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 008 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 007 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 006 Device 005: ID 0a12:0001 Cambridge Silicon Radio, Ltd Bluetooth
Dongle (HCI mode)
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 002: ID 046d:c001 Logitech, Inc. N48/M-BB48 [FirstMouse Plus] 

As a test guest I have another F12 machine, upgraded from F11, there lsub returns:

Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 1.1 root hub 

Both before and after adding the dongle and the bluetooth utils don't detect
the it.

Version-Release number of selected component (if applicable):

I first tried with F12, when it didn't work I tried updating with the Rawhide virt repo for F12 (http://jforbes.fedorapeople.org/virt-preview/f12/$basearch/
), it didn't work either and, this time, when adding the physical device, the dropbox to choose the device didn't show the same description lsusb returns, but
I could add it thanks to the bus and device numbers.
Comment 1 Cole Robinson 2009-12-22 09:54:10 EST

*** This bug has been marked as a duplicate of bug 542450 ***

Note You need to log in before you can comment on or make changes to this bug.