Bug 54257 - rebuilding bind-9.2.0-0.rc3 failed
Summary: rebuilding bind-9.2.0-0.rc3 failed
Status: CLOSED DUPLICATE of bug 53938
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: bind (Show other bugs)
(Show other bugs)
Version: 1.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Bernhard Rosenkraenzer
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-10-02 16:00 UTC by Joerg Dorchain
Modified: 2007-04-18 16:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-10-02 16:00:29 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Joerg Dorchain 2001-10-02 16:00:25 UTC
Description of Problem:
Rebuilding failed with  libtools problem (PACKES and VERSION variable not
set)

Version-Release number of selected component (if applicable):
bind-9.2.0-0.rc3

How Reproducible:
Always

Steps to Reproduce:
1. rpm -ba bind.spec --clean

Actual Results:
/bin/sh /usr/src/redhat/BUILD/bind-9.2.0rc3/libtool gcc  -O2 -march=i386
-mcpu=i686 -I/usr/src/redhat/BUILD/bind-9.2.0rc3 -I./include
-I./../nothreads/include -I../include -I./../include -I./..      -W -Wall
-Wmissing-prototypes -Wcast-qual -Wwrite-strings  -c app.c
libtool: ltconfig version `' does not match ltmain.sh version `1.3.5'
Fatal configuration error.  See the libtool docs for more information.
make[3]: *** [app.lo] Error 1
make[3]: Leaving directory
`/usr/src/redhat/BUILD/bind-9.2.0rc3/lib/isc/unix'
make[2]: *** [subdirs] Error 1
make[2]: Leaving directory `/usr/src/redhat/BUILD/bind-9.2.0rc3/lib/isc'
make[1]: *** [subdirs] Error 1
make[1]: Leaving directory `/usr/src/redhat/BUILD/bind-9.2.0rc3/lib'
make: *** [subdirs] Error 1
error: Bad exit status from /var/tmp/rpm-tmp.69684 (%build)


RPM build errors:
    Bad exit status from /var/tmp/rpm-tmp.69684 (%build)

Expected Results:
RPMS

Additional Information:
The following patch helped:

--- bind.spec.redhat	Tue Oct  2 17:38:28 2001
+++ bind.spec	Tue Oct  2 17:38:00 2001
@@ -65,6 +65,8 @@
 find doc -name "*.fixes" |xargs rm -f
 
 %build
+aclocal
+autoconf
 %configure --with-libtool --with-openssl=/usr
 make

Comment 1 Bernhard Rosenkraenzer 2001-10-02 22:06:20 UTC

*** This bug has been marked as a duplicate of 53938 ***


Note You need to log in before you can comment on or make changes to this bug.