Bug 542687 - krb5 1.7 locks AD accounts
Summary: krb5 1.7 locks AD accounts
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: krb5
Version: 12
Hardware: All
OS: Linux
low
high
Target Milestone: ---
Assignee: Nalin Dahyabhai
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-11-30 15:05 UTC by arif
Modified: 2010-09-21 14:47 UTC (History)
2 users (show)

Fixed In Version: 1.7.1-1.fc12
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-09-21 14:47:47 UTC
Type: ---


Attachments (Terms of Use)

Description arif 2009-11-30 15:05:12 UTC
Description of problem:

krb5 1.7, as installed on f12, when used with an Microsoft AD server tries incorrect passwords multiple times. As AD account lockouts are often configure theis will lock a users account on the first incorrect password.


Version-Release number of selected component (if applicable):

1.6 is fine, 1.7 is broken. 


How reproducible:

100%


Steps to Reproduce:
1. configure krb5.conf to use a AD server 
2. kinit <user>
3. Enter incorrect password
  
Actual results:

$ kinit user
Password for user@example.com: 
kinit: Clients credentials have been revoked while getting initial credentials

Now the account is locked.

Expected results:

$ kinit
Password for user@example.com: 
kinit(v5): Preauthentication failed while getting initial credentials


Additional info:

See this thread on the krb5 mailing list
  http://mailman.mit.edu/pipermail/kerberos/2009-October/015368.html

See http://mailman.mit.edu/pipermail/kerberos/2009-October/015375.html for a possible patch.

Comment 1 Troels Arvin 2010-02-03 10:35:04 UTC
Probably a dupe of Bug #554351.

Comment 2 Nalin Dahyabhai 2010-02-03 17:07:18 UTC
(In reply to comment #1)
> Probably a dupe of Bug #554351.    

Yep, it's the same one alright.  It should be fixed in 1.7.1, which I hope to get into updates-testing today.

Comment 3 Troels Arvin 2010-09-21 08:08:05 UTC
I think this bug can be closed; I haven't seen the problem since upgrading to the fixed krb package.

Comment 4 Nalin Dahyabhai 2010-09-21 14:47:47 UTC
Alright, then.  Thanks!


Note You need to log in before you can comment on or make changes to this bug.