Bug 543002 - NM-Plugin version does not match pppd version.
NM-Plugin version does not match pppd version.
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: NetworkManager-pptp (Show other bugs)
rawhide
All Linux
low Severity high
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
: 568310 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-12-01 08:13 EST by Fabian Deutsch
Modified: 2010-02-26 22:31 EST (History)
8 users (show)

See Also:
Fixed In Version: NetworkManager-pptp-0.7.997-3.git20100120.fc12
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-02-26 22:31:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Fabian Deutsch 2009-12-01 08:13:10 EST
Description of problem:
NetworkManager can not connect pptp-vpns anymore.

pppd says: pppd[2478]: Plugin /usr/lib/pppd/2.4.4/nm-pptp-pppd-plugin.so is for pppd version 2.4.4, this is 2.4.5


Version-Release number of selected component (if applicable):
# rpm -q ppp pptp NetworkManager-pptp
ppp-2.4.5-2.fc13.i686
pptp-1.7.2-8.fc12.i686
NetworkManager-pptp-0.7.996-4.git20090921.fc13.i686

How reproducible:
Always on current rawhide.

Steps to Reproduce:
1. Update to rawhide with installed NM and NM-pptp
2. Setup some pptp-vpn
3. Try to connect and look at /var/log/messages
  
Actual results:
... pppd[2478]: Plugin /usr/lib/pppd/2.4.4/nm-pptp-pppd-plugin.so is for pppd version 2.4.4, this is 2.4.5

Expected results:
VPN is connected.

Additional info:
I suppose this is just on rawhide the case.
Comment 1 Dan Williams 2010-01-06 13:12:05 EST
nm-pptp needs to pick the right directory and ensure that it conflicts with pppd when pppd's version changes
Comment 2 Jon Burgess 2010-01-18 17:44:07 EST
The same issue occurs with F-12 + ppp-2.4.5 from updates-testing.
Comment 3 Kirk Lowery 2010-02-24 11:52:05 EST
So...for the user, what is the workaround on F12? Is there some way to force nm-pptp to use the 2.4.5 directory instead of the 2.4.4.? Or is the solution to downgrade NetworkManager-pptp?
Comment 4 Kirk Lowery 2010-02-24 12:43:17 EST
Okay, found the updated rpm:

http://www.rpmfind.net//linux/RPM/fedora/updates/testing/12/i386/NetworkManager-pptp-0.7.997-3.git20100120.fc12.i686.html

Downloaded it, installed it and everything works!

Thanks, guys, for your consistent work.
Comment 5 Fedora Update System 2010-02-24 18:14:07 EST
NetworkManager-pptp-0.7.997-3.git20100120.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/F12/FEDORA-2010-0932
Comment 6 Dan Williams 2010-02-24 18:15:27 EST
The update in comment #5 has actually been in f12-updates-testing since 2010-01-22, but the ppp-2.4.5 push to stable caught me by surprise so the NM & NM-pptp updates will only go out in the next push.
Comment 7 Dan Williams 2010-02-25 13:07:02 EST
*** Bug 568310 has been marked as a duplicate of this bug. ***
Comment 8 Kuznetsov Vyacheslav 2010-02-26 02:39:49 EST
NetworkManager-pptp-0.7.997-3.git20100120.fc12.x86_64 doesn't fix the issue for me :( 
Is that the x86_64 issue now?

Your assistance is much appreciated.
Comment 9 Fabian Deutsch 2010-02-26 04:09:10 EST
Some time ago this issue was fixed in rawhide. SO using 
# yum install --enablerepo=rawhide 
might solve this problem.
Comment 10 Michal Schmidt 2010-02-26 06:21:43 EST
(In reply to comment #6)
> The update in comment #5 has actually been in f12-updates-testing since
> 2010-01-22, but the ppp-2.4.5 push to stable caught me by surprise so the NM &
> NM-pptp updates will only go out in the next push.    

Dan & Jiri,
are you aware that Bodhi allows you to create a grouped update to ensure that ppp and NM get pushed at the same time? Please make use of this feature in the future.
Comment 11 DeaD_MoroZ 2010-02-26 08:14:51 EST
Its only work on i386. i dunno how this bs happened, but i trust that in future it doesnt happend again.
Comment 12 Kuznetsov Vyacheslav 2010-02-26 08:17:33 EST
Thank you in advice, Fabian.
I've updated the NetworkManager-pptp with 

---
# yum --enablerepo=rawhide update NetworkManager-pptp
---

And got the same NetworkManager-pptp-0.7.997-3.git20100120.fc13.x86_64

The issue is still here :(
Comment 14 DeaD_MoroZ 2010-02-26 09:47:43 EST
sorry... poorly considered previous post\=
Comment 15 DeaD_MoroZ 2010-02-26 11:07:19 EST
sorry... poorly considered previous post\=
Comment 16 Kevin R. Page 2010-02-26 14:46:20 EST
Bug #548520 comment #34 and comment #10 above suggests there should have been "more than one build [added] to an update request". There really ought to be a process in place to ensures this happens.

A yum downgrade of ppp fixed the problem for me, but in the meantime I was without network - and so the ability to cure the problem - for over a day at an extremely inconvenient moment when I was relying on using my 3G connection.
Comment 17 Fedora Update System 2010-02-26 22:31:36 EST
NetworkManager-pptp-0.7.997-3.git20100120.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.