This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 54305 - Bad Size error or hang w/SA6R RAID & 2 20GB Maxtors
Bad Size error or hang w/SA6R RAID & 2 20GB Maxtors
Status: CLOSED DUPLICATE of bug 27956
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-10-04 00:50 EDT by Shannon Carey
Modified: 2007-04-18 12:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-10-04 12:00:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Shannon Carey 2001-10-04 00:50:01 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows 98; Tauron's)

Description of problem:
I am using an ABIT SA6R motherboard with two 20GB Maxtor hard drives 
connected to the onboard Highpoint raid controller.  I am trying to 
install on an existing FAT32 partition.  The RAID configuration should be 
solely constructed through hardware.

When conducting a graphical install of type Workstation, Disk Druid 
reports that drive hde has -19540MB of free space and 200% of the space is 
used.  This is quite incorrect.  Next, on the Filesystem Configuration 
screen, it says that the numbers "must total less than 0MB in size."  I 
put in suitable numbers, but which added up to more than 0MB (obviously).  
Directly after Linux begins the actual installation, it hangs and gives me 
the error traceback below, which I could not get in its entirety because 
it had frozen.

When using text only install, I tried the same thing.  This time after 
setting the Filesystem Configuration sizes, the error is "Bad Size:  The 
total size must be more than the amount of free space on the disk, which 
is 0M."  Once again, this is incorrect, and causes me to be unable to 
continue installation.

Other errors I came across were "The new partition table on device hdg is 
corrupted. To create new partitions it must be initialized, causing the 
loss of ALL DATA on this drive."  This pops up twice directly after I 
choose my Installation Option (Workstation).  I chose "Skip Drive" both 
times because I wish to retain the data on my RAID.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Run anaconda on a computer set up like my own. (see above)
2.Make the installation workstation, with a partitionless install.
3.
	

Actual Results:  When graphical install hanged, it said this

Traceback (innermost last):
File "/var/tmp/anaconda-7.1//usr/lib/anaconda/iw/progress_gui.py", line 
19, in run
rc=self.todo.doInstall()
File "/var/tmp/anaconda-7.1//usr/lib/anaconda/todo.py", line 1764, in 
doInstall
self.fstab.makeFilesystems()
File "var/tmp/anaconda-7.1//usr/lib/anaconda/fstab.py", line 730, in 
makeFilesystems
(self.progressWindow,_("Loopback"),
File "mnt/redhat/test/qa0408.4/i386/RedHat/instimage/usr/lib/anaconda

Additional info:
Comment 1 Shannon Carey 2001-10-04 11:44:36 EDT
This problem seems to be most similar to bug 27956.  What's CVS?  Part of 
rawhide?
Comment 2 Brent Fox 2001-10-04 12:00:03 EDT
CVS is short for Concurrent Versions System, which is a long way to say that
it's our source code repository.  CVS is commonly used in open-source projects
to store source code.  When we build our packages for things like Rawhide or the
distribution, the source code gets pulled from CVS.  So, when msf said that it
was fixed in CVS, that means that he's made a patch and applied it to our source
code repository, but it probably hasn't been pulled into a package-build for the
installer yet.  Given that he made the comment in February, and 7.1 was released
after that, the fix he created would have been pulled into 7.1.  But you're
still seeing the problem...

The majority of the partitioning code has been replaced for the next version of
Red Hat Linux.  If you are interested, you can download the public beta for the
next version at ftp://ftp.redhat.com/pub/redhat/linux/beta/roswell/en/iso/i386
Comment 3 Brent Fox 2001-10-15 12:23:40 EDT

*** This bug has been marked as a duplicate of 27956 ***

Note You need to log in before you can comment on or make changes to this bug.