Bug 54308 - chain-booting with grub breaks APM under 2k, lilo doesn't
chain-booting with grub breaks APM under 2k, lilo doesn't
Status: CLOSED DUPLICATE of bug 54375
Product: Red Hat Linux
Classification: Retired
Component: grub (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-10-04 01:35 EDT by James Manning
Modified: 2015-01-07 18:51 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-10-04 01:35:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description James Manning 2001-10-04 01:35:24 EDT
Description of Problem:
on my laptop, rh 7.1 (hda5) booted from lilo with windows me 
on hda2 and win2k from hda3.  When lilo chain-boots to the windows
loader (where I select between WinME or Win2K) that's on hda2,
APM works fantastic inside both.  When I ran the RH 7.2 upgrade and
switched to grub, APM stopped working in both windows versions but 
continued to work in Linux.  When
I did a mv /etc/lilo.conf.anaconda /etc/lilo.conf;lilo to switch
back to lilo chaining to the windows loader, APM in windows worked again.  
This makes me think that something about grub h/w initialization (or, less 
likely, chain booting method) is what's breaking APM in windows.

Version-Release number of selected component (if applicable):
the ver in RH 7.2 final.  I'm booted into Win2K at the moment on the 
laptop :)

How Reproducible:
100%

NOTE:

I know this isn't necessarily a grub problem, but:

1) it'd be nice for grub to act like lilo and not break Win APM
2) it would seem to be a possible entry for the knowledge base
Comment 1 Jeremy Katz 2001-10-11 17:24:58 EDT
James -- I'm quite frightened, someone else filed the same bug the same day as
you :)

I might ask you to try some things for me if I can't manage to dig up a laptop
around here to throw 2k on to test with.

*** This bug has been marked as a duplicate of 54375 ***
Comment 2 James Manning 2001-10-11 17:41:21 EDT
Ok, that's cool... I can also let you borrow the laptop if you want (for maybe like a 
week or two) if that works out better.  Either way is fine by me :)  Just lemme know 
if you wanna borrow it, I'll bring it into work and I can give it to you over lunch or 
whatever (or just hop over Meridian and drop it off)

Note You need to log in before you can comment on or make changes to this bug.