Bug 54375 - grub appears to prevent APM working for Win2K
Summary: grub appears to prevent APM working for Win2K
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: grub   
(Show other bugs)
Version: roswell
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact:
URL:
Whiteboard:
Keywords:
: 54308 55224 55921 60862 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-10-05 02:58 UTC by Dave Goldblatt
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-10-30 10:50:44 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Dave Goldblatt 2001-10-05 02:58:39 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.9.4+)
Gecko/20011001

Description of problem:
After installing Roswell on a Dell Inspiron 7000 (BIOS A15) I noticed when
booting into Windows 2000 SP2 that the APM functionality no longer appeared
under Win2K; specifically battery monitoring (on AC power/battery, battery
life) and suspend to memory or disk.


Removing grub and replacing with System Commander restored the APM
functionality to Win2K.  Microsoft's apmstat program indicated a corrupted
APM BIOS when booting under Grub; after removing Grub the utility indicated
no problems.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
Boot an Inspiron 7000 (BIOS A15) under Grub.

Actual Results:  APM unusable.

Expected Results:  APM should not be affected by booting Win2K from Grub.

Additional info:

Dell Inspiron 7000, Pentium II 366, A15 BIOS.  Linux APM functions
correctly when booting under Grub.  Filed as high since a laptop which will
not suspend is a very _hot_ laptop after some time in a case; could result
in system damage.

Comment 1 Jeremy Katz 2001-10-11 21:24:53 UTC
*** Bug 54308 has been marked as a duplicate of this bug. ***

Comment 2 Jeremy Katz 2001-10-21 23:54:22 UTC
I'll see what I can do about tracking this one down -- for clarification, you
are putting GRUB in the MBR, correct?

Comment 3 Dave Goldblatt 2001-10-22 00:54:24 UTC
Correct, GRUB was in the MBR.


Comment 4 Jeremy Katz 2001-10-27 02:32:35 UTC
Can you try the updated grub package at
http://people.redhat.com/~katzj/RPMS/grub-0.90-12.i386.rpm and see if it fixes
the problem?

Comment 5 Jeremy Katz 2001-10-27 02:33:53 UTC
(Note that you will need to install the package and then run `/sbin/grub-install
/dev/foo` to get the updated images installed into the MBR)

Comment 6 Jeremy Katz 2001-10-27 17:41:51 UTC
*** Bug 55224 has been marked as a duplicate of this bug. ***

Comment 7 Jeremy Katz 2001-10-27 17:43:50 UTC
*** Bug 55224 has been marked as a duplicate of this bug. ***

Comment 8 Dave Goldblatt 2001-10-28 02:25:31 UTC
Works like a charm.  Ship it. :-)


Comment 9 Julio Sanchez Fernandez 2001-10-30 10:50:40 UTC
It also fixed my complete inability to boot my NT from grub.

/sbin/grub-install, however, broke everything.  I added a few sleep's in it as suggested in grub-bug, though it seems the definitive solution to the problem those sleeps 
fixes is unclear...

Comment 10 Jeremy Katz 2001-10-31 22:33:36 UTC
I've added some syncs to grub-0.90-13 (which will be building and going to the
same place in a few minutes probably) using Erich's patch off of the GRUB
mailing list until a better way of making sure the data is flushed to the disk
is determined.

Comment 11 Jeremy Katz 2001-11-08 19:59:20 UTC
*** Bug 55921 has been marked as a duplicate of this bug. ***

Comment 12 Jonathan Larmour 2002-02-06 01:25:52 UTC
Any reason the updated RPM hasn't made it to RHN? Seems like it's been a
while...


Comment 13 Jeremy Katz 2002-03-07 23:50:59 UTC
*** Bug 60862 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.