Bug 543194 - [abrt] crash detected in fprintd-0.1-15.git04fd09cfa.fc12
[abrt] crash detected in fprintd-0.1-15.git04fd09cfa.fc12
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: fprintd (Show other bugs)
12
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Bastien Nocera
Fedora Extras Quality Assurance
abrt_hash:f390e266488db0f48988cdeb8f8...
:
: 543639 545242 546879 546881 551336 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-12-01 16:27 EST by Reginaldo Ribeiro
Modified: 2010-08-17 10:39 EDT (History)
6 users (show)

See Also:
Fixed In Version: 0.1-16.git04fd09cfa.fc12
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-12-28 15:13:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
File: backtrace (1.91 KB, text/plain)
2009-12-01 16:27 EST, Reginaldo Ribeiro
no flags Details

  None (edit)
Description Reginaldo Ribeiro 2009-12-01 16:27:40 EST
abrt 1.0.0 detected a crash.

How to reproduce
-----
1. Dell Latitude E6400
2. Just run fprintd-enroll
3.

backtrace
-----
Core was generated by `fprintd-enroll'.
Program terminated with signal 6, Aborted.
#0  0x00d30416 in __kernel_vsyscall ()

Thread 1 (Thread 10557):
#0  0x00d30416 in __kernel_vsyscall ()
No symbol table info available.
#1  0x005b9a81 in raise (sig=6) at ../nptl/sysdeps/unix/sysv/linux/raise.c:64
        resultvar = <value optimized out>
        resultvar = <value optimized out>
        pid = 7340020
        selftid = 10557
#2  0x005bb34a in abort () at abort.c:92
        save_stage = 2
        act = {__sigaction_handler = {sa_handler = 0x80, sa_sigaction = 
    0x80}, sa_mask = {__val = {9518283, 10338724, 6288406, 166832160, 
    3220331112, 9761809, 166826439, 9997760, 15, 166806040, 16, 1, 16, 8, 0, 
    0, 9740859, 10338724, 6298881, 7345024, 32, 10338724, 166826384, 
    166832160, 3220331160, 9647447, 0, 166842304, 9651327, 10338724, 
    10338724, 166826384}}, sa_flags = -1074635992, sa_restorer = 
    0x934c26 <IA__g_log_default_handler+598>}
        sigs = {__val = {32, 0 <repeats 31 times>}}
#3  0x00935476 in IA__g_logv (log_domain=<value optimized out>, 
    log_level=<value optimized out>, format=<value optimized out>, 
    args1=<value optimized out>) at gmessages.c:549
        depth = 0
        domain = <value optimized out>
        data = <value optimized out>
        log_func = 0x9349d0 <IA__g_log_default_handler>
        domain_fatal_mask = 5
        masquerade_fatal = <value optimized out>
        test_level = <value optimized out>
        was_recursion = 0
        i = <value optimized out>
#4  0x009354a7 in IA__g_log (log_domain=<value optimized out>, 
    log_level=<value optimized out>, format=<value optimized out>)
    at gmessages.c:569
No locals.
#5  0x08048c15 in open_device (username=<value optimized out>) at enroll.c:49
        error = 0x9f1a810
        path = <value optimized out>
#6  main (username=<value optimized out>) at enroll.c:124
        dev = <value optimized out>
        username = 0x0

cmdline: fprintd-enroll
component: fprintd
executable: /usr/bin/fprintd-enroll
kernel: 2.6.31.5-127.fc12.i686
package: fprintd-0.1-15.git04fd09cfa.fc12
rating: 3
reason: Process was terminated by signal 6
Comment 1 Reginaldo Ribeiro 2009-12-01 16:27:43 EST
Created attachment 375198 [details]
File: backtrace
Comment 2 Bastien Nocera 2009-12-09 05:46:01 EST
*** Bug 545242 has been marked as a duplicate of this bug. ***
Comment 3 Bastien Nocera 2009-12-09 05:46:14 EST
*** Bug 543639 has been marked as a duplicate of this bug. ***
Comment 4 Jan Valenta 2009-12-09 08:03:05 EST
Similar issue on x86_64 with AES1600 fingerprint reader. 

Moreover, I can log in using the fingerprint reader even if I use different finger from that one I used during the "learning" part. Which means that virtually anybody can log in to the copmuter. I don't know if this is bug in the AES1600 driver or if it relates to the fprintd crash. If the latter than I suggest increasing severity and priority of this bug.
Comment 5 Bastien Nocera 2009-12-09 08:24:29 EST
(In reply to comment #4)
> Similar issue on x86_64 with AES1600 fingerprint reader. 

It's not a bug, if you read the output of the command...

> Moreover, I can log in using the fingerprint reader even if I use different
> finger from that one I used during the "learning" part. Which means that
> virtually anybody can log in to the copmuter. I don't know if this is bug in
> the AES1600 driver or if it relates to the fprintd crash. If the latter than I
> suggest increasing severity and priority of this bug.  

There's no crashes. If the AES driver doesn't work as expected, then comment on bug 499732.
Comment 6 Jan Valenta 2009-12-09 08:26:52 EST
The logging in using different fingerprint probably relates to the AES1600 fingerprint reader driver -- bug 499732 -- https://bugzilla.redhat.com/show_bug.cgi?id=499732
Comment 7 Fedora Update System 2009-12-09 09:48:42 EST
fprintd-0.1-16.git04fd09cfa.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/fprintd-0.1-16.git04fd09cfa.fc12
Comment 8 Ken Barber 2009-12-09 18:25:08 EST
fprintd-0.1-16.git04fd09cfa.fc12 has seemingly fixed this for me. Anyway - doesn't abort now - just shows a warning as one would expect.

[ken@hag ~]$ fprintd-verify 
list_devices failed: No devices available
[ken@hag ~]$ 

Previously it was aborting as you can see from my bug 545242. As was mentioned probably only when one has no detected devices - (I think my Broadcom reader on the E6500 isn't supported yet).
Comment 9 Fedora Update System 2009-12-11 13:18:52 EST
fprintd-0.1-16.git04fd09cfa.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update fprintd'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F12/FEDORA-2009-13072
Comment 10 Bastien Nocera 2009-12-22 04:15:31 EST
*** Bug 546879 has been marked as a duplicate of this bug. ***
Comment 11 Bastien Nocera 2009-12-22 04:15:45 EST
*** Bug 546881 has been marked as a duplicate of this bug. ***
Comment 12 Fedora Update System 2009-12-28 15:13:02 EST
fprintd-0.1-16.git04fd09cfa.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 13 Bastien Nocera 2010-08-17 10:39:00 EDT
*** Bug 551336 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.