Bug 54339 - Will not install unless in expert and then does not fully install.
Will not install unless in expert and then does not fully install.
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-10-04 11:42 EDT by David Bristol
Modified: 2007-04-18 12:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-01-16 15:08:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description David Bristol 2001-10-04 11:42:40 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (X11; U; Linux 2.4.3-12 i686; Nav)

Description of problem:
Tried several iterations of hardware (AMD K6-3 750 MHz on Tyan motherboard
with the VIA chipset) and could not install unless in expert mode.
Installer would crash after package selection was completed. No speceific
error code. Only a gtk crirtical warning that ! = null. Expert mode
installs, but at the end of the installation, the x-windows configuration
crashes when testing the configuration (have not been able to try without
testing x.) Also, the installer did not properly configure the services
upon reboot. Some of the system V services are enabled by default, but it
took 4 installs before what I thought were the defaults were enabled (I.e.
sendmail, linuxconf, etc. Not that I need them, but I chose the custopm -
everything install option.) The packages appear to be installed, but they
are not configured.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Install RedHat with standard options
2.Install RedHat in expert mode and test X configuration
3.
	

Actual Results:  See description

Expected Results:  RedHat would install and configure everything for a
standard install.

Additional info:
Comment 1 Brent Fox 2001-10-04 14:15:02 EDT
What kind of machine is it?  Is it in the meridian building?
Comment 2 David Bristol 2001-10-08 10:07:26 EDT
No, it is a home built machine. Tyan (model #?) motherboard with an AMD k6-3 750
MHz processor, 256 Mb of SDRAM on a 133 MHz bus, Riva 128 Mb video card (PCI),
two NICS: linksys lne100-TX and Netgear fa310-TX. SoundBlaster Live soundcard,
USB (on the motherboard), two ATA 100 Western Digital Hard Drives and a 48X acer
CDROM. If you need more specific info, let me know. I do not yet have internet
at the house so I'll have to write it down and bring it in with me tomorrow.
Thanks for the follow up.
Comment 3 Brent Fox 2001-10-15 14:34:18 EDT
This is very strange behavior.  It sounds like you have pretty common hardware.
 It would help to have more of the debug message when the crash happens.
Comment 4 David Bristol 2001-10-16 17:17:31 EDT
Unfortunately, when the system locks up, there is no way to get to the debug
message. The system is locked completely. There is no chance to get to the other
screens (f1-f5.) I have tried another reinstall, and when I do not test the X
configuration, the install completes fine. 

With the regular install, the error message was something like:
gtk+ critical ... " ! = null "

I was unable to get it printed out, and, quite frankly, I'd rather not reinstall
if possible. If the message is critical, I will reinsand write it all down. I am
sure that the end of the error was " ! = null "
Comment 5 Brent Fox 2001-10-17 14:23:10 EDT
I don't know...it sounds like something is going wrong with the X server.  On
some cards, it seems like starting two X servers causes problems.  You're
already running one, which is the graphical installer, and then testing the X
configuration causes another one to start.

Does the behavior in bug #28373 sound like the problem you are seeing?
Comment 6 David Bristol 2001-10-24 10:09:31 EDT
That bug does not sound similar to the problems I was experiencing.
Unfortunately, everything else about the install process ran fine in expert
mode. In standard mode, it never made it to the package selection scree, and the
error message had no line number (or any other identifier for that matter), but
did give the error: `widget != NULL'.
Comment 7 Brent Fox 2001-10-24 10:26:42 EDT
Hmm...I don't really know where to go from here.  Is there any way you could
bring the machine in so we could have a look at it?  Also, does 7.2 display the
same behavior?
Comment 8 David Bristol 2001-10-24 10:33:58 EDT
This is 7.2 install. 7.0 and 7.1 installed with no problem. Again, I'm just
submitting the bug so that we can refine the install process. It's probably just
my video card (STB Velocity 128 4Mb.) If you want to close it as "not a bug" so
that you can move on to more important stuff, that's fine. I can bring it in,
but since it is my home system I would have to be there when it is tested.
Comment 9 Brent Fox 2001-10-24 10:52:26 EDT
Oh, it was filed against 7.1.  Changing versions.
Comment 10 Brent Fox 2001-10-24 10:54:12 EDT
I think it would just take a minute for you and me to try an install and
duplicate the behavior, but if it's too much trouble to bring it in then I
understand.  Just out of curiosity, did you click the "Hide Help" button on the
first screen of the installer?
Comment 11 David Bristol 2001-10-25 17:28:36 EDT
I tried hiding and not hiding the help bar thinking that would make a
difference, but it didn't.
Comment 12 David Bristol 2001-10-25 17:29:55 EDT
I can bring it in next week, on like thursday or friday (nov. 2/3.) Let me know
what would work for you.
Comment 13 Brent Fox 2001-10-26 12:09:51 EDT
Thursday sounds fine.
Comment 14 Brent Fox 2001-11-08 22:05:15 EST
Have you had the chance to bring your machine in?
Comment 15 David Bristol 2001-11-12 12:42:20 EST
No. I apologize. I was sick the week we were supposed to coordinate and have
since been reassigned to several new projects. Please let me know what day (from
Wednesday on) would work to meet before noon.
Comment 16 Michael Fulbright 2002-01-16 15:08:07 EST
Could you bring the machine by os-devel sometime and we'll have a look.
Comment 17 Brent Fox 2002-01-26 22:50:13 EST
Closing due to inactivity.  Please reopen if you have more information.

Note You need to log in before you can comment on or make changes to this bug.