This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 543777 - Anaconda cannot continue when a new partition is created with empty mount point
Anaconda cannot continue when a new partition is created with empty mount point
Status: CLOSED DUPLICATE of bug 496938
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
12
All Linux
low Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-12-02 22:17 EST by reubendb
Modified: 2009-12-06 10:17 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-12-06 10:17:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Traceback of anaconda at the point of failure. (438.76 KB, application/octet-stream)
2009-12-03 22:57 EST, reubendb
no flags Details
Anaconda traceback at the point of failure (438.76 KB, text/plain)
2009-12-03 23:01 EST, reubendb
no flags Details

  None (edit)
Description reubendb 2009-12-02 22:17:12 EST
Description of problem:

During install, I choose "Custom Layout" to create my own partition scheme. On one of the partition I created, I didn't assign any mount point. Anaconda showed a dialog box of something related to no mount point (can't remember exactly), went through the whole saving debug log, and then quit.

Version-Release number of selected component (if applicable):
12

How reproducible:
Always

Steps to Reproduce:
1. During install choose "Custom Layout" for creating partition
2. Create a partition for /, /home, and another one without assigning mount point
3. 
  
Actual results:
Anaconda cannot continue the install process

Expected results:
Anaconda continue the install process.

Additional info:
Debug log attached.
Comment 1 Radek Vykydal 2009-12-03 07:56:49 EST
Can you please attach traceback? You can do it using exception dialog that - as I understood from your description - appears in the point of failure.
Comment 2 reubendb 2009-12-03 22:57:39 EST
Created attachment 375991 [details]
Traceback of anaconda at the point of failure.
Comment 3 reubendb 2009-12-03 23:01:01 EST
Created attachment 375994 [details]
Anaconda traceback at the point of failure

For some reason my previous attachment showed up as binary, trying again by selecting plain text manually.
Comment 4 reubendb 2009-12-03 23:02:45 EST
I am sorry I thought I had attached this traceback when I initially reported the bug. I must have done something wrong and it didn't go through. If this is not what you ask for please let me know and I'll try to get the right one. Thank you.
Comment 5 Chris Lumens 2009-12-06 10:13:02 EST
anaconda 12.46 exception report
Traceback (most recent call first):
  File "/usr/lib/anaconda/storage/devices.py", line 1466, in create
    self._name = self.slave.format.mapName
  File "/usr/lib/anaconda/storage/deviceaction.py", line 205, in execute
    self.device.create(intf=intf)
  File "/usr/lib/anaconda/storage/devicetree.py", line 708, in processActions
    action.execute(intf=self.intf)
  File "/usr/lib/anaconda/storage/__init__.py", line 275, in doIt
    self.devicetree.processActions()
  File "/usr/lib/anaconda/packages.py", line 110, in turnOnFilesystems
    anaconda.id.storage.doIt()
  File "/usr/lib/anaconda/dispatch.py", line 200, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 123, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/gui.py", line 1195, in nextClicked
    self.anaconda.dispatch.gotoNext()
AttributeError: 'Ext4FS' object has no attribute 'mapName'
Comment 6 Chris Lumens 2009-12-06 10:17:57 EST

*** This bug has been marked as a duplicate of bug 496938 ***

Note You need to log in before you can comment on or make changes to this bug.