This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 545258 - hal-0.5.14-1 and failures with brightness controls
hal-0.5.14-1 and failures with brightness controls
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kdebase-workspace (Show other bugs)
12
All Linux
low Severity medium
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-12-07 19:10 EST by Rex Dieter
Modified: 2009-12-28 15:09 EST (History)
11 users (show)

See Also:
Fixed In Version: 4.3.4-1.fc12
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 545639 (view as bug list)
Environment:
Last Closed: 2009-12-28 15:09:01 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
KDE Software Compilation 196232 None None None Never
KDE Software Compilation 217316 None None None Never

  None (edit)
Description Rex Dieter 2009-12-07 19:10:03 EST
hal-0.5.14-1.fc12 seems to induce a couple of bad behaviors in kde that isn't present with hal-0.5.13-9.fc12

1.  First attempt to login from kdm seems to fail/crash X, 2nd attempt works

2.  kde's brightness controls no longer seem to work, and are now stuck at 0 (dimmest setting).

I'm currently focussed on looking at 2.
Comment 1 Rex Dieter 2009-12-07 19:45:37 EST
$ qdbus --system org.freedesktop.Hal /org/freedesktop/Hal/devices/computer_backlight org.freedesktop.Hal.Device.LaptopPanel.GetBrightness
7

This returns valid values, but

$ solid-powermanagement brightness get

Brightness is 0%

isn't very good.


During this, 

$ solid-powermanagement brightness set

continues to work.
Comment 2 Rex Dieter 2009-12-07 20:43:20 EST
wrt, crash on first login, /var/log/messages contain,

Dec  7 19:33:30 localhost kdm: :0[1453]: Cannot open ConsoleKit session: Unable to open session: Launch helper exited with unknown return code 0
Dec  7 19:33:30 localhost kdm: :0[1453]: Client start failed
Dec  7 19:33:30 localhost kdm: :0[1453]: Cannot close ConsoleKit session: Unable to close session: no session open

weird, re-assigning to kdebase-workspace for further investigation.
Comment 3 Kevin Kofler 2009-12-07 23:02:53 EST
This doesn't sound like KDM's fault, it's just echoing the error message given by libck-connector. Looks like talking to ConsoleKit is failing for some reason.

As for the KDE crash possibly related to no valid brightness, are you using Qt 4.6? See https://bugs.kde.org/show_bug.cgi?id=217805
Comment 4 Rex Dieter 2009-12-07 23:08:01 EST
Stock stuff here,
qt-4.5.3-9.fc12.x86_64
kdebase-workspace-4.3.3-7.fc12.x86_64

SMParrish was able to reproduce these symptoms @ fudcon too.
Comment 5 Richard Hughes 2009-12-08 03:00:39 EST
(In reply to comment #1)
> $ qdbus --system org.freedesktop.Hal
> /org/freedesktop/Hal/devices/computer_backlight
> org.freedesktop.Hal.Device.LaptopPanel.GetBrightness
> 7
> 
> This returns valid values, but
> 
> $ solid-powermanagement brightness get
> 
> Brightness is 0%
> 
> isn't very good.

Surely this is a solid failure then?
Comment 6 Kevin Kofler 2009-12-08 08:10:27 EST
Did something in HAL change incompatibly from 0.5.13 to 0.5.14?
Comment 7 Rex Dieter 2009-12-08 20:18:59 EST
Opened separate bug #545258 to track the libck-connector/kdm failure.

Adjusting subject here for brightness control issue(s).
Comment 8 Rex Dieter 2009-12-14 09:36:08 EST
Potential reviewboard fix submitted,
http://reviewboard.kde.org/r/2368/
Comment 9 Rex Dieter 2009-12-14 10:29:40 EST
I think I can confirm this fixes the issue here, working on a patch
Comment 10 Fedora Update System 2009-12-17 23:22:52 EST
kde-l10n-4.3.4-1.fc12, kdeutils-4.3.4-2.fc12, kdetoys-4.3.4-1.fc12, kdesdk-4.3.4-1.fc12, kdepim-runtime-4.3.4-1.fc12, kdepim-4.3.4-1.fc12, kdeplasma-addons-4.3.4-1.fc12, kdenetwork-4.3.4-1.fc12, kdemultimedia-4.3.4-1.fc12, kdegraphics-4.3.4-1.fc12, kdegames-4.3.4-1.fc12, kdeedu-4.3.4-1.fc12, kdebindings-4.3.4-1.fc12, kdeartwork-4.3.4-1.fc12, kdeadmin-4.3.4-1.fc12, kdeaccessibility-4.3.4-1.fc12, kdebase-runtime-4.3.4-2.fc12, kdebase-4.3.4-1.fc12, kdepimlibs-4.3.4-1.fc12, kdelibs-experimental-4.3.4-1.fc12, kdelibs-4.3.4-1.fc12, phonon-4.3.80-2.fc12, kde-settings-4.3-15.1, kdebase-workspace-4.3.4-3.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update kde-l10n kdeutils kdetoys kdesdk kdepim-runtime kdepim kdeplasma-addons kdenetwork kdemultimedia kdegraphics kdegames kdeedu kdebindings kdeartwork kdeadmin kdeaccessibility kdebase-runtime kdebase kdepimlibs kdelibs-experimental kdelibs phonon kde-settings kdebase-workspace'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F12/FEDORA-2009-13285
Comment 11 Fedora Update System 2009-12-21 23:52:14 EST
kde-l10n-4.3.4-1.fc12, kdeutils-4.3.4-2.fc12, kdetoys-4.3.4-1.fc12, kdesdk-4.3.4-1.fc12, kdepim-runtime-4.3.4-1.fc12, kdepim-4.3.4-1.fc12, kdeplasma-addons-4.3.4-1.fc12, kdenetwork-4.3.4-1.fc12, kdemultimedia-4.3.4-1.fc12, kdegraphics-4.3.4-1.fc12, kdegames-4.3.4-1.fc12, kdeedu-4.3.4-1.fc12, kdebindings-4.3.4-1.fc12, kdeartwork-4.3.4-1.fc12, kdeadmin-4.3.4-1.fc12, kdeaccessibility-4.3.4-1.fc12, kdebase-runtime-4.3.4-2.fc12, kdebase-4.3.4-1.fc12, kdepimlibs-4.3.4-1.fc12, kdelibs-experimental-4.3.4-1.fc12, phonon-4.3.80-2.fc12, kde-settings-4.3-15.1, oxygen-icon-theme-4.3.4-1.fc12, kdelibs-4.3.4-3.fc12, kdebase-workspace-4.3.4-3.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update kde-l10n kdeutils kdetoys kdesdk kdepim-runtime kdepim kdeplasma-addons kdenetwork kdemultimedia kdegraphics kdegames kdeedu kdebindings kdeartwork kdeadmin kdeaccessibility kdebase-runtime kdebase kdepimlibs kdelibs-experimental phonon kde-settings oxygen-icon-theme kdelibs kdebase-workspace'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F12/FEDORA-2009-13285
Comment 12 Fedora Update System 2009-12-28 15:08:41 EST
kde-l10n-4.3.4-1.fc12, kdeutils-4.3.4-2.fc12, kdetoys-4.3.4-1.fc12, kdesdk-4.3.4-1.fc12, kdepim-runtime-4.3.4-1.fc12, kdepim-4.3.4-1.fc12, kdeplasma-addons-4.3.4-1.fc12, kdenetwork-4.3.4-1.fc12, kdemultimedia-4.3.4-1.fc12, kdegraphics-4.3.4-1.fc12, kdegames-4.3.4-1.fc12, kdeedu-4.3.4-1.fc12, kdebindings-4.3.4-1.fc12, kdeartwork-4.3.4-1.fc12, kdeadmin-4.3.4-1.fc12, kdeaccessibility-4.3.4-1.fc12, kdebase-runtime-4.3.4-2.fc12, kdebase-4.3.4-1.fc12, kdepimlibs-4.3.4-1.fc12, kdelibs-experimental-4.3.4-1.fc12, phonon-4.3.80-2.fc12, kde-settings-4.3-15.1, oxygen-icon-theme-4.3.4-1.fc12, kdelibs-4.3.4-3.fc12, kdebase-workspace-4.3.4-3.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.