This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 545639 - hal-0.5.14-1 causing libck-connector failures in kdm
hal-0.5.14-1 causing libck-connector failures in kdm
Status: CLOSED DUPLICATE of bug 545267
Product: Fedora
Classification: Fedora
Component: ConsoleKit (Show other bugs)
12
All Linux
low Severity medium
: ---
: ---
Assigned To: jmccann
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-12-08 20:10 EST by Rex Dieter
Modified: 2015-01-14 18:24 EST (History)
14 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 545258
Environment:
Last Closed: 2009-12-22 11:42:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Rex Dieter 2009-12-08 20:10:28 EST
+++ This bug was initially created as a clone of Bug #545258 +++

hal-0.5.14-1.fc12 seems to induce a couple of bad behaviors in kde that isn't present with hal-0.5.13-9.fc12

1.  First attempt to login from kdm seems to fail/crash X, 2nd attempt works

2.  kde's brightness controls no longer seem to work, and are now stuck at 0 (dimmest setting).

I'm currently focussed on looking at 2.

--- Additional comment from rdieter@math.unl.edu on 2009-12-07 19:45:37 EDT ---

$ qdbus --system org.freedesktop.Hal /org/freedesktop/Hal/devices/computer_backlight org.freedesktop.Hal.Device.LaptopPanel.GetBrightness
7

This returns valid values, but

$ solid-powermanagement brightness get

Brightness is 0%

isn't very good.


During this, 

$ solid-powermanagement brightness set

continues to work.

--- Additional comment from rdieter@math.unl.edu on 2009-12-07 20:43:20 EDT ---

wrt, crash on first login, /var/log/messages contain,

Dec  7 19:33:30 localhost kdm: :0[1453]: Cannot open ConsoleKit session: Unable to open session: Launch helper exited with unknown return code 0
Dec  7 19:33:30 localhost kdm: :0[1453]: Client start failed
Dec  7 19:33:30 localhost kdm: :0[1453]: Cannot close ConsoleKit session: Unable to close session: no session open

weird, re-assigning to kdebase-workspace for further investigation.

--- Additional comment from kevin@tigcc.ticalc.org on 2009-12-07 23:02:53 EDT ---

This doesn't sound like KDM's fault, it's just echoing the error message given by libck-connector. Looks like talking to ConsoleKit is failing for some reason.

As for the KDE crash possibly related to no valid brightness, are you using Qt 4.6? See https://bugs.kde.org/show_bug.cgi?id=217805

--- Additional comment from rdieter@math.unl.edu on 2009-12-07 23:08:01 EDT ---

Stock stuff here,
qt-4.5.3-9.fc12.x86_64
kdebase-workspace-4.3.3-7.fc12.x86_64

SMParrish was able to reproduce these symptoms @ fudcon too.

--- Additional comment from richard@hughsie.com on 2009-12-08 03:00:39 EDT ---

(In reply to comment #1)
> $ qdbus --system org.freedesktop.Hal
> /org/freedesktop/Hal/devices/computer_backlight
> org.freedesktop.Hal.Device.LaptopPanel.GetBrightness
> 7
> 
> This returns valid values, but
> 
> $ solid-powermanagement brightness get
> 
> Brightness is 0%
> 
> isn't very good.

Surely this is a solid failure then?

--- Additional comment from kevin@tigcc.ticalc.org on 2009-12-08 08:10:27 EDT ---

Did something in HAL change incompatibly from 0.5.13 to 0.5.14?
Comment 1 Rex Dieter 2009-12-08 20:11:28 EST
Opened separate bug here to track the libck-connector/kdm failure separately.
Comment 2 Rex Dieter 2009-12-08 20:23:44 EST
Re-assigning to ConsoleKit to get them CC'd for comment.
Comment 3 Rex Dieter 2009-12-14 10:38:07 EST
To be clear, this particular problem only happens on the first attempt to login on a fresh boot, with kdm logging the failure to /var/log/messages,

Dec  7 19:33:30 localhost kdm: :0[1453]: Cannot open ConsoleKit session: Unable to open session: Launch helper exited with unknown return code 0

I've up/down-graded between hal-0.5.13-9 and hal-0.5.14-1 several times, with 0.5.13 being fine, 0.5.14 exhibiting this... very reproducible for me.
Comment 4 Rex Dieter 2009-12-22 11:42:52 EST
Interestingly, 2 of us that were experiencing this @ FUDCon, no longer see this since,
Dec 18 21:22:59 Updated: ConsoleKit-0.4.1-2.fc12.x86_64

Seems to be a side effect detailed in gdm as well,
https://bugzilla.redhat.com/show_bug.cgi?id=545267#c17

*** This bug has been marked as a duplicate of bug 545267 ***

Note You need to log in before you can comment on or make changes to this bug.