Bug 545638 - modem-manager trying to control non-wireless modem
modem-manager trying to control non-wireless modem
Status: CLOSED DUPLICATE of bug 533716
Product: Fedora
Classification: Fedora
Component: ModemManager (Show other bugs)
12
All Linux
low Severity medium
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-12-08 20:02 EST by Peter F. Patel-Schneider
Modified: 2010-01-18 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-01-18 17:07:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Peter F. Patel-Schneider 2009-12-08 20:02:19 EST
Description of problem:

I have a USB US Robotics modem - a real one that connects to wired phone lines.  It appears that modem-manager is trying to manage it, but this is not a wireless modem, so it is not doing anything useful, and is preventing me from using, e.g., wvdial.

Version-Release number of selected component (if applicable):

0.2 (from yum info ModemManager)

How reproducible:

Always (with this hardware)

Steps to Reproduce:
1. Connect USB US Robotics modem
2. Try to use wvdial
3.
  
Actual results:

--- /var/log/messages

Dec  8 14:59:03 idefix kernel: usb 1-5: new high speed USB device using ehci_hcd and address 5
Dec  8 14:59:03 idefix kernel: usb 1-5: New USB device found, idVendor=0baf, idProduct=0303
Dec  8 14:59:03 idefix kernel: usb 1-5: New USB device strings: Mfr=1, Product=2, SerialNumber=10
Dec  8 14:59:03 idefix kernel: usb 1-5: Product: USB Modem
Dec  8 14:59:03 idefix kernel: usb 1-5: Manufacturer: U.S.Robotics
Dec  8 14:59:03 idefix kernel: usb 1-5: SerialNumber: 0000002
Dec  8 14:59:03 idefix kernel: usb 1-5: configuration #2 chosen from 1 choice
Dec  8 14:59:03 idefix kernel: cdc_acm 1-5:2.0: ttyACM2: USB ACM device
Dec  8 14:59:03 idefix modem-manager: (ttyACM2) opening serial device...

idefix 102> wvdial
--> WvDial: Internet dialer version 1.60
--> Cannot open /dev/ttyACM2: Device or resource busy
--> Cannot open /dev/ttyACM2: Device or resource busy
--> Cannot open /dev/ttyACM2: Device or resource busy

Expected results:

wvdial dials and opens a connection

Additional info:

A workaround should be to disable modem-manager, but I can't even figure out how to do that.
Comment 1 Dan Williams 2009-12-08 22:04:13 EST
This is apparently a kernel issue in 2.6.31 where the modem or kernel blocks modem-manager's serial port communication.  What *should* be happening is that modem-manager probes the device, finds it does not support mobile broadband, and then forgets about it.  There are other reports of this problem happening with mobile broadband devices (https://bugzilla.redhat.com/show_bug.cgi?id=533716) so it's not unique to your device.
Comment 2 Dan Williams 2010-01-18 17:07:06 EST

*** This bug has been marked as a duplicate of bug 533716 ***

Note You need to log in before you can comment on or make changes to this bug.