Bug 54578 - New python diskcheck has several errors in default config file, script
Summary: New python diskcheck has several errors in default config file, script
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: diskcheck (Show other bugs)
(Show other bugs)
Version: 7.3
Hardware: i386 Linux
medium
high
Target Milestone: ---
Assignee: Preston Brown
QA Contact:
URL:
Whiteboard:
Keywords:
: 54795 57224 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-10-12 20:44 UTC by Aleksey Nogin
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-11-07 15:37:55 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
A patch that fixes all these problems with the script (but not the conf file). (2.16 KB, patch)
2001-10-12 21:34 UTC, Aleksey Nogin
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2001:152 normal SHIPPED_LIVE New diskcheck program available 2001-11-07 05:00:00 UTC

Description Aleksey Nogin 2001-10-12 20:44:55 UTC
The value of defaultCutoff is never used (it should be).

The diskcheck.conf still has the perl syntax in the examples of setting
the cutoff values.

Lots of redundancies:
 - For some reason the code calls "df" and "df -h" while the "df -h"
   already has all the necessary information.
 - In the
      if (test or ...): ... elseif (test or ...): ...
   construction the second "test or" is unneeded.
 - tempfile is defined and never used.

Comment 1 Aleksey Nogin 2001-10-12 20:59:26 UTC
Also, "-x none" should be added to exclude in diskcheck.conf to exclude "bind"
mounts and "-x tmpfs" to exclude the /dev/shm mount.

Comment 2 Aleksey Nogin 2001-10-12 21:33:12 UTC
And finally, the pct is never converted from a string to a number, so all
comparisons return random results!

Comment 3 Aleksey Nogin 2001-10-12 21:34:50 UTC
Created attachment 34021 [details]
A patch that fixes all these problems with the script (but not the conf file).

Comment 4 Preston Brown 2001-11-07 15:35:38 UTC
*** Bug 54795 has been marked as a duplicate of this bug. ***

Comment 5 Preston Brown 2001-11-07 15:38:22 UTC
fixed in an upcoming errata.


Comment 6 Harald Hoyer 2001-12-14 13:12:49 UTC
*** Bug 57224 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.