Bug 54629 - I have hadq to login 7 (SEVEN) times to load a uery, modify it, save it, and run it
I have hadq to login 7 (SEVEN) times to load a uery, modify it, save it, and ...
Status: CLOSED DUPLICATE of bug 151237
Product: Bugzilla
Classification: Community
Component: Bugzilla General (Show other bugs)
2.8
i386 Linux
high Severity high (vote)
: ---
: ---
Assigned To: David Lawrence
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-10-14 05:21 EDT by j. alan eldridge
Modified: 2005-10-31 17:00 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-07 12:59:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description j. alan eldridge 2001-10-14 05:21:28 EDT
Description of Problem:

The damned cookie handling is broken. Still. As in not fixed. Ever. It's been an 
illusion that it sometimes works.

Goto Q page.
Login.
Load query.
No longer logged in.
Login.
Goto Q page.
Login.
Load query.
No longer logged in.
Goto Q page.
Login.
Load query.
Modify query & save.
Login.
Not logged in.
Login.
Run remembered query.
Login.

This is as best as my now-dizzy mind can lay down the steps. Check the server 
log. You should be able to see the exact sequence of page gets / submits from 
that.

Browser is Konqueror from KDE 2.2.1-cvs.20011006.



Version-Release number of selected component (if applicable):


How Reproducible:


Steps to Reproduce:
1. 
2. 
3. 

Actual Results:


Expected Results:


Additional Information:
Comment 1 David Lawrence 2001-10-14 15:23:51 EDT
Does this continue to happen if you delete any old bugzilla.redhat.com cookies 
and start over from scratch?

Click on Settings->Configure Konqueror->Cookies->Management->Delete cookies 
with bugzilla.redhat.com domain->Apply.

FWIW, I made this report change using Konqueror 2.2.1 with no problems.
Comment 2 j. alan eldridge 2001-10-16 10:33:53 EDT
I've done that drill N times. It seems to be a short help. If I have to manually go and 
whack bugzilla cookies before I use it each time, that's not much of a fix, really.

It seems to be, among other things, the query page that fscks things up. Passing 
through there seems to leave a stain on the session. Another thing that happens is, 
update a bug you just entered, to add an attachment, and whoops! hit the attach 
button, gotta login, and then, oh, your attachment failed, do it over again.

There's just something fundamentally wrong with the way the session management is 
done in bugzilla. I have neither the experience with web apps nor the time needed to 
learn that to audit the thing myself. But that's what I'd suggest at this point: a 
complete code audit for session management errors. The fact that these things 
always come down to 'did you whack the cookies first?' indicates that it must not be 
getting handled correctly.

I'm using Konquerer 2.2.1 from CVS 20011011 and ALWAYS have problems. 
ALWAYS. Have since sometime in the Konquere 2.2alpha1 stages. Consistently.
This problem has been consistently happening in all versions of Konq since July.
And I've done clean KDE installs, removing my .kde dir, too. My RPMs are built with 
Bero's spec files modulo removing patches that are in the tree now.

It's not Konq. It happens, though not a badly it seems, with Mozilla, from 0.9.1 on 
through 0.9.5. 

I won't accept that every KDE installation I've done in the last 4 months is bolloxed 
up, and I won't accept that both my KDE and Mozilla installations are bolloxed up.
Comment 3 Jón Fairbairn 2003-06-04 16:45:36 EDT
I've been experiencing this problem on and off for ages.

Just now I had a look at the cookies and noticed that there were two
copies of several of them. I removed them all and for the moment it's
behaving itself.

Interestingly one set used <login>@cl.cam.ac.uk
and the other <login>%40cl.cam.ac.uk.  Could that be a source of trouble?

(aside: it's bollocks or bollixed, rather than bollox according to the OED)
Comment 4 Need Real Name 2005-04-14 05:50:39 EDT
Fixed? Dupe of bug 151237?
Comment 5 Jón Fairbairn 2005-04-14 06:28:05 EDT
I haven't encountered this problem for some time, so probably yes.
Comment 6 Rahul Sundaram 2005-09-07 12:59:39 EDT

*** This bug has been marked as a duplicate of 151237 ***

Note You need to log in before you can comment on or make changes to this bug.