Bug 151237 - cookie not being read?
cookie not being read?
Status: CLOSED CURRENTRELEASE
Product: Bugzilla
Classification: Community
Component: Bugzilla General (Show other bugs)
2.18
All Linux
medium Severity medium (vote)
: ---
: ---
Assigned To: David Lawrence
David Lawrence
:
: 54629 131973 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-16 05:08 EST by Need Real Name
Modified: 2007-04-18 13:20 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-11 10:34:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2005-03-16 05:08:46 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3) Gecko/20041020 Epiphany/1.4.4

Description of problem:
(Description says "current version is 2.17", it's 2.18)

If I enter a new bug, I am constantly asked to login during the bug entry process.
It seems a bit erratic..

Cookies are on.

Version-Release number of selected component (if applicable):


How reproducible:
Sometimes

Steps to Reproduce:
x

Additional info:
Comment 1 Need Real Name 2005-03-16 05:09:36 EST
..for example, it didn't ask me just then.

Just then, I went to "Log in" BEFORE starting to enter a bug.
Maybe that makes a difference.
Comment 2 David Lawrence 2005-03-16 10:41:03 EST
Does this continue to occur if you remove your cookies that relate to
bugzilla.redhat.com completely using your browser's preferences? It may be an
incompatibility with the cookie that the old BZ used to set.
Comment 3 Need Real Name 2005-03-16 10:50:01 EST
Yes it does.

It seems the cookie doesn't get noticed unless I explicitly click on the "Login"
link. Then the "Login" link changes to the usual "My front page" link, even
though I wasn't prompted to re-enter my username and password.
Comment 4 David Lawrence 2005-03-16 11:14:25 EST
Ok, found the problem now. Does it work now?
Comment 5 Need Real Name 2005-03-16 11:40:07 EST
It's definitely better. I can click on bug links in bugzilla e-mails, and I'm
remembered.
But if I manually go to the bugzilla page, and am logged out, I must continually
reauthenticate when I open a new bug.
Comment 6 Aaron VanDevender 2005-03-21 15:28:24 EST
I have some cookies that are being with the path of "/beta" and some with
"/bugzilla." I think maybe we are setting the /beta ones on some pages and they
obviously aren't getting played back to the server since we are viewing
/bugzilla pages.
Comment 7 David Lawrence 2005-03-21 15:50:09 EST
*** Bug 131973 has been marked as a duplicate of this bug. ***
Comment 8 David Lawrence 2005-03-22 11:59:29 EST
If you only work with /bugzilla, there should not be anywhere that /beta is
being set as a cookie. I still have the /beta around for people who have not
changed their bookmarks and/or are using XMLRPC scripts that point to /beta. I
could add a redirect to the Apache config that will redirect automatically but I
figured I would just wait a little while and remove the /beta link altogether.
Does this all work for you if you permanently remove the /beta cookies using
your browser's pereferences and use only /bugzilla?
Comment 9 Need Real Name 2005-03-23 16:01:38 EST
It just happenned again. I had no cookies, and a fresh start of epiphany.

I went to bugzilla.redhat.com, tried to enter a bug. Was asked to log in, did,
kept entering bug, was asked to login again. Ack!
Comment 10 Need Real Name 2005-03-23 16:05:31 EST
If I watch when the cookies are being stored, no cookies are stored when I
initially login (i.e. from
https://bugzilla.redhat.com/bugzilla/easy_enter_bug.cgi?action=second)

(Even if I change my cookie setting to "allow all cookies" from "allow cookies
from sites you visit", I get the same behaviour)
Comment 11 Need Real Name 2005-04-11 10:34:52 EDT
WFM
Comment 12 Rahul Sundaram 2005-09-07 12:59:53 EDT
*** Bug 54629 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.