Bug 546509 - Crash in tooltip on_style_set ()
Summary: Crash in tooltip on_style_set ()
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: metacity
Version: 12
Hardware: i686
OS: Linux
low
medium
Target Milestone: ---
Assignee: Owen Taylor
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:4937a22209c09040d11dba08911...
: 543192 546754 547187 547360 547486 547884 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-12-11 03:04 UTC by mdmpsyd@gmail.com
Modified: 2009-12-27 20:27 UTC (History)
9 users (show)

Fixed In Version: 2.28.0-13.fc12
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-12-27 20:27:33 UTC


Attachments (Terms of Use)
File: backtrace (7.23 KB, text/plain)
2009-12-11 03:04 UTC, mdmpsyd@gmail.com
no flags Details

Description mdmpsyd@gmail.com 2009-12-11 03:04:06 UTC
abrt 1.0.0 detected a crash.

Attached file: backtrace
cmdline: metacity
component: metacity
executable: /usr/bin/metacity
kernel: 2.6.31.6-162.fc12.i686.PAE
package: metacity-2.28.0-11.fc12
rating: 4
reason: Process was terminated by signal 11 (Segmentation fault)

Comment 1 mdmpsyd@gmail.com 2009-12-11 03:04:08 UTC
Created attachment 377659 [details]
File: backtrace

Comment 2 Owen Taylor 2009-12-11 13:26:55 UTC
Program terminated with signal 11, Segmentation fault.
#0  on_style_set (widget=<value optimized out>, prev=<value optimized out>)
    at ui/fixedtip.c:263
263	                             widget->style->xthickness,

===
static void
on_style_set (GtkWidget *widget, GtkStyle *prev)
{
  GtkWidget *alignment;

  alignment = gtk_bin_get_child (GTK_BIN (widget));
  gtk_alignment_set_padding (GTK_ALIGNMENT (alignment),
                             widget->style->ythickness,
                             widget->style->ythickness,
                             widget->style->xthickness,
                             widget->style->xthickness);
  gtk_widget_queue_draw (widget);
}

[...]

g_signal_connect_swapped (tip, "style-set",
                           G_CALLBACK (on_style_set), NULL);
===

The usage of _swapped() is in error here, right?

Comment 3 Matthias Clasen 2009-12-11 18:28:51 UTC
> The usage of _swapped() is in error here, right?  

Yeah, obviously.

Comment 4 Owen Taylor 2009-12-11 21:12:01 UTC
*** Bug 546754 has been marked as a duplicate of this bug. ***

Comment 5 Owen Taylor 2009-12-14 15:33:33 UTC
*** Bug 547360 has been marked as a duplicate of this bug. ***

Comment 6 Owen Taylor 2009-12-14 15:36:42 UTC
*** Bug 547187 has been marked as a duplicate of this bug. ***

Comment 7 Owen Taylor 2009-12-14 19:32:18 UTC
*** Bug 547486 has been marked as a duplicate of this bug. ***

Comment 8 Owen Taylor 2009-12-15 22:14:51 UTC
*** Bug 547884 has been marked as a duplicate of this bug. ***

Comment 9 Owen Taylor 2009-12-15 22:25:09 UTC
*** Bug 547890 has been marked as a duplicate of this bug. ***

Comment 10 Owen Taylor 2009-12-17 19:13:29 UTC
*** Bug 543192 has been marked as a duplicate of this bug. ***

Comment 11 Fedora Update System 2009-12-22 04:38:31 UTC
metacity-2.28.0-13.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update metacity'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F12/FEDORA-2009-13084

Comment 12 Fedora Update System 2009-12-27 20:27:04 UTC
metacity-2.28.0-13.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.