Bug 546721 - gdm/X doesn't start
gdm/X doesn't start
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: plymouth (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-12-11 14:27 EST by darrell pfeifer
Modified: 2010-04-21 12:44 EDT (History)
17 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-04-21 12:44:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
:0-slave.log logfile (17.57 KB, text/plain)
2010-04-14 14:36 EDT, Paul Dickson
no flags Details
:0-slave.log logfile when GDM does not start (2.58 KB, text/plain)
2010-04-14 14:37 EDT, Paul Dickson
no flags Details

  None (edit)
Description darrell pfeifer 2009-12-11 14:27:56 EST
Description of problem:

Updated my machine from koji (I realize the rawhide compose with this version hasn't happened yet). This did get the updated initscripts and plymouth.

After a reboot, booting stops when plymouth is done. Can't use ctrl-alt-f2 to get to a console.

Rebooting at runlevel 3 and doing a startx works.

Rebooting at runlevel 3 and doing a telinit 5 works.


Version-Release number of selected component (if applicable):

upstart-0.6.3-3.fc13.x86_64
initscripts-9.03-1.x86_64
plymouth-0.8.0-0.2009129.fc13.x86_64

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Tom London 2009-12-11 14:36:10 EST
Works for me if I hit "ESC" at the initial plymouth screen.  I watch the text reports of the services starting (with "OK" at the end of each line), and then get X/gdm screen.

Does not work (as reported in #1) if I allow plymouth screen to run uniterrupted.
Comment 2 iarly selbir 2009-12-11 14:53:41 EST
Did you try to downgrade initscripts and check if all works again.

Maybe that's not a initscripts problem.


Thanks your report and waiting for news.

--
Fedora Bugzappers Team Member
Comment 3 Bill Nottingham 2009-12-11 14:59:36 EST
Is it only the details plugin that works? Have you tried disabling modesetting?
Comment 4 darrell pfeifer 2009-12-11 15:08:53 EST
nomodeset works
Comment 5 Bill Nottingham 2009-12-11 20:18:24 EST
OK, assigning to plymouth.
Comment 6 Tom London 2009-12-17 09:14:06 EST
Seems to be working for me now (without 'nomodeset'), but no changes to initscipts, plymouth or upstart.

Booting now goes to gdm login screen/etc. without entering ESC at plymouth screen.

Not sure what has changed.....
Comment 7 Bug Zapper 2010-03-15 09:32:50 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 13 development cycle.
Changing version to '13'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 8 Hiemanshu Sharma 2010-04-13 07:38:05 EDT
Well I have the same error with Plymouth and KDM. I can boot fine without the rhgb quite line and it works well, otherwise I am just stuck at the fedora logo at the end of the plymouth theme.
Comment 9 Markus Mayer 2010-04-14 10:37:45 EDT
Same problem here using GDM.
Disabling rhgb or pressing ESC while plymouth shows up helps.

Smoltprofile:
http://www.smolts.org/show?uuid=pub_748daccf-258a-4ace-ac61-39957a414148+

I am using Fedora13
Comment 10 Ray Strode [halfline] 2010-04-14 10:47:41 EDT
Lothar what version of

plymouth and gdm do you have installed?
Comment 11 Paul Dickson 2010-04-14 14:36:20 EDT
Created attachment 406599 [details]
:0-slave.log logfile
Comment 12 Paul Dickson 2010-04-14 14:37:47 EDT
Created attachment 406600 [details]
:0-slave.log logfile when GDM does not start
Comment 13 Paul Dickson 2010-04-14 14:46:02 EDT
I can duplicate this issue.  GDM does not start unless I press ESC during plymouth.

I added the :0-slave files (bugzilla wanted to add the files separately, sorry) for the cases with and without pressing ESC.

plymouth-0.8.1-3.fc13.i686
gdm-2.29.92-5.fc13.i686

When GDM does not display, ps only has Xorg running under gdm-simple-slave:

/usr/bin/Xorg :0 -br -verbose -auth /var/run/gdm/auth-for-gdm-li7M6f/database -nolisten tcp
Comment 14 Ray Strode [halfline] 2010-04-14 15:57:19 EDT
you need gdm-2.29.92-6 or later
Comment 15 Adam Williamson 2010-04-14 17:07:12 EDT
those hitting this issue recently are seeing bug #577789 . It was identified and fixed but due to insufficient safeguards in Koji, an older gdm package got into the repos recently, so the problem has come back. This should be fixed tomorrow.

Leaving this report open as it pre-dates that bug, so the original reporter here has a different (and more user-specific) issue.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 16 Markus Mayer 2010-04-15 08:14:39 EDT
I am using gdm-2.29.92-5.

I am not able to test 2.29.92-6 because I am using a live image. As far as a updated live image is available I will continue testing.
Comment 17 Ville-Pekka Vainio 2010-04-15 16:05:58 EDT
Just making a note that I'm seeing this with the Intel Test Day gfx_test_week_20100414_i686.iso spin on this hardware: http://www.smolts.org/client/show/pub_528c8204-8c24-426f-8785-50d76ead6232
Comment 18 Adam Williamson 2010-04-15 16:21:12 EDT
that's definitely not 577789. hard to know if it's the same bug as the OP here, though.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 19 eric@christensenplace.us 2010-04-17 10:40:22 EDT
This appears to be fixed, now.  At least it works for me.
Comment 20 Ville-Pekka Vainio 2010-04-20 13:02:50 EDT
This seems to be fixed for me in desktop-i386-20100418.17.iso
Comment 21 Adam Williamson 2010-04-20 15:25:40 EDT
darrell, are you around? Any update from you? Thanks!



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 22 darrell pfeifer 2010-04-20 15:46:06 EDT
I've held off because I've moved on to a different version. I'm a koji junkie (well past being a rawhide junkie)

In the current rawhide/koji, the problem is fixed for me.
Comment 23 Adam Williamson 2010-04-20 16:22:25 EDT
are you using the fc13 or fc14 stuff from koji?



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 24 darrell pfeifer 2010-04-20 16:28:13 EDT
I'm totally fc14.
Comment 25 Markus Mayer 2010-04-21 06:27:47 EDT
This seems to be fixed for me in desktop-i386-20100418.17.iso (gdm-2.29.92-6), too
Comment 26 Adam Williamson 2010-04-21 12:44:26 EDT
well, let's split the difference and close the bug, since no-one seems to be having trouble any more; it's possible Darrell's situation is broken in f13, but we can't really check that. Darrell, if you do get to testing f13 and find the bug is still there, please re-open or file a new bug. Thanks.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Note You need to log in before you can comment on or make changes to this bug.