Bug 577789 - Transition to GDM does not work, screen hangs
Transition to GDM does not work, screen hangs
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: plymouth (Show other bugs)
13
All Linux
high Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
Fedora Extras Quality Assurance
:
: 577504 579450 581887 (view as bug list)
Depends On:
Blocks: F13Beta/F13BetaBlocker
  Show dependency treegraph
 
Reported: 2010-03-29 05:03 EDT by Kamil Páral
Modified: 2013-01-10 00:48 EST (History)
13 users (show)

See Also:
Fixed In Version: plymouth-0.8.1-1.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-03-31 00:46:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
system logs (180.00 KB, application/x-tar)
2010-03-29 09:07 EDT, Kamil Páral
no flags Details

  None (edit)
Description Kamil Páral 2010-03-29 05:03:42 EDT
Description of problem:
Since the last upgrade of plymouth (I believe) the transition to GDM stopped working. When I have just a single screen, the last image of graphical plymouth sequence (fedora logo on blue screen) hangs indefinitely - no transition to GDM. When connected in dual screen, plymouth last image changes to black screen on both screens and again it hangs indefinitely, no GDM. However, it seems that everythings is working (GDM is started), because I can restart computer by Ctrl+Alt+Delete, or by SysRQ. But I don't see anything. Neither I can switch to VT (maybe I can, but I don't see anything). There doesn't seem to be any error message in the logs (the last message from X server is "GdmSimpleSlave: Started X server").

Important: When I press ESC during boot and therefore switch from graphical plymouth boot to text plymouth boot, everythings works just fine, GDM appears.

It seems that graphical plymouth boot somehow disables screen output or something like that.

Version-Release number of selected component (if applicable):
plymouth-gdm-hooks-0.8.1-1.fc13.x86_64
plymouth-graphics-libs-0.8.1-1.fc13.x86_64
plymouth-system-theme-0.8.1-1.fc13.x86_64
plymouth-plugin-label-0.8.1-1.fc13.x86_64
plymouth-core-libs-0.8.1-1.fc13.x86_64
plymouth-utils-0.8.1-1.fc13.x86_64
plymouth-scripts-0.8.1-1.fc13.x86_64
plymouth-0.8.1-1.fc13.x86_64
plymouth-plugin-two-step-0.8.1-1.fc13.x86_64
plymouth-theme-charge-0.8.1-1.fc13.x86_64

How reproducible:
always
Comment 1 Kamil Páral 2010-03-29 09:07:24 EDT
Created attachment 403287 [details]
system logs

I used plymouth:debug kernel line to boot. I had dual monitor setup and didn't cancel the graphical boot, so it stuck with black screen. These are the logs from that attempt. I don't see any errors.
Comment 2 Kamil Páral 2010-03-29 09:09:06 EDT
I have downgraded plymouth to:

plymouth-plugin-label-0.8.0-0.20100305.1.fc13.x86_64
plymouth-scripts-0.8.0-0.20100305.1.fc13.x86_64
plymouth-0.8.0-0.20100305.1.fc13.x86_64
plymouth-theme-charge-0.8.0-0.20100305.1.fc13.x86_64
plymouth-core-libs-0.8.0-0.20100305.1.fc13.x86_64
plymouth-utils-0.8.0-0.20100305.1.fc13.x86_64
plymouth-system-theme-0.8.0-0.20100305.1.fc13.x86_64
plymouth-graphics-libs-0.8.0-0.20100305.1.fc13.x86_64
plymouth-gdm-hooks-0.8.0-0.20100305.1.fc13.x86_64
plymouth-plugin-two-step-0.8.0-0.20100305.1.fc13.x86_64

The problem is still present, it is not caused by recent plymouth update. Maybe it's caused by some other component? How to find out?
Comment 3 Kamil Páral 2010-03-29 11:27:31 EDT
According to halfline, this big could be resolved by updating gdm:
https://admin.fedoraproject.org/updates/gdm-2.29.92-6.fc13,plymouth-0.8.1-1.fc13?_csrf_token=5039bb596b3e193f24d8245b3e1f87bb41d3ad8d

I will try that and report back.
Comment 4 Kamil Páral 2010-03-29 12:01:07 EDT
gdm-2.29.92-6.fc13 fixes this issue. Now we just need to push it to updates-testing.
Comment 5 Joachim Backes 2010-03-29 13:08:59 EDT
(In reply to comment #4)
> gdm-2.29.92-6.fc13 fixes this issue. Now we just need to push it to
> updates-testing.    

Bingo, works for me.
Comment 6 James Laska 2010-03-29 13:51:04 EDT
Should this be in MODIFIED?
Comment 7 Fedora Update System 2010-03-29 13:53:50 EDT
gdm-2.29.92-6.fc13,plymouth-0.8.1-1.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/gdm-2.29.92-6.fc13,plymouth-0.8.1-1.fc13
Comment 8 Aram Agajanian 2010-03-29 22:49:24 EDT
*** Bug 577504 has been marked as a duplicate of this bug. ***
Comment 9 hannes 2010-03-30 02:01:50 EDT
The gdm-2.29.92-6.fc13,plymouth-0.8.1-1.fc13 package worked for me! Installed it from Koji and the problem is gone!
Thanks...
Comment 10 Adam Williamson 2010-03-30 11:51:57 EDT
does oxf13 know to pull this into rc2?



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 11 James Laska 2010-03-30 12:01:55 EDT
(In reply to comment #10)
> does oxf13 know to pull this into rc2?

Initially, I'm content to keep these in updates-testing.  However, the updates have since received critpath approval from rel-eng and qa.  So technically they could be pulled into RC2, do we want them?
Comment 12 Jesse Keating 2010-03-30 18:30:15 EDT
I can pull them into an RC2 I'm going to prepare tonight.
Comment 13 Adam Williamson 2010-03-30 23:04:59 EDT
it's a beta blocker, so yes, we want them. boot failing with plymouth enabled is not a good thing. :)



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 14 Fedora Update System 2010-03-31 00:46:32 EDT
plymouth-0.8.1-1.fc13, gdm-2.29.92-6.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 15 Ray Strode [halfline] 2010-03-31 16:34:41 EDT
Adam, note boot was never failing for the beta.

This problem was entirely isolated to users who had plymouth in updates-testing without gdm in updates-testing
Comment 16 Ray Strode [halfline] 2010-04-05 11:14:25 EDT
*** Bug 579450 has been marked as a duplicate of this bug. ***
Comment 17 Adam Williamson 2010-04-14 17:08:07 EDT
This bug has come back from the dead because an older gdm package mistakenly got into the f13 repos: 2.29.92-5.fc13 came back. We've identified the cause of this and it should be fixed tomorrow, 2.29.92-6.fc13 should return then.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 18 Björn Persson 2010-04-16 10:11:13 EDT
*** Bug 581887 has been marked as a duplicate of this bug. ***
Comment 19 Iwao Yagami 2010-05-30 07:19:12 EDT
I am having this exact issue all over again. The GDM transition is hanging, allowing the mouse image to be seen, but on a black background and no prompts are displayed. This time around I can switch to another terminal (writing this from Lynx on tty3, actually). System is fully updated and has been working fine since install (a few days). Came out of the blue.
Comment 20 QFanatic 2010-10-18 12:39:53 EDT
This bug seems to have returned again.  Identical symptoms to those listed above. Everything updated to latest and was working fine.

Selected an earlier kernel version (147) vs latest (56) and it did not re-occur.  Tried again with latest kernel and problem re-occurred.
Comment 21 Adam Williamson 2010-10-18 17:31:26 EDT
if changing the kernel fixes it, it's not the same as this bug, it's a problem with the part of the graphics driver that lives in the kernel. Please file a new bug against xorg-x11-drv-intel , xorg-x11-drv-ati or xorg-x11-drv-nouveau (depending on your graphics adapter). Thanks!



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Note You need to log in before you can comment on or make changes to this bug.