Bug 54719 - nautilus won't work over remote X
Summary: nautilus won't work over remote X
Status: CLOSED DEFERRED
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: nautilus   
(Show other bugs)
Version: 7.3
Hardware: All Linux
medium
high
Target Milestone: ---
Assignee: Havoc Pennington
QA Contact: Aaron Brown
URL:
Whiteboard:
Keywords:
: 55240 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-10-16 20:58 UTC by Chris Ricker
Modified: 2007-04-18 16:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-02-27 06:26:18 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Chris Ricker 2001-10-16 20:58:26 UTC
I use XDMCP a lot.  I recently tried running nautilus remotely over it, and
discovered that it dies instantly on startup.  The problem, I would guess,
is that the object broker isn't getting forwarded to the remote display.

Looks like Yet Another Reason KDE and GMC Are Better Than Nautilus.

Comment 1 Josep Guallar-Esteve 2001-11-13 19:49:47 UTC
I have succesfully run Nautilus over the network through ssh login. I am using the 
current IA64 beta.


Comment 2 Mike A. Harris 2001-12-01 12:43:24 UTC
Doesn't work for me either during s390 testing


Comment 3 Havoc Pennington 2001-12-01 17:47:38 UTC
Are you running your whole session remotely, or just Nautilus while you are also
logged in elsewhere. GNOME doesn't like two open sessions at once, at the moment.

Comment 4 Chris Ricker 2001-12-01 18:29:13 UTC
Whole session.  That's kinda by definition when you're doing XDMCP, after all....

Comment 5 Chris Ricker 2002-02-27 06:26:13 UTC
This is still true with RH 7.2 release + all errata.  nautilus works only
intermittently over XDMCP.

Here's what I experienced this afternoon.  I had two machines, thing1 and
thing2.  thing1 was configured with gdm listening to XDMCP direct queries, and I
was logged in on thing2 in X.  I brought up xnest -query thing1, and it
connected to thing1 and I logged in, selecting gnome.  gnome started up in the
nested X server on thing2, but nautilus displayed on thing1.  When I then exited
out of xnest and lathered, rinsed, repeated, nautilus displayed in xnest on
thing2 the second time.

Comment 6 Havoc Pennington 2002-02-27 17:41:28 UTC
At this point we are moving to new development on GNOME 2; it attempts to
address logging in more than once on separate machines in a more comprehensive way.

Backporting the architecture changes required to handle this to GNOME 1 isn't 
planned, but things should work or be fairly easy to fix once we migrate to GNOME 2.

Comment 7 Havoc Pennington 2002-02-27 19:22:49 UTC
*** Bug 55240 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.