Bug 55240 - In a 2nd Xsession on one display, nautilus opens in screen 0
In a 2nd Xsession on one display, nautilus opens in screen 0
Status: CLOSED DUPLICATE of bug 54719
Product: Red Hat Linux
Classification: Retired
Component: nautilus (Show other bugs)
7.2
athlon Linux
medium Severity low
: ---
: ---
Assigned To: Havoc Pennington
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-10-27 22:00 EDT by Joe Krahn
Modified: 2007-04-18 12:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-12-12 13:32:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joe Krahn 2001-10-27 22:00:26 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.78 [en] (X11; U; Linux 2.4.9-7 i686)

Description of problem:
If I launch a 2nd Xsession on one display, Nautilus opens in the first
screen. When that 2nd Xsession ends, Nautilus stays open in the first but
all of the side-bars crash. Possibly related, the 2nd Xsession has no
desktop icons. Other gnome startup apps work OK.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Start from a default .gnome with "start-here" (May occur from
non-default .gnome as well)
2. Login to an X session.
3. Start a 2nd X session:  startx -- :1
4. Switch to the first X session: Ctrl-Alt-F7
5. Go back and log out of X session 2 
	

Actual Results:  At step 3, things look OK, but no Nautilus.
At step 4: there it is in screen :0
At step 5: that 2nd nautilus is now unhappy.

Expected Results:  X session :1 should work just like X session :0

Additional info:

Probably doesn't affect many people since most people only do one Xsession.
Comment 1 Kyle Bateman 2001-11-10 16:38:54 EST
I have the same problem.  Any time a user is logged in to the same server more
than once, all nautilus sessions start on the first X session created.  All
subsequent sessions are useless as there is no file manager.

Is there a workaround for this?  I have several users that need to be logged in
on more than one terminal at a time.  What's more, I haven't been able to figure
out how to switch gnome back to gmc (it doesn't seem to be in the toolkit anyway).
Comment 2 Joe Krahn 2001-11-11 10:32:50 EST
I found that deleting the /tmp/orbit-username directory prevents this problem.
So, the proper workaround would probably be to set a different ORBit directory
or a different ORBit username, but I don't think that is possible. (If not, it
should be.) I don't know the consequences of regularly deleting /tmp/orbit-user,
but it might work. A possible ugly hack would be to create a set of ORBit lib
files with /tmp/orbit- changed, and set LD_LIBRARY_PATH for the 2nd server.
Comment 3 Havoc Pennington 2001-11-12 14:06:14 EST
I'm told that this is relatively easy to get working now (there is a way to
convince bonobo-activation to make a component per-display). But there's still
some engineering involved.
Comment 4 Ralph Rodriguez 2001-12-12 13:32:42 EST
I ran into the bug using Xnest.  In /etc/X11/gdm/gdm.conf, I set:
	[xdmcp]
	Enable=1
and then ran:
	Xnest -query hostname :1 &
I logged onto the display manager using gnome.  The nautilus window
appeared in the main window, not the nested window.  The nautilus
program seems stable, though.  That is, no crashes.
Comment 5 Havoc Pennington 2002-02-27 14:22:53 EST

*** This bug has been marked as a duplicate of 54719 ***

Note You need to log in before you can comment on or make changes to this bug.