Bug 547339 - SELinux is preventing /usr/sbin/vsftpd "net_raw" access.
SELinux is preventing /usr/sbin/vsftpd "net_raw" access.
Status: CLOSED DUPLICATE of bug 537428
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
12
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Eric Paris
Fedora Extras Quality Assurance
setroubleshoot_trace_hash:c6058ce94b6...
:
: 545675 550657 552726 553188 557551 558884 559922 561865 562638 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-12-14 07:35 EST by Mihai Harpau
Modified: 2010-02-09 18:21 EST (History)
14 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-02-09 18:21:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Mihai Harpau 2009-12-14 07:35:01 EST
Summary:

SELinux is preventing /usr/sbin/vsftpd "net_raw" access.

Detailed Description:

SELinux denied access requested by vsftpd. It is not expected that this access
is required by vsftpd and this access may signal an intrusion attempt. It is
also possible that the specific version or configuration of the application is
causing it to require additional access.

Allowing Access:

You can generate a local policy module to allow this access - see FAQ
(http://fedora.redhat.com/docs/selinux-faq-fc5/#id2961385) Please file a bug
report.

Additional Information:

Source Context                system_u:system_r:ftpd_t:s0-s0:c0.c1023
Target Context                system_u:system_r:ftpd_t:s0-s0:c0.c1023
Target Objects                None [ capability ]
Source                        vsftpd
Source Path                   /usr/sbin/vsftpd
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           vsftpd-2.2.0-5.fc12
Target RPM Packages           
Policy RPM                    selinux-policy-3.6.32-56.fc12
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Plugin Name                   catchall
Host Name                     (removed)
Platform                      Linux (removed) 2.6.31.6-166.fc12.x86_64 #1 SMP Wed
                              Dec 9 10:46:22 EST 2009 x86_64 x86_64
Alert Count                   8
First Seen                    Lu 14 dec 2009 14:10:50 +0000
Last Seen                     Lu 14 dec 2009 14:25:37 +0000
Local ID                      659a4709-8ad9-45fa-a3ec-108465d6a454
Line Numbers                  

Raw Audit Messages            

node=(removed) type=AVC msg=audit(1260793537.404:87): avc:  denied  { net_raw } for  pid=9524 comm="vsftpd" capability=13 scontext=system_u:system_r:ftpd_t:s0-s0:c0.c1023 tcontext=system_u:system_r:ftpd_t:s0-s0:c0.c1023 tclass=capability

node=(removed) type=SYSCALL msg=audit(1260793537.404:87): arch=c000003e syscall=56 success=no exit=-1 a0=40000011 a1=0 a2=7fd1f445084e a3=0 items=0 ppid=0 pid=9524 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm="vsftpd" exe="/usr/sbin/vsftpd" subj=system_u:system_r:ftpd_t:s0-s0:c0.c1023 key=(null)



Hash String generated from  selinux-policy-3.6.32-56.fc12,catchall,vsftpd,ftpd_t,ftpd_t,capability,net_raw
audit2allow suggests:

#============= ftpd_t ==============
allow ftpd_t self:capability net_raw;
Comment 1 Miroslav Grepl 2009-12-28 06:08:46 EST
*** Bug 550657 has been marked as a duplicate of this bug. ***
Comment 2 Miroslav Grepl 2010-01-06 07:14:24 EST
*** Bug 552726 has been marked as a duplicate of this bug. ***
Comment 3 Miroslav Grepl 2010-01-07 07:46:53 EST
*** Bug 553188 has been marked as a duplicate of this bug. ***
Comment 4 Carl G. 2010-01-16 21:51:26 EST
*** Bug 545675 has been marked as a duplicate of this bug. ***
Comment 5 Carl G. 2010-01-16 21:55:20 EST
Eric, could you provide a feedback concerning this bug report ?

---

Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 6 Miroslav Grepl 2010-01-22 04:33:26 EST
*** Bug 557551 has been marked as a duplicate of this bug. ***
Comment 7 Miroslav Grepl 2010-01-27 07:47:37 EST
*** Bug 558884 has been marked as a duplicate of this bug. ***
Comment 8 Daniel Walsh 2010-01-29 08:53:00 EST
*** Bug 559922 has been marked as a duplicate of this bug. ***
Comment 9 Daniel Walsh 2010-02-04 10:27:56 EST
*** Bug 561865 has been marked as a duplicate of this bug. ***
Comment 10 Miroslav Grepl 2010-02-08 12:19:07 EST
*** Bug 562638 has been marked as a duplicate of this bug. ***
Comment 11 Eric Paris 2010-02-09 18:21:35 EST

*** This bug has been marked as a duplicate of bug 537428 ***

Note You need to log in before you can comment on or make changes to this bug.