Bug 550657 - SELinux is preventing /usr/sbin/vsftpd "net_raw" access.
SELinux is preventing /usr/sbin/vsftpd "net_raw" access.
Status: CLOSED DUPLICATE of bug 547339
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Daniel Walsh
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2009-12-26 12:17 EST by Bob hernandez
Modified: 2010-02-08 07:38 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2009-12-28 06:08:46 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Bob hernandez 2009-12-26 12:17:49 EST

SELinux is preventing /usr/sbin/vsftpd "net_raw" access.

Detailed Description:

SELinux denied access requested by vsftpd. It is not expected that this access
is required by vsftpd and this access may signal an intrusion attempt. It is
also possible that the specific version or configuration of the application is
causing it to require additional access.

Allowing Access:

You can generate a local policy module to allow this access - see FAQ
(http://fedora.redhat.com/docs/selinux-faq-fc5/#id2961385) Please file a bug

Additional Information:

Source Context                system_u:system_r:ftpd_t:s0-s0:c0.c1023
Target Context                system_u:system_r:ftpd_t:s0-s0:c0.c1023
Target Objects                None [ capability ]
Source                        vsftpd
Source Path                   /usr/sbin/vsftpd
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           vsftpd-2.2.0-6.fc12
Target RPM Packages           
Policy RPM                    selinux-policy-3.6.32-59.fc12
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Plugin Name                   catchall
Host Name                     (removed)
Platform                      Linux (removed) #1 SMP
                              Wed Dec 9 11:14:59 EST 2009 i686 i686
Alert Count                   1
First Seen                    Sat 26 Dec 2009 07:14:59 AM HST
Last Seen                     Sat 26 Dec 2009 07:14:59 AM HST
Local ID                      43da2f59-ba74-459c-999f-3c45a60927b2
Line Numbers                  

Raw Audit Messages            

node=(removed) type=AVC msg=audit(1261847699.396:26894): avc:  denied  { net_raw } for  pid=6184 comm="vsftpd" capability=13 scontext=system_u:system_r:ftpd_t:s0-s0:c0.c1023 tcontext=system_u:system_r:ftpd_t:s0-s0:c0.c1023 tclass=capability

node=(removed) type=SYSCALL msg=audit(1261847699.396:26894): arch=40000003 syscall=120 success=no exit=-1 a0=40000011 a1=0 a2=b42338 a3=b42338 items=0 ppid=0 pid=6184 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm="vsftpd" exe="/usr/sbin/vsftpd" subj=system_u:system_r:ftpd_t:s0-s0:c0.c1023 key=(null)

Hash String generated from  selinux-policy-3.6.32-59.fc12,catchall,vsftpd,ftpd_t,ftpd_t,capability,net_raw
audit2allow suggests:

#============= ftpd_t ==============
allow ftpd_t self:capability net_raw;
Comment 1 Miroslav Grepl 2009-12-28 06:08:46 EST

*** This bug has been marked as a duplicate of bug 547339 ***

Note You need to log in before you can comment on or make changes to this bug.