Bug 547633 - dhcrelay segfault
dhcrelay segfault
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: dhcp (Show other bugs)
12
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Jiri Popelka
Fedora Extras Quality Assurance
:
: 547694 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-12-15 04:17 EST by Pytela, Zdenek
Modified: 2010-02-11 09:45 EST (History)
1 user (show)

See Also:
Fixed In Version: 4.1.1-5.fc12
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-02-11 09:45:13 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Pytela, Zdenek 2009-12-15 04:17:43 EST
dhcrelay listening on a virtual 802.1q interface stops with segfault (error 4)
after a first dhcp request.
Client with a static ip address set works properly.

F12 is fully updated, the same behavior for dhcp-4.1.0p1-13.fc12.x86_64 and dhcp-4.1.0p1-14.fc12.x86_64 from updates-testing.
Comment 1 Jiri Popelka 2009-12-15 06:25:34 EST
Thanks for the report.

I need you to obtain backtrace.
First of all you need to install dhcp debuginfo package: 'debuginfo-install dhcp'.

Then the easiest way to get backtrace is to use ABRT.
If you don't have it installed please install it with 'yum install abrt abrt-libs abrt-gui'. Do necessary steps to reproduce the crash and abrt should notice it and let you know. If he doesn't open it with Application->System Tools->Automatic Bug Reporting Tool. Double-click on the line corresponding to this crash. If he says he needs some other debuginfo, please install it and press Refresh button. Copy and paste the backtrace into this bug report.

Tell me if the ABRT way is not working or read
http://fedoraproject.org/wiki/StackTraces
how to obtain backtrace (stacktrace) manually.

Thanks.
Comment 2 Pytela, Zdenek 2009-12-15 07:56:09 EST
Thank you for a detailed howto which I was missing (although I hope it's not necessary to use any of the graphic tools).
Unfortunately it looks there's no debuginfo for dhcp in f12 or f11:
No debuginfo packages available to install
Dependencies openldap-debuginfo-2.4.19-1.fc12.x86_64 and glibc-debuginfo-2.11-2.x86_64 succeeded to install, though.

In dhcrelay's coredump there is 
Program terminated with signal 11, Segmentation fault.                          
#0  0x0000000000409f37 in getservbyname () at ../nss/getXXbyYY.c:89             
89      { 

strace in the very scecond of the crash says:
...
13:45:12.047769 select(8, [4 5 6 7], [], [], {0, 0}) = 2 (in [4 5], left {0, 0})
13:45:12.047817 recvmsg(4, {msg_name(0)=NULL, msg_iov(1)=[{"\377\377\377\377\377\377\0\27\10@1t\10\0E\20\0016\0\0\0\0\200\0219\250\0\0\0\0\377\377"..., 1536}], msg_controllen=36, {cmsg_len=36, cmsg_level=SOL_PACKET, cmsg_type=, ...}, msg_flags=0}, 0) = 324
13:45:12.047876 --- SIGSEGV (Segmentation fault) @ 0 (0) ---
Comment 3 Pytela, Zdenek 2009-12-15 08:12:03 EST
Well, one should enable repo updates-testing-debuginfo when a package from updates-testing is installed.
Abrt result sent.
Comment 4 Jiri Popelka 2009-12-15 08:55:02 EST
*** Bug 547694 has been marked as a duplicate of this bug. ***
Comment 5 Jiri Popelka 2009-12-15 08:56:40 EST
Backtrace is in duplicate bug.
https://bugzilla.redhat.com/show_bug.cgi?id=547694#c1
Comment 6 Pytela, Zdenek 2010-02-09 08:38:46 EST
dhcrelay version 4.1.1 from f12 updates-testing (dhcp-4.1.1-5.fc12.x86_64) works fine even in vlan environment without any fault (yet). As far as I am concerned the problem is solved.
Comment 7 Jiri Popelka 2010-02-09 08:56:16 EST
Oh, such a great news !

I hadn't seen any dhcrelay related bugfix in Release notes, so I didn't tell you to try 4.1.1 build.

I'll close this bug when dhcp-4.1.1 hits stable repository.
Comment 8 Fedora Update System 2010-02-11 09:44:51 EST
dhcp-4.1.1-5.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.