Bug 547780 - [abrt] crash detected in gnome-settings-daemon-2.28.1-8.fc12
Summary: [abrt] crash detected in gnome-settings-daemon-2.28.1-8.fc12
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-settings-daemon
Version: 12
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: Bastien Nocera
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:90ae4b56a6535fbfe15efc8f1e0...
: 539263 543582 (view as bug list)
Depends On:
Blocks: 547868
TreeView+ depends on / blocked
 
Reported: 2009-12-15 17:20 UTC by Patrick Monnerat
Modified: 2010-02-17 03:45 UTC (History)
5 users (show)

Fixed In Version: 2.28.1-9.fc12
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 547868 (view as bug list)
Environment:
Last Closed: 2010-01-03 21:00:46 UTC
Type: ---


Attachments (Terms of Use)
File: backtrace (3.23 KB, text/plain)
2009-12-15 17:21 UTC, Patrick Monnerat
no flags Details

Description Patrick Monnerat 2009-12-15 17:20:58 UTC
abrt 1.0.0 detected a crash.

How to reproduce
-----
1. Login on a xinetd-controlled VNC session
2. Immediate crash


Attached file: backtrace
cmdline: /usr/libexec/gnome-settings-daemon
component: gnome-settings-daemon
executable: /usr/libexec/gnome-settings-daemon
kernel: 2.6.31.6-166.fc12.x86_64
package: gnome-settings-daemon-2.28.1-8.fc12
rating: 4
reason: Process was terminated by signal 11

Comment 1 Patrick Monnerat 2009-12-15 17:21:00 UTC
Created attachment 378560 [details]
File: backtrace

Comment 2 Patrick Monnerat 2009-12-15 18:01:55 UTC
Probably a duplicate of 543582, but with more backtrace info

Comment 3 Matthias Clasen 2009-12-15 19:17:06 UTC
Can you run xdpyinfo on the display you are using there ? I wonder if it doesn't have the XKEYBOARD extension, which would cause libxklavier to fall back to the xmodmap backend, which in turn will trigger a bug in gnome-settings-daemons code.

Comment 4 Fedora Update System 2009-12-15 21:42:02 UTC
gnome-settings-daemon-2.28.1-9.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/gnome-settings-daemon-2.28.1-9.fc12

Comment 5 Patrick Monnerat 2009-12-16 10:48:59 UTC
No, vnc (tigervnc-server-1.0.0-3.fc12.x86_64) does not have the XKEYBOARD extension:

number of extensions:    19
    BIG-REQUESTS
    DAMAGE
    DOUBLE-BUFFER
    GLX
    Generic Event Extension
    MIT-SCREEN-SAVER
    MIT-SHM
    RANDR
    RENDER
    SGI-GLX
    SHAPE
    SYNC
    VNC-EXTENSION
    X-Resource
    XC-MISC
    XFIXES
    XInputExtension
    XTEST
    XVideo

Comment 6 Patrick Monnerat 2009-12-17 17:10:29 UTC
gnome-settings-daemon-2.28.1-9.fc12 fixes the problem. Thanks.

Comment 7 Fedora Update System 2009-12-18 04:38:32 UTC
gnome-settings-daemon-2.28.1-9.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update gnome-settings-daemon'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F12/FEDORA-2009-13374

Comment 8 Fedora Update System 2010-01-03 21:00:42 UTC
gnome-settings-daemon-2.28.1-9.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 9 Matthias Clasen 2010-02-17 03:44:30 UTC
*** Bug 543582 has been marked as a duplicate of this bug. ***

Comment 10 Matthias Clasen 2010-02-17 03:45:18 UTC
*** Bug 539263 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.