Bug 54792 - up2date doesn't update lilo.conf if existing linux.bak
up2date doesn't update lilo.conf if existing linux.bak
Status: CLOSED ERRATA
Product: Red Hat Linux
Classification: Retired
Component: up2date (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Adrian Likins
Jay Turner
:
: 55731 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-10-18 21:17 EDT by marfree
Modified: 2015-01-07 18:52 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-11-05 17:36:17 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description marfree 2001-10-18 21:17:30 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (X11; U; Linux 2.4.9-6 i686)

Description of problem:
Launched gui up2date and installed packages, and then revisited to get the
latest kernel packages on 18-OCT-01 which failed the end of the kernel
installation.

Version-Release number of selected component (if applicable):


How reproducible:
Didn't try

Steps to Reproduce:
1. Clean install RH7.1 (kernel-2.4.2-2)
2. Go to rhn via up2date before 09-OCT-01 and get new kernel/header
(kernel-2.4.3-12)
3. Go to rhn via up2date after 09-OCT-01 and get new kernel/header
(kernel-2.4.9.6)
	

Actual Results:  up2date reports that it's unable to modify lilo.conf. I
had to workaround and hack in a new entry for kernel-2.4.9-6.

Expected Results:  the up2date procedure (step 2) reproduced.

Additional info:

docs kind of helped but could be better.
Comment 1 Adrian Likins 2001-10-24 16:32:16 EDT
Could you append a copy of your lilo.conf file?

There can be a couple of reasons up2date will raise an error
about not being able to update lilo.conf:

1. the test mode run of lilo fails, typically caused by
    the version of lilo.conf installed being incorrect

2. Upsupported config paramaters are used. (the lilo support
    code in up2date-2.5.4 doesnt support bios drive remapping for example)



Comment 2 Adrian Likins 2001-11-05 16:01:59 EST
Okay, think I see what I going on here. the label names chosen
for the backup lilo stanza's are failing. 

Should be a fix in the next version of the client.
Comment 3 Adrian Likins 2001-11-05 17:36:12 EST
*** Bug 55731 has been marked as a duplicate of this bug. ***
Comment 4 David M. Cook 2002-02-22 12:28:18 EST
Fix: http://www.redhat.com/support/errata/RHBA-2001-119.html

Note You need to log in before you can comment on or make changes to this bug.