Bug 54853 - Unsuccessful Redhat installation
Unsuccessful Redhat installation
Status: CLOSED DUPLICATE of bug 12099
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Brock Organ
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-10-21 06:17 EDT by Need Real Name
Modified: 2007-04-18 12:37 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-10-23 00:10:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-10-21 06:17:21 EDT
Description of Problem:

I configured my PC as a multi-boot PC and this means that I'm using quite 
a lot partitions (primary&logical) on my IDE-HDD drive.
 
I've used the following partitions to install Linux (Redhat 7.1 
distribution) on:
- boot partition below 1024 cylinder on a partition labeled hda7
- root partition on partition labeled hda17
This installation was not successful.

From what I understand sofar, Linux has problems with partitions above 
hda16. I know for a fact that the Redhat installation cannot cope with it. 
The information I've found on the internet thusfar is also pointing in 
that direction (I did not find any information on how to resolve this 
problem). The highest entry is /dev/hda16 (inode) on a default Linux 
installation.
 
Why this message you may ask? Well, in my opinion the Redhat installer 
(I'm impressed with the graphical install by the way) has to submit a 
warning that Linux will have problems with the hda17. It should do so 
before the installation process, not after!
Doing it after the install and not on forehand reminds me of something 
called the Windows OS. And one important reason for getting acquinted with 
Linux is that I'm getting fed up with the poor quility of that Windows OS. 

I don't know if it is just an issue with the Redhat distribution. Maybe it 
is a more general issue that also can cause problems with other Linux 
distributions. And because I'm curious what Linux experts think of the 
problems that might occur if Linux is used on a HDD with a lot of 
partitions I'm posting this message. 
 
It is very disappointing to come to the conclusion that Linux (I assume it 
is not only the case for the Redhat distribution) restricts the number of 
partitions on a single harddrive to 16. Probably this was enough years ago 
when harddisks were a lot smaller. A long time ago 640K of memory was also 
enough, but time advances.
 
I'm not a Linux Kernel expert, so I don't know if limiting the numbers of 
partitions on a single drive to 16 has to do with that Kernel. I can also 
imagine that that limition is caused simply by making an arbitrary choice, 
and the choice made was to support only a maximum of 16 partitions on a 
single drive.
 
If that is the case, then it might be a good idea to consider to increase 
that number (if the actual HDD partitioning requires that), as limiting 
the number to 16 in the year 2001 with harddisks of 40 GByte and above is 
NOT future proof to say the least. And I think that for PC users who 
configure their machines as multi-boot devices using more than 16 
partitions is not out of the ordinary.
 
I hope that you'll take the time to give some feedback on this issue.
 
Regards, Marlo

Version-Release number of selected component (if applicable):
Redhat 7.1 installer

How Reproducible:
100% reproducible

Steps to Reproduce:
1.choose a root partition above hda16 during installation
2. 
3. 

Actual Results:
Error during post-install process:
An error occurred while installing the bootloader. We highly recommend you 
make a recovery boot floppy when prompted, otherwise you may not be able 
to reboot into Redhat Linux.
(during the Linux boat process the error reported is: Fatal: Not a 
number /dev/hda17)

Expected Results:


Additional Information:
Comment 1 Brent Fox 2001-10-22 17:33:26 EDT
This is a limitation of the kernel, not the installer.  Changing component to
the kernel.
Comment 2 Arjan van de Ven 2001-10-22 17:37:04 EDT
Not kernel bug; kernel can do more than 16 IDE partitions just fine
(SCSI is a different story); Anaconda probably doesn't make the device nodes....
Comment 3 Need Real Name 2001-10-22 18:03:31 EDT
I agree, it is not a kernel bug. From what I've learned thusfar the kernel 
supports up to 63 partitions on an IDE drive.

The problem indeed has to do with the fact that device nodes above hda16 are 
not created during a "standard" Redhat intstallation.

Someone has informed my that I could add devices in /dev by means of the 
command:
  mknod /dev/hda17 b 3 17

However when issueing this command (after booting the recovery boot floppy) I 
received the following (error) message:
  mknod: '/dev/hda17': Read-only file system

The result is that the device node hda17 is not added. Until now I haven't 
found a workaround or solution to get the root partition on hda17 up and 
running.



Comment 4 Brent Fox 2001-10-22 21:34:50 EDT
So arjan, is this a problem with the dev package then?  I think the installer
can't do much if there's no file higher than hda16 in /dev.  Am I right here?
Comment 5 Jeremy Katz 2001-10-22 21:43:54 EDT
There are a few things here... the dev package will need the additional devices
for the higher IDE devices and then we'll have to fix isys to know about them as
well.
Comment 6 Brent Fox 2001-10-22 22:40:09 EDT
Changing component back to anaconda.
Comment 7 Jeremy Katz 2001-10-23 16:38:11 EDT

*** This bug has been marked as a duplicate of 12099 ***

Note You need to log in before you can comment on or make changes to this bug.