Bug 12099 - RFE: Support more than 16 partitions/drive
RFE: Support more than 16 partitions/drive
Status: CLOSED DEFERRED
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
6.2
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Matt Wilson
: FutureFeature
: 18265 54853 57167 57828 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-06-11 18:58 EDT by rhaig
Modified: 2007-03-26 23:32 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:47:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description rhaig 2000-06-11 18:58:57 EDT
During install, I get "no free resources" on trying to partition the disk.
I found on Deja.com the following article:
	http://www.deja.com/getdoc.xp?AN=628953505&fmt=text

	After some experimentation with fdisk, I've found that if you
	define partitions to the point that there's greater than 16,
	i.e. define /dev/hda17, that Red Hat 6.2 chokes and dies on the
	install.  On the step between fdisk and disk druid, it fails
	with the message:  An error occurred reading the partition table
	for the block device hda.  The error was:  No free resources.  I
	lined up a small (8G) disk to test this, so that there wouldn't
	be any above the line (1024 cyl) problems.  I don't think this
	is a general linux problem, just confined to Red Hat, but I'll
	have to do some further testing to confirm that.

I did indeed have 18 partitions on my disk.  I deleted the last few and the
install worked.

It looks like 16 is a boundry condition in the install code somewhere.


HOW TO REPRODUCE

partition a disk (I used a 7G Maxtor) with more than 16 partitions
(Mine had 18).

boot from install CD

use text mode install

at the point where the installer tries to partition the disk, the error
will occur.

note: this was not tested under graphical install.
Comment 1 Michael Fulbright 2000-06-15 12:03:21 EDT
This is a known limitation of the 6.2 installer, and increasing the limit
for IDE devices is under consideration.
Comment 2 Michael Fulbright 2000-09-15 15:29:41 EDT
Brock is this limit still a problem in Pinstripe?
Comment 3 Michael Fulbright 2000-10-04 18:18:54 EDT
*** Bug 18265 has been marked as a duplicate of this bug. ***
Comment 4 Jeremy Katz 2001-10-23 16:38:06 EDT
*** Bug 54853 has been marked as a duplicate of this bug. ***
Comment 5 Jeremy Katz 2001-12-07 16:49:40 EST
*** Bug 57167 has been marked as a duplicate of this bug. ***
Comment 6 Jeremy Katz 2002-01-02 17:23:12 EST
*** Bug 57828 has been marked as a duplicate of this bug. ***
Comment 7 Michael Fulbright 2002-03-26 12:25:44 EST
Deferred to future release.
Comment 8 rhaig 2002-03-26 13:13:58 EST
when the next release (after the current beta) comes out I'll test this.  you
can be sure I'll open a new bug report if it's not fixed.  I've seen (with other
vendors) bugs marked as "next release" and then forgotten about.
Comment 9 Michael Fulbright 2002-05-26 14:59:54 EDT
Fixing bug status- sorry for the email.
Comment 10 David Balažic 2003-01-13 10:39:30 EST
Phoebe can create 40 partitions during GUI install.
I started with an empty hard drive.

There were problems at boot-up though :

 - /dec/hdxnn exists only up to partition 32, I created the rest ( up to 63 ) 
manually and then all worked
 - note : current fdisk ( util-linux-2.11w-2 ) can handle only 16 partitions 
per (IDE?) disk, use something else for partitioning ( maybe parted )
Comment 11 Red Hat Bugzilla 2006-02-21 13:47:41 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.