Bug 549089 - [NetworkManager] wired interface eth0 des not reconnect after resume from suspend
Summary: [NetworkManager] wired interface eth0 des not reconnect after resume from sus...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: pm-utils
Version: 12
Hardware: i686
OS: Linux
low
medium
Target Milestone: ---
Assignee: Jaroslav Škarvada
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 632115 635006 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-12-20 11:35 UTC by Joachim Frieben
Modified: 2010-10-19 08:26 UTC (History)
16 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-10-19 08:26:50 UTC


Attachments (Terms of Use)
Log file /var/log/messages (17.77 KB, text/plain)
2009-12-20 11:35 UTC, Joachim Frieben
no flags Details
Log file /var/log/messages (124.56 KB, text/plain)
2010-01-27 14:19 UTC, Joachim Frieben
no flags Details
File 55NetworkManager from pm-utils-1.2.5-6.fc12.i686 (991 bytes, text/plain)
2010-01-27 14:21 UTC, Joachim Frieben
no flags Details
pm log AFTER adding --print-reply to 55NetworkManager (6.71 KB, application/octet-stream)
2010-05-02 20:52 UTC, Vladimir Mencl
no flags Details
/usr/lib/pm-utils/sleep.d/55NetworkManager from pm-utils-1.2.5-7.fc12.i686 (991 bytes, application/octet-stream)
2010-05-02 20:53 UTC, Vladimir Mencl
no flags Details

Description Joachim Frieben 2009-12-20 11:35:10 UTC
Created attachment 379461 [details]
Log file /var/log/messages

Description of problem:
After resume from suspend, eth0 on an IBM ThinkPad T23 is disabled. By
clicking the NM applet with the right mouse button and checkmarking "Enable
Networking", NM reconnects to the wired network.

Version-Release number of selected component (if applicable):
NetworkManager-0.7.996-7.git20091113.fc12.i686

How reproducible:
Always.

Steps to Reproduce:
1. Boot system.
2. Suspend system from GNOME session.
3. Resume from suspend.
  
Actual results:
Wired device eth0 stays disabled.

Expected results:
NM reconnects to wired network.

Additional info:
- This used to work for Fedora 11.
- Checkmarking "Enable Networking" triggers successful reconnection.

Comment 1 Dan Williams 2010-01-04 22:16:40 UTC
Next time this happens, can you grab /var/log/messages for me and attach it?

Comment 2 Dan Williams 2010-01-07 02:24:44 UTC
Sorry; does this happen consistently?

Can you attach your  /usr/lib64/pm-utils/sleep.d/55NetworkManager file?

Comment 3 Joachim Frieben 2010-01-27 14:19:24 UTC
Created attachment 387082 [details]
Log file /var/log/messages

Networking still disabled after resume with NetworkManager-0.7.998-2.git20100106.fc12.i686.

Comment 4 Joachim Frieben 2010-01-27 14:21:00 UTC
Created attachment 387083 [details]
File 55NetworkManager from pm-utils-1.2.5-6.fc12.i686

Comment 5 Dan Williams 2010-04-09 01:10:53 UTC
appears to be a pm-utils problem (well really a dbus problem); try adding "--print-reply" right after the dbus-send bits in 55NetworkManager.  If that fixes it, then it's definitely a dbus/pm-utils issue.

What version of dbus do you have?

Comment 6 Vladimir Mencl 2010-05-02 20:43:10 UTC
Hi,

I'm having exactly the same problem on Fedora 12 on an IBM/Lenovo ThinkPad T60.

After a suspend/resume cycle, the NetworkManager comes up back again with networking disabled.  Checking the Enable Networking box makes everything work again.

I've just tried what was recommended above - to add the "--print-reply" option into 55NetworkManager - and it works like a charm.  The problem is completely gone away and networking stays enabled after a suspend/resume cycle.

The versions of relevant packages on my system are:

$ rpm -qa NetworkManager\* dbus\* pm\* | sort

dbus-1.2.16-9.fc12.i686
dbus-devel-1.2.16-9.fc12.i686
dbus-glib-0.82-2.fc12.i686
dbus-glib-devel-0.82-2.fc12.i686
dbus-libs-1.2.16-9.fc12.i686
dbus-python-0.83.0-6.fc12.i686
dbus-sharp-0.63-14.fc12.i686
dbus-x11-1.2.16-9.fc12.i686
NetworkManager-0.8.0-6.git20100408.fc12.i686
NetworkManager-glib-0.8.0-6.git20100408.fc12.i686
NetworkManager-gnome-0.8.0-6.git20100408.fc12.i686
pmd-4.2.5-4.fc12.noarch
pm-utils-1.2.5-7.fc12.i686


Would you like me to attach any logs?  I'd be happy to do so.

Cheers,
Vlad
vladimir.mencl<at>gmail.com

Comment 7 Vladimir Mencl 2010-05-02 20:47:15 UTC
Hi,

A bit extra info - I've just found this in /var/log/pm-suspend.log:

/usr/lib/pm-utils/sleep.d/55NetworkManager suspend suspend: method return sender=:1.1 -> dest=:1.944 reply_serial=2
success.
...
/usr/lib/pm-utils/sleep.d/55NetworkManager resume suspend: method return sender=:1.1 -> dest=:1.985 reply_serial=2
success.

Cheers,
Vlad

Comment 8 Vladimir Mencl 2010-05-02 20:52:21 UTC
Created attachment 410856 [details]
pm log AFTER adding --print-reply to 55NetworkManager

Comment 9 Vladimir Mencl 2010-05-02 20:53:32 UTC
Created attachment 410857 [details]
/usr/lib/pm-utils/sleep.d/55NetworkManager from pm-utils-1.2.5-7.fc12.i686

/usr/lib/pm-utils/sleep.d/55NetworkManager from pm-utils-1.2.5-7.fc12.i686 (BEFORE adding --print-reply)

Comment 10 Anthony Name 2010-06-20 07:18:36 UTC
This is also affecting Fedora 13 x86_64 builds using NetworkManager 0.8.1-0.1.git20100510

On two different but identical machines when they are awoken from S3 the "Enable Networking" button on the NetworkManager icon is unticked.

If you manually go to the machine and click the box to "Enable Networking" it all comes back to life.

I've added the --print-reply bit and will let you know if that clears it.

Comment 11 Anthony Name 2010-06-20 12:19:15 UTC
Well it looks like adding the --print-reply line has fixed it on both machines.  If I don't post further to this log within the next week assume it has fully cleared the fault.  If you want any log information from me please let me know.

Comment 12 Joachim Frieben 2010-08-31 05:53:58 UTC
(In reply to comment #5)
Adding "--print-reply" right after the dbus-send bits in 55NetworkManager does work around this issue which stills persists. The system has been fully updated to current F12 including packages:

- NetworkManager-0.8.1-4.git20100817.fc12
- dbus-1.2.16-9.fc12
- pm-utils-1.2.5-7.fc12.x86_64

Comment 13 wonderful_spam 2010-09-04 07:16:39 UTC
I experienced the same problem in F13 on a Thinkpad R60e. Adding "--print-reply" works around here, too.

Packages:

- NetworkManager-0.8.1-4.git20100817.fc13
- dbus-1.2.24-1.fc13  
- pm-utils-1.2.6.1-1.fc13

Comment 14 Carl G. 2010-09-09 18:50:23 UTC
*** Bug 632115 has been marked as a duplicate of this bug. ***

Comment 15 Kieran Clancy 2010-09-14 22:18:04 UTC
For what it's worth, it looks like a regression of bug 477964. It was supposed to be fixed by the following commit:
http://cgit.freedesktop.org/dbus/dbus/commit/?id=87ddff6b24d9b9d4bba225c33890db25022d8cbe

So perhaps there is a regression in dbus?

Comment 16 Orion Poplawski 2010-09-23 21:31:14 UTC
*** Bug 635006 has been marked as a duplicate of this bug. ***

Comment 17 Jaroslav Škarvada 2010-10-19 08:26:50 UTC
Seems as fixed now, if the problem persists feel free to reopen.


Note You need to log in before you can comment on or make changes to this bug.