Bug 632115 - "networking is disabled" after suspend
Summary: "networking is disabled" after suspend
Keywords:
Status: CLOSED DUPLICATE of bug 549089
Alias: None
Product: Fedora
Classification: Fedora
Component: NetworkManager
Version: 13
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Dan Williams
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-09-09 08:11 UTC by Toni Willberg
Modified: 2010-09-09 18:50 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-09-09 18:50:23 UTC


Attachments (Terms of Use)

Description Toni Willberg 2010-09-09 08:11:10 UTC
Description of problem:


 After waking up from suspend, NetworkManager says "networking is disabled".

Version-Release number of selected component (if applicable):

 NetworkManager-0.8.1-4.git20100817.fc13.x86_64

Harware:
 Lenovo Thinkpad X200, iwglan driver.

How reproducible:

 Not always, but too often.

Steps to Reproduce:
 1. suspend
 2. resume
 3. click on NetworkManager icon
  

Solution:
 service NetworkManager restart

 Somehow NetworkManager doesn't realize that the hardware is up and running again and requires restarting the service.

This bug seems to relate to a kernel bug #628088

Comment 1 Bruce vaNorman 2010-09-09 16:09:47 UTC
Same problem, more recent version, 32 bit kernel. Problem is intermittent ~30% of the resumes from S3
---
[bvn@office ~]$ sudo ifconfig eth0 up
[bvn@office ~]$ sudo ifconfig
eth0      Link encap:Ethernet  HWaddr 00:24:8C:BF:D5:D0  
          inet6 addr: fe80::224:8cff:febf:d5d0/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:192608992 errors:0 dropped:0 overruns:0 frame:0
          TX packets:192509533 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:1620489346 (1.5 GiB)  TX bytes:2604356400 (2.4 GiB)
          Interrupt:27 Base address:0x8000 

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:1889 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1889 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:1938051 (1.8 MiB)  TX bytes:1938051 (1.8 MiB)

[bvn@office ~]$ sudo service network restart
Shutting down interface eth0:                              [  OK  ]
Shutting down loopback interface:                          [  OK  ]
Bringing up loopback interface:                            [  OK  ]
Bringing up interface eth0:  Error: Connection activation failed:
 Device not managed by NetworkManager
                                                           [FAILED]
[bvn@office ~]$ uname -r
2.6.34.6-47.fc13.i686.PAE
[bvn@office ~]$ rpm -qa | grep network
system-config-network-1.6.1-1.fc13.noarch
system-config-network-tui-1.6.1-1.fc13.noarch
[bvn@office ~]$ rpm -qa | grep Network
NetworkManager-0.8.1-6.git20100831.fc13.i686
NetworkManager-openconnect-0.8.1-1.fc13.i686
NetworkManager-gnome-0.8.1-6.git20100831.fc13.i686
NetworkManager-openvpn-0.8.1-1.fc13.i686
NetworkManager-pptp-0.8.1-1.fc13.i686
NetworkManager-vpnc-0.8.1-1.fc13.i686
NetworkManager-glib-0.8.1-6.git20100831.fc13.i686
[bvn@office ~]$

Comment 2 Carl G. 2010-09-09 18:50:23 UTC
I believe it's a duplicate of 549089.

*** This bug has been marked as a duplicate of bug 549089 ***


Note You need to log in before you can comment on or make changes to this bug.