Bug 5494 - Selecting UTC+1:00 timezone causes postinstall to hang...
Selecting UTC+1:00 timezone causes postinstall to hang...
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
6.1
i386 Linux
high Severity high
: ---
: ---
Assigned To: Matt Wilson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-10-04 13:22 EDT by fons.rademakers
Modified: 2008-05-01 11:37 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-02-11 12:34:01 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description fons.rademakers 1999-10-04 13:22:11 EDT
During install of 6.1 I selected as timezone UTC+1:00.
This caused the postinstall procedure to hang. It seemed it
could not copy the file UTC+1:00.
Comment 1 Jay Turner 1999-10-20 11:54:59 EDT
This issue has been assigned to a developer for further action.
Comment 2 Jay Turner 1999-10-20 15:00:59 EDT
*** Bug 5570 has been marked as a duplicate of this bug. ***

This is ever-so-similar to ID 5524 as the result is the
same, but the circumstances are different.

The graphical installer hangs during post-installation
configuration if:

  1. Timezone selection is done from "UTC Offset" tab
  2. Selected Zone is "UTC-06:00 U.S.Central"
  3. "Use Daylight Saving Time" checkbox is *not* selected

The error reported on tty1 is:

  OSError [Errno 2] No such file or directory:
'/mnt/sysimage/usr/share/zoneinfo/UTC-06:00'

This following about a page of tracebacks, which I didn't
write down. I can reproduce this error 100% of the time
under the circumstances listed above, so retrieving the
traceback info should not be a problem if it is necessary.

(By the way, is there some reason RedHat decided to leave
Dallas off of the time zone config map? There is nothing but
a big blank area where Texas is.)
Comment 3 Anonymous 1999-10-28 23:33:59 EDT
When the GUI starts up, the following message appears on tty1...

error opening security plicy file
/usr/X11R6/lib/X11/xserver/SecurityPolicy

Hmm, it's still all working, so carry on.  I then do all the fdisk
stuff, choose packages, and they are installed.  A dialog box comes up
on the GUI screen saying:

	"performing post install configuration..."

Then it hangs right there indefinitely.  I see the following on
tty1...

Gtk-CRITICAL **: file gtkwidget.c: line 1584 (gtk_widget_map):
assertion 'GTK_WIDGET_VISIBLE (widget) == TRUE' failed.

Gtk-CRITICAL **: file gtkwidget.c: line 1584 (gtk_widget_map):
assertion 'GTK_WIDGET_VISIBLE (widget) == TRUE' failed.

Gtk-WARNING **: shmget failed!
Exception in thread Thread-3:
Traceback (innermost last):
File "/usr/lib/python1.5/threading.py", line 376, in __bootstrap
self.run()
File
"/mnt/redhat/comps/install/6.1/i386/RedHat/instimage/usr/6.1/python1.5/site-packages/iw/progress.py",
line 16, in run
File "/usr/lib/python1.5/site-packages/todo.py", line 1587, in
doInstall self.writeTimezone()
File "/usr/lib/python1.5/site-packages/todo.py", line 487, in
witeTimezone self.instPath + "/etc/localtime")
File "/usr/lib/python1.5/site-packages/iutil.py", line 105, in
copyFile f = os.open(source.os, os,O_RDONLY)
OSError: [Errno 2] No such file or directory:
'/mnt/sysimage/usr/share/zoneinfo/UTC+10:00'

Obviously a problem setting up the local time zoneinfo (we are 10
hours ahead of GMT here).

Should there be a space between the UTC and the +10:00 ?  Seems so to
me -- if so, can I be given the "quickfix" for this so I can get
things work for next time?



------- Additional Comments From   11/01/99 06:21 -------
It hans with UTC+2:00 as well.
Actually it tries to look at the file "UTC+2:00" in the directory
/usr/share/zoneinfo of the system being installed. The "normal"
timezone files are there, but the UTC* ones are not.
Comment 4 Matt Wilson 1999-12-22 12:46:59 EST
I am currently testing a fix that will be included in the next release of Red
Hat Linux.
Comment 5 igor.marakov 1999-12-22 13:16:59 EST
Gee..., How about a patch, so some of us could finally install what already
has been paid for?
In my unfortunate case install 100% dies at this point whether or not
I select UTC* or /America/New York or just hit "Next" button without touching
anything at all. The end result is still the same. As an additional "benefit"
system is left in unbootable state.
The only workaround I have found so far was to reinstall my old 5.2 and
do an "upgrade". This creates bootable system and also brings up a whole
bunch of other bugs including non-functioning "control panel" apps.
But this is another story...
Comment 6 Jacques Limpens 2000-01-03 15:01:59 EST
There seems to me a dependency with problem 5524. But this one gives neithewr a
solution.

Jacques Limpens.
Comment 7 lazarus 2000-01-06 22:08:59 EST
What the *(())^% is this. I have been trying in vain to install 6.1 for 8 days.
This bug is killing me. You (red hat) say you will create a fix for the next
release??? Please get real here. This is not a viable resolution. I want a fix.
I want it ASAP. If you have a fix then close this report and tell us what the
fix is. I am getting really angry. You don't want to get me angry.
Comment 8 lazarus 2000-01-07 21:30:59 EST
The problem here is that the file 'zone.tab' which has the time zone data is
located in /mnt/runtime/usr/share/zoneinfo   and NOT in /mnt/sysimage/usr/share/
zoneinfo.     This is why the failure occurs.

Why can't you fix this? It appears a simple matter to alter a script or whatever
file. Not an expert on python but surely the traceback is evident as to
where to alter the statements!!!!

Should be a 10 minute hack. Shoot me the fix by email and I will test it for
you or send me a replacement whatever. Can't we resolve this problem and get
on to more productive items?????
Comment 9 Charles Merriam 2000-01-12 01:00:59 EST
Well I'm stuck.  When I try to install in Text Mode, I get a "grabData()
RPM_STRING_TYPE count must be 1" and stairstep abort messages.

Since I can't install graphically, and can't install text, does RedHat give
refunds?  I bought through a channel and hate to go ballistic.
Comment 10 lazarus 2000-01-12 19:47:59 EST
I no longer experience this failure during install. I switched out the
CDROM drive which eliminated the Bad Magic. See bug report 8360 for further
details.
Comment 11 Charles Merriam 2000-01-13 19:20:59 EST
The bug title is a bit vague, given the half dozen or so 'just failed' type of
installation errors.  Here's what I found out so far:

1.  The user manifestation to me:  on *ANY* graphical installation, regardless
of timezones, regardless of network choices, the graphical installation would
hang during installation of the packages (apparently called 'post-install?').
The actual library that it would hang on would differ depending on various
options.

2.  To see what's going on, try hitting the Ctrl-Alt-1, Ctrl-Alt-2... keys.
This will give you a hint.  You will usually see an error on Ctrl-Alt-1 such as:
  error opening security policy file /usr/X11R6/lib/X11/xserver/SecurityPolicy

  Gtk-CRITICAL **: file gtkwidget.c: line 1584 (gtk_widget_map): assertion
  'GTK_WIDGET_VISIBLE (widget) == TRUE' failed.
  <repeat some number of times>
  grabData() RPM_STRING_TYPE count must be 1
  Xlib: unexpected async reply (sequence 0X1149ac)!

The 'security policy' line just means that the X-Windows connection was lost.
The GTK_WIDGET_VISIBLE message and the unexpected async reply also appear to
normal messages for switching out of graphical mode during an install.
The actual error is the grabData() error.  Unfortunately, this doesn't tell you
much.

3.  There is an installer patch that seems to make this problem go away.  Follow
the directions at
<href=http://www.redhat.com/support/errata/RHEA1999045-01.html>http://www.redhat
.com/support/errata/RHEA1999045-01.html</a>.  Your mileage will vary.

4.  If this fails to work for you, phone support recommened 1) buying a 6.0
CD-ROM from LinuxMall, 2) installing Linux 6.0, and 3) updating it to 6.1.  They
had no idea if it would work.

5.  If Redhat cares enough to bring a the annoying system, I'm in the valley.

Cheers, and good luck,

Charles Merriam
Comment 12 Charles Merriam 2000-01-13 19:21:59 EST
Sorry, the URL is http://www.redhat.com/support/errata/RHEA1999045-01.html
Comment 13 Charles Merriam 2000-01-14 12:00:59 EST
OK, I was wrong.
1.  The update does not fix the problem.  I just was lucky and got a chunk of
this installed.
2.  This is a duplicate, the real bug is Bug 5494.  I'll add my further comments
to this bug number.

Charles Merriam
Comment 14 Steve Welburn 2000-01-22 07:35:59 EST
As mentioned on other bugs, this seems to come down to CD-Rom problems. I
couldn't install from a Philips CDU 3610, a new Memorex 48x drive solved my
problems.
Comment 15 Jay Turner 2000-02-11 12:33:59 EST
Bug is fixed in the latest installer (available in beta)

Note You need to log in before you can comment on or make changes to this bug.