Bug 549498 - New package: hostapd - IEEE 802.11 AP, IEEE 802.1X/WPA/WPA2/EAP/RADIUS Authenticator
Summary: New package: hostapd - IEEE 802.11 AP, IEEE 802.1X/WPA/WPA2/EAP/RADIUS Authen...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: hostapd
Version: 12
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: John W. Linville
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On: 548180
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-12-21 20:40 UTC by John W. Linville
Modified: 2009-12-24 20:35 UTC (History)
1 user (show)

Fixed In Version: 0.6.9-6.fc12
Doc Type: Bug Fix
Doc Text:
Clone Of: 548180
Environment:
Last Closed: 2009-12-24 20:35:50 UTC


Attachments (Terms of Use)

Description John W. Linville 2009-12-21 20:40:40 UTC
+++ This bug was initially created as a clone of Bug #548180 +++

Spec URL: http://linville.fedorapeople.org/hostapd.spec
SRPM URL: http://linville.fedorapeople.org/hostapd-0.6.9-2.src.rpm
Description:
hostapd is a user space daemon for access point and authentication
servers.  It implements IEEE 802.11 access point management, IEEE
802.1X/WPA/WPA2/EAP Authenticators and RADIUS authentication server.

hostapd is designed to be a "daemon" program that runs in the back-
ground and acts as the backend component controlling authentication.
hostapd supports separate frontend programs and an example text-based
frontend, hostapd_cli, is included with hostapd.

--- Additional comment from linville@redhat.com on 2009-12-16 15:46:08 EDT ---

*** Bug 545169 has been marked as a duplicate of this bug. ***

--- Additional comment from linville@redhat.com on 2009-12-16 16:15:17 EDT ---

*** Bug 494171 has been marked as a duplicate of this bug. ***

--- Additional comment from kwizart@gmail.com on 2009-12-16 16:29:33 EDT ---

- starting review -

--- Additional comment from linville@redhat.com on 2009-12-16 16:38:46 EDT ---

kwizart, I snuck-in a new copy using gnutls instead of openssl -- please take note! :-)

--- Additional comment from linville@redhat.com on 2009-12-16 17:11:13 EDT ---

* Wed Dec 16 2009 John W. Linville <linville@redhat.com> - 0.6.9-3
- Use gnutls instead of openssl (avoid license disputes)
- Turn-off internal EAP server (broken w/ gnutls)
- Remove %doc files not applicable to chosen configuration
- Un-mangle README filename for logwatch sub-package

--- Additional comment from kwizart@gmail.com on 2009-12-16 17:31:17 EDT ---


* You need to use our $RPM_OPT_FLAGS (at this time it only uses -O2 -Wall -g)

* It's better to use "install -p" to prevent timestamp changes. (fixed in -3)

* There are lot of commented options. Some are tagged as experimental, But I wonder if others cannot be enabled ?
(this doesn't concern the Driver Interfaces).
Specially as the CONFIG_EAP_FAST=y which requires the newer openssl

* This package doesn't use a dist tag , Why ?

TODO
-> Duplication code verification, in progress.
-> Runtime test on ath5k driver.

--- Additional comment from linville@redhat.com on 2009-12-16 18:27:15 EDT ---

Most of the "commented options" (I presume you mean in .config) relate to the internal EAP server.  Jouni tells me that it is broken when using gnutls, so I disabled the related options when I changed the configuration to using gnutls.  We could reenable some number of them if we use openssl instead, but I wanted to avoid the license disputes.  The others relate to newer 802.11 features that may or may not be useful.

I simply forgot the RPM_OPT_FLAGS and dist tag -- this one is a bit more of a pain to package than most. :-)  Also, I had to hack the Makefile a bit to make RPM_OPT_FLAGS practical...

* Wed Dec 16 2009 John W. Linville <linville@redhat.com> - 0.6.9-4
- Remove wired.conf from %doc (not in chosen configuration)
- Use $RPM_OPT_FLAGS
- Add %{?dist} tag

--- Additional comment from linville@redhat.com on 2009-12-16 19:15:41 EDT ---

*sigh*

WPA-PSK connections seem to be broken with gnutls and/or turning-off all the EAP stuff.  So, what are the ramifications of using openssl?

If we go this route, we can reevaluate some of the other stuff in .config...

* Wed Dec 16 2009 John W. Linville <linville@redhat.com> - 0.6.9-5
- Use openssl instead of gnutls (broken)

--- Additional comment from linville@redhat.com on 2009-12-16 19:18:40 EDT ---

SRPM: http://linville.fedorapeople.org/hostapd-0.6.9-5.fc11.src.rpm

--- Additional comment from lemenkov@gmail.com on 2009-12-17 06:52:36 EDT ---

*** Bug 230449 has been marked as a duplicate of this bug. ***

--- Additional comment from linville@redhat.com on 2009-12-17 10:45:22 EDT ---

* Thu Dec 17 2009 John W. Linville <linville@redhat.com> - 0.6.9-6
- Enable RADIUS server
- Enable "wired" and "none" drivers
- Use BSD license option

SRPM: http://linville.fedorapeople.org/hostapd-0.6.9-6.fc11.src.rpm

--- Additional comment from tom@compton.nu on 2009-12-17 11:00:56 EDT ---

I notice you haven't uncommented CONFIG_IEEE80211N in the configuration so it won't have 802.11n support.

The build I'm using at the moment does have that enabled (although I don't have any clients to test it with) and it doesn't seem to have caused any problems.

--- Additional comment from linville@redhat.com on 2009-12-17 11:07:24 EDT ---

Tom, thanks for the report!  I would be open to enabling that, just haven't tested it myself.

If you don't mind, let's get the package approved and then we can play with further configuration options...fair enough?

--- Additional comment from kyle@averageurl.com on 2009-12-20 00:38:30 EDT ---

I can provide runtime testing on ath9k on 802.11n, if needed. I'd love to see this package accepted with the full set of features that I'd be using. :)

--- Additional comment from kwizart@gmail.com on 2009-12-20 17:12:04 EDT ---

I wasn't able to use hostapd with the nl80211 driver on Fedora 11, but everything went fine for Fedora 12 using an atheros hardware.
(none work with intel and a iwl3945 driver)

++++++++++++++++++++++++++++++++++++++++

This package (hostapd) is APPROVED by me

++++++++++++++++++++++++++++++++++++++++

--- Additional comment from adel.gadllah@gmail.com on 2009-12-21 03:27:48 EDT ---

(In reply to comment #15)
> I wasn't able to use hostapd with the nl80211 driver on Fedora 11, but
> everything went fine for Fedora 12 using an atheros hardware.
> (none work with intel and a iwl3945 driver)
> 
> ++++++++++++++++++++++++++++++++++++++++
> 
> This package (hostapd) is APPROVED by me
> 
> ++++++++++++++++++++++++++++++++++++++++  

Thanks for finally packing and reviewing this one ;)

As for the intel issue it is not supported at the driver side.

--- Additional comment from linville@redhat.com on 2009-12-21 09:00:04 EDT ---

New Package CVS Request
=======================
Package Name: hostapd
Short Description: IEEE 802.11 AP, IEEE 802.1X/WPA/WPA2/EAP/RADIUS Authenticator
Owners: linville
Branches: F-12
InitialCC: linville

--- Additional comment from kevin@tummy.com on 2009-12-21 14:40:44 EDT ---

cvs done.

Comment 1 Fedora Update System 2009-12-21 20:43:07 UTC
hostapd-0.6.9-6.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/hostapd-0.6.9-6.fc12

Comment 2 Fedora Update System 2009-12-24 20:35:45 UTC
hostapd-0.6.9-6.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.