Bug 54966 - Grub install screen enhancement
Grub install screen enhancement
Status: CLOSED DUPLICATE of bug 10645
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
Brock Organ
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-10-23 15:50 EDT by Jp Robinson
Modified: 2007-04-18 12:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-10-23 15:50:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jp Robinson 2001-10-23 15:50:13 EDT
Description of Problem:
When a SCSI card and a "Add-in ATA-66/100" card are installed (or onboard 
IDE-raid, IDE raid and SCSI yada yada) the system seems to think the IDE 
devices should always boot first, regardless if the bios really does this. 
(not to mention the bios order may be changed for systems with a scsi cd-
rom on a mainly ide system or vice versa)
The RFE is to simply allow the user to pick between MBR on A) first IDE 
drive B) first SCSI drive as well as leaving a choice for the first sector 
of the root/boot partition. That or possibly a "OTHER: <insert device 
here>" selection in expert mode.
Comment 1 Jeremy Katz 2001-10-23 16:20:38 EDT
Yep, reported for.  For what it's worth, I am working on this for the next release.

*** This bug has been marked as a duplicate of 10645 ***
Comment 2 Joe Krahn 2001-11-14 08:25:17 EST
I had the same problem. Here's my suggestions, for what it's worth: 
The option should be to install onto the MBR of any disk, since the boot disk
doesn't even have to be the first SCSI or first IDE. In the case of a dual-boot
system, it might even make to install to more than one MBR to be able to use at
least one OS in the event a disk fails. In both cases, it would be nice to have
a GUI for installing/editing the GRUB bootloader since we want to make it
newbie-friendly and because most people are new to GRUB. It's easy to do by
hand, but even some examples in the grub man or in /etc/grub.conf would be
helpful to be sure I'm doing it right.

Note You need to log in before you can comment on or make changes to this bug.