Bug 10645 - Can't choose SCSI MBR for LILO when ide drive installed
Can't choose SCSI MBR for LILO when ide drive installed
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
6.2
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Jeremy Katz
:
: 10388 54966 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-04-07 14:52 EDT by robert.nilsson
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-10-23 16:20:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description robert.nilsson 2000-04-07 14:52:43 EDT
When installing Red Hat v6.2 on Intel, It's not possible to choose the MBR
on the SCSI-disk for LILO. However, I can choose my IDE-disk wich I'm not
using as a "system" disk. Is this a bug? I solved it by simply unplugging
the IDE-disk during the installation phase and when it was all done, I
rebooted the PC and connected the disk again. It works fine now.
Comment 1 Michael Fulbright 2000-04-10 11:53:59 EDT
Traditionally PC hardware was unable to boot from the anything other than
what BIOS considered the first two drives, which normally are IDE. Newer
BIOS's remove this restriction as you may very well know.  It is under
consideration to remove this restriction in the installer as well in future
releases.
Comment 2 Jeff Norden 2000-04-12 19:56:59 EDT
Lilo is unfortunately still not very good at dealing with combined scsi/ide
setups.

It just blithely assumes the ide disk will be first.  If you just add an ide
disk to a previously scsi-only system (and your bios is smart enough to still
boot from the scsi disk), you are in for trouble.  The next time you type
'lilo', it prints the innocent sounding "Warning: /dev/sda is not on the first
disk", and then proceeds to totally f-up sda's boot sector (it be set to load
linux from the location on hda where the boot file on sda is actually located).
It will be a while before you successfully re-boot your system after you do
this.

I spent about 6 months doing what Robert did - disabling my ide disk every time
I ran lilo (this can be done by disabling onboard-ide in bios, so at least you
don't have to open the case).  I eventually discovered the correct way to handle
this situation, which is to put the two extra lines:
  disk=/dev/sda
  bios=0x80
into lilo.conf.  This tells lilo that sda really is the first disk.


I think it would be *really great* for the redhat installer to become smart
enough to do this.  Then others like Robert and myself won't have to suffer in
the future.  In fact, it wouldn't hurt to add those lines to the lilo.conf file
of any PC system which has only scsi disks in order to prevent problems later on
if ide disks are added.
Comment 3 Brock Organ 2000-04-28 09:48:59 EDT
jeff's notes on the lilo -v problem has been opened in a separate bug 11093...
Comment 4 Michael Fulbright 2000-09-15 15:47:18 EDT
*** Bug 10388 has been marked as a duplicate of this bug. ***
Comment 5 Michael Fulbright 2000-09-26 12:10:52 EDT
Moving to RESOVLED - DEFERRED from CLOSED - DEFERRED
Comment 6 Michael Fulbright 2000-09-26 12:56:34 EDT
Moving to RESOVLED - DEFERRED from CLOSED - DEFERRED
Comment 7 Jeremy Katz 2001-10-23 16:20:33 EDT
*** Bug 54966 has been marked as a duplicate of this bug. ***
Comment 8 Jeremy Katz 2002-01-21 19:33:15 EST
For future releases of Red Hat Linux, you will be able to reorder the boot
devices if you are using the GRUB boot loader

Note You need to log in before you can comment on or make changes to this bug.